Author Topic: 4.5.2 RC1 - Variables window shows no groupe titles, only black bars  (Read 5080 times)

Offline archer69

  • Full Member
  • ***
  • Posts: 249
    • View Profile
    • JH-Photography
Kirk,

In the 'Variables' window, the different variables are grouped with a title (the title name I guess is based on where in the metadata they variables of this groupe are located).

In the latest beta for Windows, if I open the 'Variables' window I don't get the groupe titles anymore, but only a black box.

Perhaps you can check that.
« Last Edit: July 31, 2007, 07:25:43 PM by archer69 »
Regards,
Juerg H.
www.jh-photography.net

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21661
    • View Profile
    • Camera Bits, Inc.
Re: 4.5.2 RC1 - Variables window shows no groupe titles, only black bars
« Reply #1 on: July 31, 2007, 08:00:02 PM »
Archer,

In the 'Variables' window, the different variables are grouped with a title (the title name I guess is based on where in the metadata they variables of this groupe are located).

In the latest beta for Windows, if I open the 'Variables' window I don't get the groupe titles anymore, but only a black box.

Perhaps you can check that.

What OS are you running?

-Kirk

Offline archer69

  • Full Member
  • ***
  • Posts: 249
    • View Profile
    • JH-Photography
Re: 4.5.2 RC1 - Variables window shows no groupe titles, only black bars
« Reply #2 on: July 31, 2007, 08:44:45 PM »
Kirk,

I'm using WinXP.
Regards,
Juerg H.
www.jh-photography.net

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21661
    • View Profile
    • Camera Bits, Inc.
Re: 4.5.2 RC1 - Variables window shows no groupe titles, only black bars
« Reply #3 on: July 31, 2007, 09:15:37 PM »
I'm using WinXP.

What video card and driver do you have?

-Kirk

Offline archer69

  • Full Member
  • ***
  • Posts: 249
    • View Profile
    • JH-Photography
Re: 4.5.2 RC1 - Variables window shows no groupe titles, only black bars
« Reply #4 on: July 31, 2007, 09:31:35 PM »
I believe it's a ATI card and driver.

But this is the same as before, and with previous versions of PM (including the last previous beta) I didn't have the problem.
Regards,
Juerg H.
www.jh-photography.net

Offline archer69

  • Full Member
  • ***
  • Posts: 249
    • View Profile
    • JH-Photography
Re: 4.5.2 RC1 - Variables window shows no groupe titles, only black bars
« Reply #5 on: July 31, 2007, 09:38:27 PM »
Just checked something:

On my laptop, the group title backgound is black and I assume the text is black as well. That's why I only see a black bar.
The video card is a NVidia.

On my workstation, the backgound is blue and the text is white.
The video card is a ATI.

I have no idea why the colors displayed are different?????
Regards,
Juerg H.
www.jh-photography.net

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21661
    • View Profile
    • Camera Bits, Inc.
Re: 4.5.2 RC1 - Variables window shows no groupe titles, only black bars
« Reply #6 on: July 31, 2007, 10:26:02 PM »
I believe it's a ATI card and driver.

But this is the same as before, and with previous versions of PM (including the last previous beta) I didn't have the problem.

Interesting.  Well, I haven't changed the custom drawing code in the Variables dialog in a couple of years so I would imagine that this is some sort of driver issue on your system.  I will look at the code and see if somehow it is depending on some sort of default behavior.

-Kirk

Offline jimb

  • Full Member
  • ***
  • Posts: 108
    • View Profile
Re: 4.5.2 RC1 - Variables window shows no groupe titles, only black bars
« Reply #7 on: August 01, 2007, 05:30:40 AM »
I also see this behavior on two different XP systems, and it seems like it has been present for a while (but I can't remember how long, sorry). Both systems have various Nvidia hardware.

I just checked it on PM 4.4.3.3 and it is also as described, so its been around a while. In fact, I assumed it was designed that way.

Jim

Offline archer69

  • Full Member
  • ***
  • Posts: 249
    • View Profile
    • JH-Photography
Update - Variables window shows no group titles, only black bars
« Reply #8 on: August 03, 2007, 06:56:30 PM »
Kirk,

Just as an update: I found out why on my laptop the variable group titles show only black bars.

It seems the title background and title text colors are the same as set in the Windows Diplay Preference > Appearance dialoge.

The Appearance settings on my laptop were:
Window and Buttons = Windows XP Style
Color Scheme = Silver (which defaults to black text for titles, and on top I changed the backgound color from default light grey to a very dark grey, almost black).

These settings in the PM Variable window show a dark grey (almost black) group title backgound with black group title text = I could only see a black bar.

The Appearance settings on my desktop are:
Window and Buttons = Windows XP Style
Color Scheme = Default Blue (which defaults to white text for titles and blue backgound color).

These settings in the PM Variable window shows a blue group title backgound with white group title text.

After setting the Appearance on my laptop to the same as on my destop, the problem was fixed (shows now a blue group title backgound with white group title text as well).

Just thought I give you an update so you don't spend any more time looking for a reason, and if someone else has the same problem you may be able to advise him what may cause the issue.

PS: I had changed the laptop settings about 3 or 4 weeks ago and not used PM a lot on it since, that's why I didn't notice an issue with previous PM versions.
« Last Edit: August 03, 2007, 07:16:38 PM by archer69 »
Regards,
Juerg H.
www.jh-photography.net

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21661
    • View Profile
    • Camera Bits, Inc.
Re: Update - Variables window shows no group titles, only black bars
« Reply #9 on: August 03, 2007, 08:54:26 PM »
Archer,

Just as an update: I found out why on my laptop the variable group titles show only black bars.

It seems the title background and title text colors are the same as set in the Windows Diplay Preference > Appearance dialoge.

The Appearance settings on my laptop were:
Window and Buttons = Windows XP Style
Color Scheme = Silver (which defaults to black text for titles, and on top I changed the backgound color from default light grey to a very dark grey, almost black).

These settings in the PM Variable window show a dark grey (almost black) group title backgound with black group title text = I could only see a black bar.

The Appearance settings on my desktop are:
Window and Buttons = Windows XP Style
Color Scheme = Default Blue (which defaults to white text for titles and blue backgound color).

These settings in the PM Variable window shows a blue group title backgound with white group title text.

After setting the Appearance on my laptop to the same as on my destop, the problem was fixed (shows now a blue group title backgound with white group title text as well).

Just thought I give you an update so you don't spend any more time looking for a reason, and if someone else has the same problem you may be able to advise him what may cause the issue.

PS: I had changed the laptop settings about 3 or 4 weeks ago and not used PM a lot on it since, that's why I didn't notice an issue with previous PM versions.

It won't be happening anymore.  I changed the rendering to use white text on a black background.

-Kirk

Offline archer69

  • Full Member
  • ***
  • Posts: 249
    • View Profile
    • JH-Photography
Re: 4.5.2 RC1 - Variables window shows no groupe titles, only black bars
« Reply #10 on: August 03, 2007, 11:30:39 PM »
Thanks Kirk.  ;D
Regards,
Juerg H.
www.jh-photography.net