Author Topic: 4.5.2 Problem with Capture NX and star rating/color label  (Read 4481 times)

Offline archer69

  • Full Member
  • ***
  • Posts: 249
    • View Profile
    • JH-Photography
4.5.2 Problem with Capture NX and star rating/color label
« on: August 12, 2007, 10:04:56 AM »
Kirk (and others using PM with Capture NX),

I upgraded Capture NX to version 1.2 on Thursday and then PM to version 4.5.2 yesterday, and have now the following problem (using Windows XP system):

I have PM set to use Capture NX for editing of NEF and JPEG files (color labeled purple). Usually I open the first file into NX, and when I'm done (either safing back as NEF or as TIFF), I close the file in NX, but leave NX running so it doesn't need to restart when I open the next file from within PM. I then change the color labels of the edited NEF's or JPG's from purple to yellow, and if a TIFF was created I change it from purple to green (just my way to keep track of which files are untouched, and which files were edited).

Since the update to 4.5.2, I cannot change the color labels (or star ratings for that matter) of files that I had openend during that session in Capture NX, even if it's not open anylonger in NX. I actually have to close NX completely to being able to do this. With the previous versions of PM I didn't have that problem. The workaround at the moment is to close NX completely after each file edit, which means I have to start the application and open the file for every new file edit, which slows down the whole process a lot (NX isn't a speed demon, as we already know).

Does PM somehow flag a file as being edited when I open it in a external editor? If so, it seems that the flag is not removed when the file is closed in the editor and remains locked.

The problem of course is that I updated both PM and Capture NX at almost the same time. Any help is appreciated.
« Last Edit: August 12, 2007, 10:07:24 AM by archer69 »
Regards,
Juerg H.
www.jh-photography.net

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21661
    • View Profile
    • Camera Bits, Inc.
Re: 4.5.2 Problem with Capture NX and star rating/color label
« Reply #1 on: August 12, 2007, 10:21:09 AM »
Kirk (and others using PM with Capture NX),

I upgraded Capture NX to version 1.2 on Thursday and then PM to version 4.5.2 yesterday, and have now the following problem (using Windows XP system):

I have PM set to use Capture NX for editing of NEF and JPEG files (color labeled purple). Usually I open the first file into NX, and when I'm done (either safing back as NEF or as TIFF), I close the file in NX, but leave NX running so it doesn't need to restart when I open the next file from within PM. I then change the color labels of the edited NEF's or JPG's from purple to yellow, and if a TIFF was created I change it from purple to green (just my way to keep track of which files are untouched, and which files were edited).

Since the update to 4.5.2, I cannot change the color labels (or star ratings for that matter) of files that I had openend during that session in Capture NX, even if it's not open anylonger in NX. I actually have to close NX completely to being able to do this. With the previous versions of PM I didn't have that problem. The workaround at the moment is to close NX completely after each file edit, which means I have to start the application and open the file for every new file edit, which slows down the whole process a lot (NX isn't a speed demon, as we already know).

Does PM somehow flag a file as being edited when I open it in a external editor? If so, it seems that the flag is not removed when the file is closed in the editor and remains locked.

No it doesn't flag it in any way.  Does NX have a lock on the file?  To test this, you can go to Windows Explorer and try to move the file to the Recycle Bin (do this as a test on a file you don't need) and if it fails to move to the Recycle Bin then NX must not be closing the file.

-Kirk

Offline archer69

  • Full Member
  • ***
  • Posts: 249
    • View Profile
    • JH-Photography
Re: 4.5.2 Problem with Capture NX and star rating/color label
« Reply #2 on: August 12, 2007, 05:53:57 PM »
Kirk,

There is really something strange going on with NX and PM.

1. NX does not lock the files either as I can delete and/or move them in both PM or explorer with NX still open (despite the fact that I can't change the labels/stars).
2. If I open other contact sheets (from earlier) and to the same (open from PM in NX and save as TIFF, then change color labe in PM while NX open) it works fine. Only with the folders I worked on since upgrading PM yesterday I seem to have problems.

Having that said, I did some more playing around just to find out what's going on. I used a out of camera JPEG file (with PM captions added yesterday).

1. Open JPEG from within PM in NX and save as TIFF -> can't change color label of original JPEG nor newly created TIFF in PM while NX is open.

2. Open same JPEG from withing PM in NX and save as NEF -> can't change color label of original JPEG, but CAN change label in newly created NEF while NX is open.

3. Open new NEF file in NX and save as TIFF -> can't change color label of JPEG or TIFF, but still can change label in NEF with NX open.

4. Now that I have a pair of original JPEG and new NEF file, I assumed that if I use the 'update IPTC/XMP' comand in PM it will update the JPEG to whatever the NEF is, but that doesn't work either. Acutally I got more than once a error message saying that a error occured during update (no matter whether NX was open or not). Other times it works, but the preview in PM of that file is gone. And again othertimes it works flawlessly.

I'm somehow at a loss here. I assume that NX is causing the problem, but then again I have problems with NX not open (but with files openend in NX and some created with NX).

I have no idea what to do.

Regards,
Juerg H.
www.jh-photography.net

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21661
    • View Profile
    • Camera Bits, Inc.
Re: 4.5.2 Problem with Capture NX and star rating/color label
« Reply #3 on: August 12, 2007, 07:57:05 PM »
Archer,

There is really something strange going on with NX and PM.

1. NX does not lock the files either as I can delete and/or move them in both PM or explorer with NX still open (despite the fact that I can't change the labels/stars).
2. If I open other contact sheets (from earlier) and to the same (open from PM in NX and save as TIFF, then change color labe in PM while NX open) it works fine. Only with the folders I worked on since upgrading PM yesterday I seem to have problems.

Having that said, I did some more playing around just to find out what's going on. I used a out of camera JPEG file (with PM captions added yesterday).

1. Open JPEG from within PM in NX and save as TIFF -> can't change color label of original JPEG nor newly created TIFF in PM while NX is open.

2. Open same JPEG from withing PM in NX and save as NEF -> can't change color label of original JPEG, but CAN change label in newly created NEF while NX is open.

3. Open new NEF file in NX and save as TIFF -> can't change color label of JPEG or TIFF, but still can change label in NEF with NX open.

4. Now that I have a pair of original JPEG and new NEF file, I assumed that if I use the 'update IPTC/XMP' comand in PM it will update the JPEG to whatever the NEF is, but that doesn't work either. Acutally I got more than once a error message saying that a error occured during update (no matter whether NX was open or not). Other times it works, but the preview in PM of that file is gone. And again othertimes it works flawlessly.

I'm somehow at a loss here. I assume that NX is causing the problem, but then again I have problems with NX not open (but with files openend in NX and some created with NX).

I have no idea what to do.

I suggest you send us some sample files so we can try to reproduce the problems locally.  Contact me privately for server upload information.

Thanks,

-Kirk

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2523
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: 4.5.2 Problem with Capture NX and star rating/color label
« Reply #4 on: August 13, 2007, 01:53:00 AM »
@Archer,

I too found some odd things going on where I sometimes got an error updating IPTC information (botfrom I file I edited in Capture NX.  Funny thing is though trying for a second time was always successful.  Have you tried this?

@Kirk,

Could it be that PM is caching information, tries to update and write back the cached info, sees it was changed under water, fails.  With the second try it had updated the cache with the newer info and succeeded?  Hmm, now I'm writing this, it doesn't sound logical as the thumbnails had already been updated, so it stands to reason any cached info would be too...

Note: it is very hard to get this reproduced (at least I haven't yet found a way, otherwise I would have reported it  :D); sometimes it happens but most of the times it doesn't...

Regards,
    Hayo
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline archer69

  • Full Member
  • ***
  • Posts: 249
    • View Profile
    • JH-Photography
Re: 4.5.2 Problem with Capture NX and star rating/color label
« Reply #5 on: August 13, 2007, 04:07:59 PM »
Hayo,

@Archer,

I too found some odd things going on where I sometimes got an error updating IPTC information (botfrom I file I edited in Capture NX.  Funny thing is though trying for a second time was always successful.  Have you tried this?
Yes, this happened to me too. While NX is running is running IPTC update doesn't work. But after I quite it mostley works, except for a few times. On top, there were also cases where the update worked, but the tumb view of the picture in the contact sheet disapeared and I had only a blank squeare there until I did Cntr+J to separate JPEG and RAW. It's very unpredictable.

Kirk,

Regarding changing labels while NX is running, I played a little more and had more than once the case that I tried to change a label several time without success for the same file, and then suddenly it worked once or twice, and then again it didn't work. Sometimes I had a feeling like there is a process/program part running on the computer while NX is open that prevents PM form performing the label function, but that this process sometimes pauses (or stops completely) for a short periode (a few seconds) before resuming. If you are lucky and use the label comand during this short time it works, and doesn't as soon as the process starts again.

One thing I knwo is that my computer got updated with a program called NetFrame from version 1 to version 2 while the NX software was updated. Copuld it be that PM somehow use that program or is not compatible with version 2?

PS: Can you send me the server upload information? I sent you some e-mails yesterday, but got the information the files where too large to be received.
« Last Edit: August 13, 2007, 04:10:32 PM by archer69 »
Regards,
Juerg H.
www.jh-photography.net

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21661
    • View Profile
    • Camera Bits, Inc.
Re: 4.5.2 Problem with Capture NX and star rating/color label
« Reply #6 on: August 13, 2007, 04:11:08 PM »
Archer,

One thing I knwo is that my computer got updated with a program called NetFrame from version 1 to version 2 while the NX software was updated. Copuld it be that PM somehow use that program or is not compatible with version 2?

I have never heard of NetFrame so I can guarantee that PM does not use it directly.

I received your sample images.  Please also send me screenshots of the IPTC/XMP tab and Files tab of the Photo Mechanic Preferences dialog.

Thanks,

-Kirk

Offline archer69

  • Full Member
  • ***
  • Posts: 249
    • View Profile
    • JH-Photography
Re: 4.5.2 Problem with Capture NX and star rating/color label
« Reply #7 on: August 13, 2007, 04:43:00 PM »
Archer,

One thing I knwo is that my computer got updated with a program called NetFrame from version 1 to version 2 while the NX software was updated. Copuld it be that PM somehow use that program or is not compatible with version 2?

I have never heard of NetFrame so I can guarantee that PM does not use it directly.

Sorry, it's .NET Framework, not NetFrame (I guess I just created a new software  ;D)

Quote
I received your sample images.  Please also send me screenshots of the IPTC/XMP tab and Files tab of the Photo Mechanic Preferences dialog.

Will send it tonight as soon as I'm home.

Thanks for your help.
Regards,
Juerg H.
www.jh-photography.net