Author Topic: 4.5.2 Update not installing  (Read 3240 times)

Offline Baneen

  • Newcomer
  • *
  • Posts: 8
    • View Profile
4.5.2 Update not installing
« on: September 03, 2007, 11:02:17 AM »
I have 4.5.0 and downloaded the 4.5.2 update but both the version on the exe and the about box both says 4.5.0. I've haven't had a problem to date with installing updates. Can anyone point me to a solution.

Thanks in advance.

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2523
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: 4.5.2 Update not installing
« Reply #1 on: September 03, 2007, 12:06:10 PM »
Check to see if you (accidentally) installed PM 4.5.2 into a separate directory and you are still clicking the 4.5 icon.

Assuming Windows: have a look in C:\Program Files\Camerabits, you'll probably find you both have a PM 4 and a PM 4.5 directory.

Hope this helps.
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21959
    • View Profile
    • Camera Bits, Inc.
Re: 4.5.2 Update not installing
« Reply #2 on: September 03, 2007, 01:50:53 PM »
I have 4.5.0 and downloaded the 4.5.2 update but both the version on the exe and the about box both says 4.5.0. I've haven't had a problem to date with installing updates. Can anyone point me to a solution.

The easiest thing to do is to uninstall Photo Mechanic until both versions are gone, and then install 4.5.2 again.

-Kirk

Offline Baneen

  • Newcomer
  • *
  • Posts: 8
    • View Profile
Re: 4.5.2 Update not installing
« Reply #3 on: September 04, 2007, 11:16:33 AM »
Check to see if you (accidentally) installed PM 4.5.2 into a separate directory and you are still clicking the 4.5 icon.

Assuming Windows: have a look in C:\Program Files\Camerabits, you'll probably find you both have a PM 4 and a PM 4.5 directory.

Hope this helps.

This is true ... how did that happen?

I will uninstall and reinstall 4.5.2.

Thanks.

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2523
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: 4.5.2 Update not installing
« Reply #4 on: September 04, 2007, 11:58:03 PM »
Check to see if you (accidentally) installed PM 4.5.2 into a separate directory and you are still clicking the 4.5 icon.

Assuming Windows: have a look in C:\Program Files\Camerabits, you'll probably find you both have a PM 4 and a PM 4.5 directory.

Hope this helps.

This is true ... how did that happen?

I will uninstall and reinstall 4.5.2.

Thanks.

When you install the software, it asks for the directory where to place PM in.  Between 4.5 and 4.5 I think this has changed.  So the install of 4.5.2 did not overwrite 4.5 as you'd expect. This resulted in both being still around.
I think uninstalling 4.5 would solve the problem too.  But to be on the safe side, remove all PM versions.
(remember to remove any files from the PM directory in "C:\Program Files" as well.

Cheers.
Hayo Baan - Photography
Web: www.hayobaan.nl