Author Topic: Default IPTC Encoding  (Read 14988 times)

Offline David_Hall

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Default IPTC Encoding
« on: September 05, 2007, 08:07:36 AM »
Can you please tell me what the default IPTC Encoding should be set at, in the Preferences> IPTC/XMP tab?
Mine has been set to Mac Roman and the write in Unicode is not checked.

I have started using PM PC version 4.5.2 to do my IPTC data for my Tiff files, however when I upload the images to my stock agent Corbis, they are rejecting the images do to errors in the IPTC data fields.

I was doing this in Photoshop CS before had no problems, and now with PM the info is showing up in the PS file info window all correct.

Thanks,
David Hall
« Last Edit: September 05, 2007, 08:22:21 AM by David_Hall »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23356
    • View Profile
    • Camera Bits, Inc.
Re: Default IPTC Encoding
« Reply #1 on: September 05, 2007, 09:13:46 AM »
Can you please tell me what the default IPTC Encoding should be set at, in the Preferences> IPTC/XMP tab?
Mine has been set to Mac Roman and the write in Unicode is not checked.

I have started using PM PC version 4.5.2 to do my IPTC data for my Tiff files, however when I upload the images to my stock agent Corbis, they are rejecting the images do to errors in the IPTC data fields.

I was doing this in Photoshop CS before had no problems, and now with PM the info is showing up in the PS file info window all correct.

Unless you're using accented characters, the encoding makes no difference.  What errors are Corbis reporting?  What OS are you running?

-Kirk

Offline David_Hall

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Default IPTC Encoding
« Reply #2 on: September 05, 2007, 09:39:37 AM »
Can you please tell me what the default IPTC Encoding should be set at, in the Preferences> IPTC/XMP tab?
Mine has been set to Mac Roman and the write in Unicode is not checked.

I have started using PM PC version 4.5.2 to do my IPTC data for my Tiff files, however when I upload the images to my stock agent Corbis, they are rejecting the images do to errors in the IPTC data fields.

I was doing this in Photoshop CS before had no problems, and now with PM the info is showing up in the PS file info window all correct.

Unless you're using accented characters, the encoding makes no difference.  What errors are Corbis reporting?  What OS are you running?

-Kirk


Hey Kirk,

I am running XP Pro.
The Default IPTC Encoding was set to ANSI and Write IPTC as Unicode is checked
Here is the latest error message from Corbis:

A failure was encountered processing an ingest file.  The following
information describes the context of the ingest, the failure message(s),
and the disposition of the ingest process.

The disposition of the Ingest Process is as follows:
Media record was not created.  The ingest file was moved to the Ingest
Error Directory
(\\NA00MEDAPP01\MEDAPPSHARE1\IngestProcess\Recovery\photo.inc.\youn
gadultsbeach_955.tif).

The following error message(s) were reported:
File ingested was invalid (msg='[[[Corrupted IFD block pointer []]]]').

MediaID: Media not created
Provider Submitted By: Photo, Inc.
Original Filename: YoungAdultsBeach_955.TIF File submission Date/Time:
9/5/2007 8:00:12 AM Upload Folder Submitted To: Photo.Inc.


The first message from Corbis, Default IPTC Encoding was set to Mac Roman, write as Unicode was not checked:

A failure was encountered processing an ingest file.  The following
information describes the context of the ingest, the failure message(s),
and the disposition of the ingest process.

The disposition of the Ingest Process is as follows:
Media record was not created.  The ingest file was moved to the Ingest
Error Directory
(\\NA00MEDAPP01\MEDAPPSHARE1\IngestProcess\Recovery\photo.inc.\medi
calstock_0201.tif).

The following error message(s) were reported:
An unexpected error occurred during the Ingest Process (msg='Extraction
of metadata (IPTC) from file failed (msg='Length cannot be less than
zero.
Parameter name: length').').

MediaID: Media not created
Provider Submitted By: Photo, Inc.
Original Filename: MedicalStock_0201.TIF File submission Date/Time:
9/5/2007 3:56:39 AM Upload Folder Submitted To: Photo.Inc.

Offline David_Hall

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Default IPTC Encoding
« Reply #3 on: September 05, 2007, 10:09:18 AM »
This is what is showing up in my Copyright Notice field in PS CS:

© Copyright Photo Inc/David P. Hall 2007

I am not putting that A symbol in there before the copyright notice, it's showing up after I make a change in PM's IPTC Info window.

I had Square symbols before the A, then I made a correction, now the A shows up.
I think this is what is throwing off Corbis' ingest process.


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23356
    • View Profile
    • Camera Bits, Inc.
Re: Default IPTC Encoding
« Reply #4 on: September 05, 2007, 11:18:49 AM »
This is what is showing up in my Copyright Notice field in PS CS:

© Copyright Photo Inc/David P. Hall 2007

I am not putting that A symbol in there before the copyright notice, it's showing up after I make a change in PM's IPTC Info window.

I had Square symbols before the A, then I made a correction, now the A shows up.
I think this is what is throwing off Corbis' ingest process.

That looks like possible Unicode (UTF-8) encoded data.  You'll need to turn off the Write IPTC as Unicode checkbox.  Since you're using the © symbol (it is out of the normal ASCII character set range), you'll need to find out what encoding Corbis is expecting to see.  It is likely to be "Microsoft Latin1+Euro", but you should check with them first.

-Kirk

Offline David_Hall

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Default IPTC Encoding
« Reply #5 on: September 05, 2007, 12:13:31 PM »
Should I set the IPTC to Microsoft Latin bla bla bla....what ever you wrote After checking with them.
« Last Edit: September 05, 2007, 12:15:29 PM by David_Hall »

Offline David_Hall

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Default IPTC Encoding
« Reply #6 on: September 05, 2007, 12:23:19 PM »
I think my problem has stemed from a cross platform situation.
When I'm shooting I'm ingesting through PM version 4.5.1.1 on my Mac Book Pro, and applying the Stationary pad info, such as copyright. My desktop is a PC and the PM version 4.5.2 there reads the copyright symbol as a question mark. If I add any additional IPTC info in PM on the PC, I get square symbols in the file info in PS. The square symbols show up between the existing PS info and the new info I've added with PM.
Have you heard of something like this before??

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23356
    • View Profile
    • Camera Bits, Inc.
Re: Default IPTC Encoding
« Reply #7 on: September 05, 2007, 03:51:45 PM »
David,

I think my problem has stemed from a cross platform situation.
When I'm shooting I'm ingesting through PM version 4.5.1.1 on my Mac Book Pro, and applying the Stationary pad info, such as copyright. My desktop is a PC and the PM version 4.5.2 there reads the copyright symbol as a question mark. If I add any additional IPTC info in PM on the PC, I get square symbols in the file info in PS. The square symbols show up between the existing PS info and the new info I've added with PM.
Have you heard of something like this before??

You'll need to make the encoding match on all systems that you're going to use with the same set of photos, or use Unicode which can contain nearly all known characters.  But you'll have to find out what Corbis wants the character set to be if you're going to send images to them using characters like © which can be in different locations in different character sets.

Before version 4.5, Photo Mechanic always used Mac Roman as the character set.  In 4.5 we give you a choice.  Mac Roman is still the default but you can change it to any encoding you like.

-Kirk

Offline David_Hall

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Default IPTC Encoding
« Reply #8 on: September 09, 2007, 05:48:10 AM »
Hey Kirk,

Thanks for the info.

What I'm finding on my PC (XP Pro SP2, PM 4.5.2) when I add info to the file, and I hit the space bar like you do when you type a sentence, I'm getting the the Square symbols showing up in my File Info in PS CS, where the spaces are.
PM IPTC default setting is at Mac Roman.

Any ideas??

Thanks

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2537
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: Default IPTC Encoding
« Reply #9 on: September 09, 2007, 06:02:37 AM »
With Windows, use the encoding Windows Latin1 +Euro.  Photoshop seems to like it better that way :)
(which is not really surprising as that is the default font encoding anyway)
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23356
    • View Profile
    • Camera Bits, Inc.
Re: Default IPTC Encoding
« Reply #10 on: September 09, 2007, 10:28:38 AM »
David,

What I'm finding on my PC (XP Pro SP2, PM 4.5.2) when I add info to the file, and I hit the space bar like you do when you type a sentence, I'm getting the the Square symbols showing up in my File Info in PS CS, where the spaces are.
PM IPTC default setting is at Mac Roman.

That's really strange.  The space character is the same in all character sets.  Can you send me a sample file?  Contact me directly by clicking on my name to the left of this message.  Send me a personal message.  I will respond with server upload info.

Thanks,

-Kirk

Offline David_Hall

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Default IPTC Encoding
« Reply #11 on: September 09, 2007, 05:28:29 PM »
Kirk,

My bad.....it's not the space bar, I meant to tell you it's the Enter key when I want to start a new line of info that is giving me the square symbols.
I'll shoot you a file if you still need it.

David,

What I'm finding on my PC (XP Pro SP2, PM 4.5.2) when I add info to the file, and I hit the space bar like you do when you type a sentence, I'm getting the the Square symbols showing up in my File Info in PS CS, where the spaces are.
PM IPTC default setting is at Mac Roman.

That's really strange.  The space character is the same in all character sets.  Can you send me a sample file?  Contact me directly by clicking on my name to the left of this message.  Send me a personal message.  I will respond with server upload info.

Thanks,

-Kirk


Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2537
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: Default IPTC Encoding
« Reply #12 on: September 10, 2007, 03:59:07 AM »
If on windows, set the encoding to Windows Latin1 +Euro.  That should help.
Furthermore, make sure you have the "Line ending" setting in the preferences set to "CR (Recommended)", and not to LF or CR/LF.

Hope this helps.
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline David_Hall

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Default IPTC Encoding
« Reply #13 on: September 10, 2007, 05:19:03 PM »
>>David,

Quote from: David_Hall on September 09, 2007, 05:30:07 PM
My bad.....it's not the space bar, I meant to tell you it's the Enter key when I want to start a new line of info that is giving me the square symbols.
I'll shoot you a file if you still need it.

Then it sounds like you need to change the line endings from CR to CR/LF.

If this solves your problem then please post the solution in the forums thread you originally posted in.

Thanks,

-Kirk<<<


Thanks for the help guys......I set the default IPTC to Microsoft Latin1+Euro and the line ending to CR/LF and it has solved the Square symbol problem from the Enter key......Now I'll have to see if I'm still crashing Corbis' FTP when I upload my files.

Offline archer69

  • Full Member
  • ***
  • Posts: 249
    • View Profile
    • JH-Photography
Re: Default IPTC Encoding
« Reply #14 on: September 13, 2007, 07:19:31 AM »
>>David,

Quote from: David_Hall on September 09, 2007, 05:30:07 PM
My bad.....it's not the space bar, I meant to tell you it's the Enter key when I want to start a new line of info that is giving me the square symbols.
I'll shoot you a file if you still need it.

Then it sounds like you need to change the line endings from CR to CR/LF.

If this solves your problem then please post the solution in the forums thread you originally posted in.

Thanks,

-Kirk<<<


Thanks for the help guys......I set the default IPTC to Microsoft Latin1+Euro and the line ending to CR/LF and it has solved the Square symbol problem from the Enter key......Now I'll have to see if I'm still crashing Corbis' FTP when I upload my files.

I have the the same that it shows a square as a line ending in Adobe Bridge (CS3) on a XP machine.

No matter what encoding I set with PM (Mac Roman or Microsoft Latin1+Euro and/or line ending CR or CR/LF) the square symbol does not disapear. Even it's not really doing harm (as far as I can see) it's just really anoying.
Regards,
Juerg H.
www.jh-photography.net