Author Topic: Strange IPTC problems  (Read 4721 times)

Offline nekken

  • Newcomer
  • *
  • Posts: 14
    • View Profile
Strange IPTC problems
« on: October 16, 2007, 09:04:11 AM »
Mac 10.3.9
Photo Mechanic 4.5.3 Beta 2 - it also happened trying 4.5.2 which is why I tried the Beta.

Initially I had an issue with saving usage and rights info to some files.  It would not stay after typing it in I did hit the save button.  Other IPTC info would work though.  I then opened the files in PhotoShop CS2 to try to put the info in there.

After entering the info in PhotoShop I could see it in PhotoShop when I closed and reopened the file.

I then viewed the files again in Photo Mechanic thinking everything would be ok but all the IPTC info was gone.

I then reopened the file in PhotoShop where the usage info was correct but all the other info was gone.

Any insight?

-Ken

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21938
    • View Profile
    • Camera Bits, Inc.
Re: Strange IPTC problems
« Reply #1 on: October 16, 2007, 09:13:14 AM »
Ken,

Mac 10.3.9
Photo Mechanic 4.5.3 Beta 2 - it also happened trying 4.5.2 which is why I tried the Beta.

Initially I had an issue with saving usage and rights info to some files.  It would not stay after typing it in I did hit the save button.  Other IPTC info would work though.  I then opened the files in PhotoShop CS2 to try to put the info in there.

After entering the info in PhotoShop I could see it in PhotoShop when I closed and reopened the file.

I then viewed the files again in Photo Mechanic thinking everything would be ok but all the IPTC info was gone.

I then reopened the file in PhotoShop where the usage info was correct but all the other info was gone.

Any insight?

Yes.  You need to change your IPTC/XMP preferences in Photo Mechanic to be a XMP-centric workflow.  Here are settings that work well with Adobe apps:



[attachment deleted by admin]

Offline nekken

  • Newcomer
  • *
  • Posts: 14
    • View Profile
Re: Strange IPTC problems
« Reply #2 on: October 16, 2007, 09:53:11 AM »
Those settings sort of worked, but I was able to modify them to get to see the data.  However the problem still exists with one file type.  If I try to input info into the rights and usage field of a Photoshop eps it won't stick.  I can add it PhotoShop but the info does not show up in Photo Mechanic.  The same thing happened with the settings above and the modified ones I used.

Offline nekken

  • Newcomer
  • *
  • Posts: 14
    • View Profile
Re: Strange IPTC problems
« Reply #3 on: October 16, 2007, 11:46:24 AM »
Another issue that has come up today with IPTC data is that once I get all the files correctly annotated, I upload them to PhotoShelter though Photo Mechanic.  Once the files are uploaded they sometime show erratic IPTC data.  Usually a set that I did not see in Photo Mechanic that is totally different from what I entered.

Is there a workflow that I can use that will give me consistent results.

We basically receive images from every source imaginable.  They are then annotated with IPTC data, or IPTC is added to information already there.  The files are then uploaded through Photo Mechanic to PhotoShelter.  What settings should I use to make sure what I see in Photo Mechanic is what shows up in PhotoShelter?


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21938
    • View Profile
    • Camera Bits, Inc.
Re: Strange IPTC problems
« Reply #4 on: October 16, 2007, 12:15:03 PM »
Those settings sort of worked, but I was able to modify them to get to see the data.  However the problem still exists with one file type.  If I try to input info into the rights and usage field of a Photoshop eps it won't stick.  I can add it PhotoShop but the info does not show up in Photo Mechanic.  The same thing happened with the settings above and the modified ones I used.

Is this an EPS-TIFF file?

-Kirk

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21938
    • View Profile
    • Camera Bits, Inc.
Re: Strange IPTC problems
« Reply #5 on: October 16, 2007, 12:19:48 PM »
Another issue that has come up today with IPTC data is that once I get all the files correctly annotated, I upload them to PhotoShelter though Photo Mechanic.  Once the files are uploaded they sometime show erratic IPTC data.  Usually a set that I did not see in Photo Mechanic that is totally different from what I entered.

Is there a workflow that I can use that will give me consistent results.

We basically receive images from every source imaginable.  They are then annotated with IPTC data, or IPTC is added to information already there.  The files are then uploaded through Photo Mechanic to PhotoShelter.  What settings should I use to make sure what I see in Photo Mechanic is what shows up in PhotoShelter?

I don't know what PhotoShelter prefers: IPTC or XMP, or even some EXIF tags like the Description tag.  But some of the fields you mentioned like the IPTC Scene can only be represented in XMP.  Since you have no control over what kind of metadata was entered previously, this may be a hard one to solve.

I would start with asking the PhotoShelter folks if they support IPTC4XMP and whether there is any setting to prefer IPTC4XMP over legacy IPTC data.  If so, then you should be able to take a group of images and use the IPTC Stationery Pad to apply some simple change to an unused field which will cause IPTC4XMP to be added (or updated if it already existed) and then upload to PhotoShelter.

HTH,

-Kirk

Offline nekken

  • Newcomer
  • *
  • Posts: 14
    • View Profile
Re: Strange IPTC problems
« Reply #6 on: October 16, 2007, 12:59:27 PM »
ok, I'll give them a try and update you when I here back.

Offline nekken

  • Newcomer
  • *
  • Posts: 14
    • View Profile
Re: Strange IPTC problems
« Reply #7 on: October 18, 2007, 09:42:30 AM »
UPDATE:
PhotoShelter dose support  IPTC4XMP.  It seems that the issue of a different set of IPTC info showing up only appears in certain files.  Basically there are some files that I can change the IPTC in Photo Mechanic and it updates, uploads and  shows fine.  In other files it updates in Photo Mechanic but refuses to display in other programs.  The other programs show another set of IPTC that did not show in Photo Mechanic to begin with.

I can send you a file if you want to take a look at one. 

Thanks,
Ken

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21938
    • View Profile
    • Camera Bits, Inc.
Re: Strange IPTC problems
« Reply #8 on: October 18, 2007, 09:49:09 AM »
Ken,

UPDATE:
PhotoShelter dose support  IPTC4XMP.  It seems that the issue of a different set of IPTC info showing up only appears in certain files.  Basically there are some files that I can change the IPTC in Photo Mechanic and it updates, uploads and  shows fine.  In other files it updates in Photo Mechanic but refuses to display in other programs.  The other programs show another set of IPTC that did not show in Photo Mechanic to begin with.

OK, then you can use the Update IPTC/XMP command on the Tools menu to make your images consistent (according to your read/write IPTC/XMP preferences.)  Or you can use the "Mask/Unmask" command on the Tools menu to Mask (temporarily hide) the IPTC data from all apps (you can unmask it later if you wish.)

-Kirk

Offline nekken

  • Newcomer
  • *
  • Posts: 14
    • View Profile
Re: Strange IPTC problems
« Reply #9 on: October 23, 2007, 11:01:17 AM »
Second Update:

I'm still struggling with some of these files.  I have opened the image on several computers with Photo Mechanic and they all show the same IPTC data.  I reinput the metadata with the settings you gave me. 

However, Photoshop, PhotoShelter and iView all show different metadata in the file.  Any suggestions?

Ken

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21938
    • View Profile
    • Camera Bits, Inc.
Re: Strange IPTC problems
« Reply #10 on: October 23, 2007, 11:23:20 AM »
Ken,

Second Update:

I'm still struggling with some of these files.  I have opened the image on several computers with Photo Mechanic and they all show the same IPTC data.  I reinput the metadata with the settings you gave me. 

However, Photoshop, PhotoShelter and iView all show different metadata in the file.  Any suggestions?

Can you list specific fields that aren't working, and what information PM is showing and what the other apps are showing for the same fields?

Also, could you upload a sample file for me to look at?  Contact me directly by clicking on my name to the left of this message and send me a "personal message".  I will respond with server upload information.

-Kirk

Offline nekken

  • Newcomer
  • *
  • Posts: 14
    • View Profile
Re: Strange IPTC problems
« Reply #11 on: October 23, 2007, 12:08:00 PM »
It doesn't seem to be restricted to any particular field.  I'll upload the file to you, but here are screen shots from Photo Mechanic and PhotoShelter.



[attachment deleted by admin]