Author Topic: PM Freeze on SD card ingest  (Read 2337 times)

Offline nevetsokyeron

  • Newcomer
  • *
  • Posts: 10
    • View Profile
    • steven noreyko :: photographer
PM Freeze on SD card ingest
« on: December 30, 2007, 01:23:26 PM »
Using PhotoMechanic 4.5.2 and 4.5.3 on MacOS 10.4.11

I'm experiencing a freeze when ingesting jpg images from an 2GB SD card (Sandisk Extreme III with Sandisk MicroMate reader). SD card is being used in a Canon Powershot SD870is

The problem appears to be intermittent, but here's what's happening.

- Start ingest of card
- Ingest progress bar gets to some point and the status stops updating.  It still says "Copying..." but the progress bar is stopped.
- If I "abort" the copy at this point it shows the task as aborted, but then PM is completely frozen and will not do anything.  It also appears to lock out the Memory Card so I'm unable to eject it from the Finder. Force Quitting PM at this point doesnt really work. Everything continues to be locked up.
- Force quitting PM before hitting abort seems to quit PM, but on restarting PM, its locked up - "application not responding". Also this appears to dismount the Memory card (icon is no longer on desktop), but on removing it, the Finder complains that it was still mounted.

In either case I have to reboot or at least logout/login to get things back to normal.

Note - no data in crash log.

Note -  Doing a direct Finder Copy of the images from the memory card seems to work fine. Although I think one time it also locked up the Finder (not reproducible so far). 

Obviously something is going wrong with Photo Mechanic here - but could this also be due to something wonky on the SD card (bad sectors??) ?  Wondering if I need to send it back to Sandisk under warranty?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24277
    • View Profile
    • Camera Bits, Inc.
Re: PM Freeze on SD card ingest
« Reply #1 on: December 30, 2007, 09:21:59 PM »
Steve,

Using PhotoMechanic 4.5.2 and 4.5.3 on MacOS 10.4.11

I'm experiencing a freeze when ingesting jpg images from an 2GB SD card (Sandisk Extreme III with Sandisk MicroMate reader). SD card is being used in a Canon Powershot SD870is

The problem appears to be intermittent, but here's what's happening.

- Start ingest of card
- Ingest progress bar gets to some point and the status stops updating.  It still says "Copying..." but the progress bar is stopped.
- If I "abort" the copy at this point it shows the task as aborted, but then PM is completely frozen and will not do anything.  It also appears to lock out the Memory Card so I'm unable to eject it from the Finder. Force Quitting PM at this point doesnt really work. Everything continues to be locked up.
- Force quitting PM before hitting abort seems to quit PM, but on restarting PM, its locked up - "application not responding". Also this appears to dismount the Memory card (icon is no longer on desktop), but on removing it, the Finder complains that it was still mounted.

In either case I have to reboot or at least logout/login to get things back to normal.

Note - no data in crash log.

Note -  Doing a direct Finder Copy of the images from the memory card seems to work fine. Although I think one time it also locked up the Finder (not reproducible so far). 

Obviously something is going wrong with Photo Mechanic here - but could this also be due to something wonky on the SD card (bad sectors??) ?  Wondering if I need to send it back to Sandisk under warranty?

I don't know why it would do that.  Photo Mechanic uses the filesystem to read the card so if we make a call out to read data and it never returns to us then it would indeed lock up Photo Mechanic.

If I had to guess, then I would say that there is probably something peculiar about either the card or the reader.

-Kirk