Author Topic: Adjust capture time, then sort by capture time not working...  (Read 3062 times)

Offline JerryL

  • Newcomer
  • *
  • Posts: 16
    • View Profile
Hi all.

I have about 3000 images from two cameras taken at an event today.  At the beginning each camera took a "sync-up" shot at the exact same moment, thereby establishing the time difference between them (2 minutes, 53 seconds).

For all the files from Camera B, I did a relative adjustment of +2:53 via PM 4.43 to synchronize all files.  I then moved the files from both cameras into a common folder.

HOWEVER...

Opening the folder in PM, ensuring that it's sorting by capture time is not collating the files as expected.

Image 6 which shows a capture time (according to PM) of 7:59:43 a.m.  Image 7 is 2 seconds later, etc.  Image 43, from the 2nd camera, also shows a capture time (according to PM) of 7:59:43 a.m.  Image 42, from the first camera shows a capture time of 8:07:32.

The problem is that Image 6 and Image 43 SHOULD be side by side, when sorted by capture time.  Instead there is a large number of other files from the first camera in-between.

The capture times do NOT run sequentially for the files, even though PM says they are sorted by capture time.  I deleted the thumbs cache, rebooted the machine, burnt incense, but nothing has helped.  None of the files are write-protected, etc.

Sorting by filename does work, sorting by modification time appears to work, but capture is hosed.

Help...

jerry

Offline JerryL

  • Newcomer
  • *
  • Posts: 16
    • View Profile
Re: Adjust capture time, then sort by capture time not working...
« Reply #1 on: June 17, 2006, 07:21:07 PM »
Two add'l comments...

1. This is on WinXP, most current version, most current updates
2. This appears specific to one of our two production machines.  I happened to use the 2nd machine to do the work on; adjusting the capture time on files for other projects - on the 1st machine - has worked just fine.  Both machines have the same version of PM, so I'm pretty clueless on what's up here...

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20251
    • View Profile
    • Camera Bits, Inc.
Re: Adjust capture time, then sort by capture time not working...
« Reply #2 on: June 18, 2006, 12:00:22 AM »
I have about 3000 images from two cameras taken at an event today.  At the beginning each camera took a "sync-up" shot at the exact same moment, thereby establishing the time difference between them (2 minutes, 53 seconds).

For all the files from Camera B, I did a relative adjustment of +2:53 via PM 4.43 to synchronize all files.  I then moved the files from both cameras into a common folder.

HOWEVER...

Opening the folder in PM, ensuring that it's sorting by capture time is not collating the files as expected.

Image 6 which shows a capture time (according to PM) of 7:59:43 a.m.  Image 7 is 2 seconds later, etc.  Image 43, from the 2nd camera, also shows a capture time (according to PM) of 7:59:43 a.m.  Image 42, from the first camera shows a capture time of 8:07:32.

The problem is that Image 6 and Image 43 SHOULD be side by side, when sorted by capture time.  Instead there is a large number of other files from the first camera in-between.

The capture times do NOT run sequentially for the files, even though PM says they are sorted by capture time.  I deleted the thumbs cache, rebooted the machine, burnt incense, but nothing has helped.  None of the files are write-protected, etc.

Sorting by filename does work, sorting by modification time appears to work, but capture is hosed.

Could you zip up a set of files that exhibits this problem and upload it to us?  Contact me privately for server info.

-Kirk