Author Topic: Star rating no longer transferring consistently to Expression Media  (Read 8317 times)

Offline drmrbrewer

  • Full Member
  • ***
  • Posts: 122
    • View Profile
PM 4.5.3.1 on Windows Vista Ultimate.

My star ratings applied in PM are no longer visible consistently in Expression Media.  Sometimes they appear, sometimes not.  Can't yet work out a pattern.  However, I'm pretty sure that, where the rating is not visible in EM, it's on a NEF saved with the new Capture NX 2.  Even then, it's not *all* NX2 files that exhibit this.  I can't think of any other update I've applied recently.

Screenshots of my preferences are attached.

Has anyone else seen this?

Thanks,

Mike


[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20397
    • View Profile
    • Camera Bits, Inc.
Re: Star rating no longer transferring consistently to Expression Media
« Reply #1 on: June 10, 2008, 03:32:45 PM »
Mike,

PM 4.5.3.1 on Windows Vista Ultimate.

My star ratings applied in PM are no longer visible consistently in Expression Media.  Sometimes they appear, sometimes not.  Can't yet work out a pattern.  However, I'm pretty sure that, where the rating is not visible in EM, it's on a NEF saved with the new Capture NX 2.  Even then, it's not *all* NX2 files that exhibit this.  I can't think of any other update I've applied recently.

Screenshots of my preferences are attached.

Has anyone else seen this?

We're looking into this issue right now.  I'll let you know what we find out.

-Kirk


Offline drmrbrewer

  • Full Member
  • ***
  • Posts: 122
    • View Profile
Re: Star rating no longer transferring consistently to Expression Media
« Reply #2 on: June 11, 2008, 01:26:11 AM »
Kirk,

This issue is odd, because I had assumed that my settings for RAW files meant that I was transferring stuff using XMP sidecars, which would be independent of whether the NEFs are saved using NX1, NX2 or whatever?

However, I also had an instance yesterday where I rated a bunch of jpegs in PM, and later viewed those jpegs in PM only to find that the ratings had vanished.  I had assumed, in this case, that the ratings are written directly into the files at the time of rating, so I'm surprised that this could happen.  If I can ever repeat this, I'll let you know (although I don't shoot jpegs that often).

Mike

Offline iau

  • Newcomer
  • *
  • Posts: 29
    • View Profile
Re: Star rating no longer transferring consistently to Expression Media
« Reply #3 on: June 14, 2008, 01:20:21 PM »
There is an issue with EM2 not reading xmp-data from more than 4 files in a folder. Could this be the reason? Only my ratings for the first four files in a folder is transfered to EM2.

- iau

Offline drmrbrewer

  • Full Member
  • ***
  • Posts: 122
    • View Profile
Re: Star rating no longer transferring consistently to Expression Media
« Reply #4 on: June 15, 2008, 12:33:13 PM »
iau: I'm still using EM1 (EM2 broke my scripts, so I'm not in a hurry to upgrade).

Kirk: is this a known issue?  By that I mean you can replicate it your side?  It's a bit like playing Russian Roulette at the moment with my star ratings, and a bit frustrating as a result.

Thanks,

Mike

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20397
    • View Profile
    • Camera Bits, Inc.
Re: Star rating no longer transferring consistently to Expression Media
« Reply #5 on: June 15, 2008, 01:58:42 PM »
Mike,

iau: I'm still using EM1 (EM2 broke my scripts, so I'm not in a hurry to upgrade).

Kirk: is this a known issue?  By that I mean you can replicate it your side?  It's a bit like playing Russian Roulette at the moment with my star ratings, and a bit frustrating as a result.

Not as of yet, but we have other reports from users to look into.

-Kirk


Offline drmrbrewer

  • Full Member
  • ***
  • Posts: 122
    • View Profile
Re: Star rating no longer transferring consistently to Expression Media
« Reply #6 on: June 16, 2008, 12:33:12 PM »
In the last batch I did, some (but not all) 3-star ratings were being lost, while none of the 1- and 2-star ratings was affected.

Mike

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20397
    • View Profile
    • Camera Bits, Inc.
Re: Star rating no longer transferring consistently to Expression Media
« Reply #7 on: June 20, 2008, 06:03:16 PM »
Mike,

PM 4.5.3.1 on Windows Vista Ultimate.

My star ratings applied in PM are no longer visible consistently in Expression Media.  Sometimes they appear, sometimes not.  Can't yet work out a pattern.  However, I'm pretty sure that, where the rating is not visible in EM, it's on a NEF saved with the new Capture NX 2.  Even then, it's not *all* NX2 files that exhibit this.  I can't think of any other update I've applied recently.

Here is what I think is going on.  Capture NX2 now puts XMP data into NEF files.  It also happens to ignore XMP sidecar files.  So when the XMP data is created inside the NEF file by NX2, it doesn't retain your current Color Class or Rating.

On the EM side, I think what must be going on is that EM is preferring the embedded XMP data from the NEF and is therefore ignoring the XMP sidecar file.

Files that appear to work for you have likely not been adjusted in NX2 and so they work in EM.

I think the solution would be to abandon the use of XMP sidecar files and instruct PM to embed IPTC4XMP into your TIFF-based RAW files (NEFs).  Ratings should then be consistently picked up by EM when importing.

After that, you'll find that Color Classes won't always work if NX2 is used to change the color label since it likes to use the IPTC Urgency field as an index for the color label.  We are working on a solution to this to synchronize the Color Class and IPTC Urgency field in PM.

I know that in the past iView Media Pro used the IPTC Urgency field to index its color labels.  EM may have carried this tradition forward as well.

I would like for you to test a beta when I get it ready.  I will contact you directly when it is available.

-Kirk

« Last Edit: June 20, 2008, 06:05:47 PM by Kirk Baker »

Offline drmrbrewer

  • Full Member
  • ***
  • Posts: 122
    • View Profile
Re: Star rating no longer transferring consistently to Expression Media
« Reply #8 on: June 21, 2008, 02:25:12 AM »
Hi Kirk,

I'd be happy to help with the beta.

I've done a bit more playing, based on what you're saying about XMP data now being created by NX2 inside the NEF.  What had been troubling me is that *all* NEFs in my folder had been edited by NX2, and yet only a subset of those were not transferring star ratings across to EM.  I'd expect it to be all or nothing.

However, I believe that this may be due to the fact that I actually directly edit (open, tweak, save and close) only a small selection of NEFs from a shoot, and then copy settings across to other NEFs in a batch process.

So I reckon that NX2 is embedding star rating XMP data (at the 0 star level because it doesn't read my PM-created XMP sidecars) into those NEFs I *directly* edit.  For the batch process applied to the rest, NX2 does not embed any star rating XMP data into the NEF, so many (most) of my NEFs have no embedded star ratings from NX2.

When importing into EM, I guess that EM is reading embedded XMP star ratings in preference to sidecar XMP ratings, and so will always prefer what NX2 has put in -- at the 0 star level, making it appear as if my ratings are vanishing.

For those NEFs that have only been *batched* by NX2, rather than directly edited, there is no embedded XMP rating, so EM will happily look at what PM has put into the sidecar.

I haven't fully tested this, but it seems at least faintly plausible.

I guess there is now no option but to do as you say, and get PM to embed data into the NEF rather than use sidecars (since I can't see a way to force EM to read sidecars above embedded).  Unless your beta will change things...

Mike

Offline drmrbrewer

  • Full Member
  • ***
  • Posts: 122
    • View Profile
Re: Star rating no longer transferring consistently to Expression Media
« Reply #9 on: June 21, 2008, 09:32:57 AM »
I think the solution would be to abandon the use of XMP sidecar files and instruct PM to embed IPTC4XMP into your TIFF-based RAW files (NEFs).  Ratings should then be consistently picked up by EM when importing.

So, would that be the same as the suggestion for NX in the PM manual, but with the "Add Embedded IPTC4XMP" box also ticked (unlike in the manual)?

Thanks,

Mike

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20397
    • View Profile
    • Camera Bits, Inc.
Re: Star rating no longer transferring consistently to Expression Media
« Reply #10 on: June 21, 2008, 10:39:48 AM »
Mike,

I think the solution would be to abandon the use of XMP sidecar files and instruct PM to embed IPTC4XMP into your TIFF-based RAW files (NEFs).  Ratings should then be consistently picked up by EM when importing.

So, would that be the same as the suggestion for NX in the PM manual, but with the "Add Embedded IPTC4XMP" box also ticked (unlike in the manual)?

Yes, but I don't see any real reason when using Capture NX2 to embed IPTC data anymore, unless your clients need it.  So you could uncheck the "Add embedded IPTC" checkbox.

-Kirk


Offline archer69

  • Full Member
  • ***
  • Posts: 249
    • View Profile
    • JH-Photography
Re: Star rating no longer transferring consistently to Expression Media
« Reply #11 on: June 29, 2008, 10:21:26 AM »
Kirk,

Mike,

I think the solution would be to abandon the use of XMP sidecar files and instruct PM to embed IPTC4XMP into your TIFF-based RAW files (NEFs).  Ratings should then be consistently picked up by EM when importing.

So, would that be the same as the suggestion for NX in the PM manual, but with the "Add Embedded IPTC4XMP" box also ticked (unlike in the manual)?

Yes, but I don't see any real reason when using Capture NX2 to embed IPTC data anymore, unless your clients need it.  So you could uncheck the "Add embedded IPTC" checkbox.

-Kirk



I just upgraded to NX2 and ran into the problem of Labels AND Star rantings going lost. It worked perfectly for my PM -> Capture NX -> CS3 work flow. But now no more. If I open a NEF file in NX2, make adjustments and save it back, it retains the PM labels and star ratings. But if I save it from NX2 as TIFF or JPEG, the labels and ratings are gone.

I have PM 'write' options set to:
- JPEG's etc: "Add both IPTC and IPTC4XMP"
- TIFF based RAW: "Add embedded IPTC" plus "Always create and/or update XMP sidecar files with IPTC4XMP"

For the PM 'read' options I have:
- JPEG's etc: "Read embedded XMP before IPTC"
- TIFF based RAW: "Read XMP sidecar files" before "Read embedded XMP" before "Read embedded IPTC"

These were based on your recommendations because Adobe reads embedded XMP before XMP sidecar files, but only writes to XMP sidecar files.

Now, with your proposal to embed XMP always and not use XMP sidecar files, the whole thing may work with PM and NX2, but not with CS3.

Or do I miss something?
Juerg
« Last Edit: June 29, 2008, 02:32:49 PM by archer69 »
Regards,
Juerg H.
www.jh-photography.net

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20397
    • View Profile
    • Camera Bits, Inc.
Re: Star rating no longer transferring consistently to Expression Media
« Reply #12 on: June 29, 2008, 03:45:18 PM »
Juerg,

I think the solution would be to abandon the use of XMP sidecar files and instruct PM to embed IPTC4XMP into your TIFF-based RAW files (NEFs).  Ratings should then be consistently picked up by EM when importing.

So, would that be the same as the suggestion for NX in the PM manual, but with the "Add Embedded IPTC4XMP" box also ticked (unlike in the manual)?

Yes, but I don't see any real reason when using Capture NX2 to embed IPTC data anymore, unless your clients need it.  So you could uncheck the "Add embedded IPTC" checkbox.

-Kirk



I just upgraded to NX2 and ran into the problem of Labels AND Star rantings going lost. It worked perfectly for my PM -> Capture NX -> CS3 work flow. But now no more. If I open a NEF file in NX2, make adjustments and save it back, it retains the PM labels and star ratings. But if I save it from NX2 as TIFF or JPEG, the labels and ratings are gone.

I have PM 'write' options set to:
- JPEG's etc: "Add both IPTC and IPTC4XMP"
- TIFF based RAW: "Add embedded IPTC" plus "Always create and/or update XMP sidecar files with IPTC4XMP"

For the PM 'read' options I have:
- JPEG's etc: "Read embedded XMP before IPTC"
- TIFF based RAW: "Read XMP sidecar files" before "Read embedded XMP" before "Read embedded IPTC"

These were based on your recommendations because Adobe reads embedded XMP before XMP sidecar files, but only writes to XMP sidecar files.

Now, with your proposal to embed XMP always and not use XMP sidecar files, the whole thing may work with PM and NX2, but not with CS3.

Or do I miss something?

No, you're not missing something.  The way Capture NX2 works only with embedded XMP makes it quite difficult to also work with Adobe products.  It would be nice if Capture NX2 would add an option to work with XMP sidecar files and have an option to not embed XMP into NEF files.

-Kirk


Offline archer69

  • Full Member
  • ***
  • Posts: 249
    • View Profile
    • JH-Photography
Re: Star rating no longer transferring consistently to Expression Media
« Reply #13 on: June 29, 2008, 04:10:49 PM »
Kirk,

Juerg,

I just upgraded to NX2 and ran into the problem of Labels AND Star rantings going lost. It worked perfectly for my PM -> Capture NX -> CS3 work flow. But now no more. If I open a NEF file in NX2, make adjustments and save it back, it retains the PM labels and star ratings. But if I save it from NX2 as TIFF or JPEG, the labels and ratings are gone.

I have PM 'write' options set to:
- JPEG's etc: "Add both IPTC and IPTC4XMP"
- TIFF based RAW: "Add embedded IPTC" plus "Always create and/or update XMP sidecar files with IPTC4XMP"

For the PM 'read' options I have:
- JPEG's etc: "Read embedded XMP before IPTC"
- TIFF based RAW: "Read XMP sidecar files" before "Read embedded XMP" before "Read embedded IPTC"

These were based on your recommendations because Adobe reads embedded XMP before XMP sidecar files, but only writes to XMP sidecar files.

Now, with your proposal to embed XMP always and not use XMP sidecar files, the whole thing may work with PM and NX2, but not with CS3.

Or do I miss something?

No, you're not missing something.  The way Capture NX2 works only with embedded XMP makes it quite difficult to also work with Adobe products.  It would be nice if Capture NX2 would add an option to work with XMP sidecar files and have an option to not embed XMP into NEF files.

-Kirk



Thanks. I was afraid that was the answer. Now, is there any way to change that and make it work. Or should I just forget Adobe Bridge at all (that's where the issue comes up, but I guess it will come up for others that use Light room as well)?

And if I now suddenly have to embed IPTC4XMP, will that in the future mess up something else? Or if I set PM to both embed XMP and create/update XMP sidecar files, what happens then. How will PM then handle a file that suddenly has a different sidecar file, will it automatically update the embedded info and vica versa?

I guess for the time being I stick with NX1 and send a e-mail to Nikon support, even I don't think they care. Unfortunately they have quite an attitude in that regard.

And sorry to all the others, I wasn't my intent to hijack a thread concerning EM with my Adobe issues.

Juerg
Regards,
Juerg H.
www.jh-photography.net

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20397
    • View Profile
    • Camera Bits, Inc.
Re: Star rating no longer transferring consistently to Expression Media
« Reply #14 on: June 29, 2008, 06:08:24 PM »
Juerg,

I just upgraded to NX2 and ran into the problem of Labels AND Star rantings going lost. It worked perfectly for my PM -> Capture NX -> CS3 work flow. But now no more. If I open a NEF file in NX2, make adjustments and save it back, it retains the PM labels and star ratings. But if I save it from NX2 as TIFF or JPEG, the labels and ratings are gone.

I have PM 'write' options set to:
- JPEG's etc: "Add both IPTC and IPTC4XMP"
- TIFF based RAW: "Add embedded IPTC" plus "Always create and/or update XMP sidecar files with IPTC4XMP"

For the PM 'read' options I have:
- JPEG's etc: "Read embedded XMP before IPTC"
- TIFF based RAW: "Read XMP sidecar files" before "Read embedded XMP" before "Read embedded IPTC"

These were based on your recommendations because Adobe reads embedded XMP before XMP sidecar files, but only writes to XMP sidecar files.

Now, with your proposal to embed XMP always and not use XMP sidecar files, the whole thing may work with PM and NX2, but not with CS3.

Or do I miss something?

No, you're not missing something.  The way Capture NX2 works only with embedded XMP makes it quite difficult to also work with Adobe products.  It would be nice if Capture NX2 would add an option to work with XMP sidecar files and have an option to not embed XMP into NEF files.

-Kirk



Thanks. I was afraid that was the answer. Now, is there any way to change that and make it work. Or should I just forget Adobe Bridge at all (that's where the issue comes up, but I guess it will come up for others that use Light room as well)?

And if I now suddenly have to embed IPTC4XMP, will that in the future mess up something else? Or if I set PM to both embed XMP and create/update XMP sidecar files, what happens then. How will PM then handle a file that suddenly has a different sidecar file, will it automatically update the embedded info and vica versa?

I guess for the time being I stick with NX1 and send a e-mail to Nikon support, even I don't think they care. Unfortunately they have quite an attitude in that regard.

Embedding XMP and using XMP sidecar files as well won't solve the issue with Adobe's products.  The solution would be for either Adobe to completely ignore embedded XMP when sidecar files are present, or for Nikon Capture NX2 to have an option to work only with XMP sidecar files.

Either change would solve the issue.

-Kirk