Author Topic: D300 download problem  (Read 2266 times)

Offline ehanauer

  • Newcomer
  • *
  • Posts: 2
    • View Profile
D300 download problem
« on: June 30, 2008, 01:30:08 PM »
PM doesn't recognize my Nikon D300.  I am able to ingest images with Image Capture and with Lightroom, but not with Photo Mechanic.

Macintosh G5, system 10.5.3
Photo Mechanic 4.5.3.1

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20525
    • View Profile
    • Camera Bits, Inc.
Re: D300 download problem
« Reply #1 on: June 30, 2008, 01:36:44 PM »
PM doesn't recognize my Nikon D300.  I am able to ingest images with Image Capture and with Lightroom, but not with Photo Mechanic.

Macintosh G5, system 10.5.3
Photo Mechanic 4.5.3.1

Are you directly connecting your camera to your computer or are you using a card reader?  Does the camera disk show up as a disk in the Finder?  Photo Mechanic needs for there to be a disk mounted in order to ingest from it.

-Kirk


Offline ehanauer

  • Newcomer
  • *
  • Posts: 2
    • View Profile
Re: D300 download problem
« Reply #2 on: June 30, 2008, 04:13:34 PM »
Camera is directly connected to the computer but doesn't show on the desktop.  Still, it's being read in Image Capture and in Lightroom, just not in PM. 

It does read it when it's on a card reader, but not when I connect the camera.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20525
    • View Profile
    • Camera Bits, Inc.
Re: D300 download problem
« Reply #3 on: June 30, 2008, 06:37:04 PM »
Camera is directly connected to the computer but doesn't show on the desktop.  Still, it's being read in Image Capture and in Lightroom, just not in PM. 

It does read it when it's on a card reader, but not when I connect the camera.

I suggest just using the card reader you've got.  They're more reliable than a camera connection anyway.

-Kirk