Author Topic: "Scanning Source Paths" - hanging  (Read 13889 times)

Offline mcarlson

  • Newcomer
  • *
  • Posts: 16
    • View Profile
"Scanning Source Paths" - hanging
« on: August 11, 2008, 05:04:10 PM »
Using latest version of Mac OS and latest version of PM on a MacBook Pro with 2MB RAM...  I'm having problems with the ingest hanging for a looooong time with the "Scanning Soure Paths" dialog 'stuck'.  It usually happens when I'm ingesting cards that I've already partially ingested (shot, ingested, used cards again, try to ingest...hanging...).  Using Lexar card reader and SanDisk CF III and IV cards.  Another poster on SportsShooter started a thread with the problem and he reports it using a MB Pro and SanDisk readers.

Thoughts?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24131
    • View Profile
    • Camera Bits, Inc.
Re: "Scanning Source Paths" - hanging
« Reply #1 on: August 11, 2008, 06:56:20 PM »
Using latest version of Mac OS and latest version of PM on a MacBook Pro with 2MB RAM...  I'm having problems with the ingest hanging for a looooong time with the "Scanning Soure Paths" dialog 'stuck'.  It usually happens when I'm ingesting cards that I've already partially ingested (shot, ingested, used cards again, try to ingest...hanging...).  Using Lexar card reader and SanDisk CF III and IV cards.  Another poster on SportsShooter started a thread with the problem and he reports it using a MB Pro and SanDisk readers.

I'd really rather see you list actual version numbers rather than tell me you're just using the latest version of this or that.  What version of Mac OS X are you using?  What version of Photo Mechanic are you using?

-Kirk


Offline mcarlson

  • Newcomer
  • *
  • Posts: 16
    • View Profile
Re: "Scanning Source Paths" - hanging
« Reply #2 on: August 11, 2008, 08:03:57 PM »
Mac OS X 10.5.4 and PM 4.5.3.1

Offline mcarlson

  • Newcomer
  • *
  • Posts: 16
    • View Profile
Re: "Scanning Source Paths" - hanging
« Reply #3 on: August 11, 2008, 08:06:10 PM »
Sorry, should have read PM 4.5.3.2.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24131
    • View Profile
    • Camera Bits, Inc.
Re: "Scanning Source Paths" - hanging
« Reply #4 on: August 11, 2008, 09:01:10 PM »
Sorry, should have read PM 4.5.3.2.

Thanks!

When you say that the dialog 'hangs' do you mean that it never finishes, or that it just happens to take a long time?

What happens if you turn off Incremental Ingest?  (Besides it copying files that have already been copied.)  Does the scanning phase still take a long time?

-Kirk


Offline mcarlson

  • Newcomer
  • *
  • Posts: 16
    • View Profile
Re: "Scanning Source Paths" - hanging
« Reply #5 on: August 12, 2008, 05:24:58 AM »
I know this doesn't help much, but it doesn't follow any regular pattern.  Sometimes it works great, sometimes it hangs and never finishes, sometimes it hangs then eventually finishes.  Unfortunately the last few times it's happened have been during breaks in sporting events when I've been tight on deadline so I've just aborted the ingest and tried again, where it worked fine...it really makes no sense as to what I do or don't do.

Offline Laskadog

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: "Scanning Source Paths" - hanging
« Reply #6 on: August 12, 2008, 05:57:23 AM »
I'll chime in with the same problem.  Using OSX 10.5.4 on a MacBook Pro and PM 4.5.3.1

I always incremental ingest, but I'll try turning it off.  I also deosn't seem to Unmount the disk either.  It hangs for a long time and then all of a sudden just goes. 

I may have some down time today, so I'll run some tests with Incremental ingest on/off, full card/empty card etc.

Thanks,

David

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24131
    • View Profile
    • Camera Bits, Inc.
Re: "Scanning Source Paths" - hanging
« Reply #7 on: August 12, 2008, 06:51:48 AM »
I know this doesn't help much, but it doesn't follow any regular pattern.  Sometimes it works great, sometimes it hangs and never finishes, sometimes it hangs then eventually finishes.  Unfortunately the last few times it's happened have been during breaks in sporting events when I've been tight on deadline so I've just aborted the ingest and tried again, where it worked fine...it really makes no sense as to what I do or don't do.

OK, well we'll try to reproduce this in-house and see if we can get it to happen for us.

-Kirk
« Last Edit: August 12, 2008, 08:48:49 AM by Kirk Baker »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24131
    • View Profile
    • Camera Bits, Inc.
Re: "Scanning Source Paths" - hanging
« Reply #8 on: August 12, 2008, 06:52:55 AM »
David,

I'll chime in with the same problem.  Using OSX 10.5.4 on a MacBook Pro and PM 4.5.3.1

I always incremental ingest, but I'll try turning it off.  I also deosn't seem to Unmount the disk either.  It hangs for a long time and then all of a sudden just goes. 

I may have some down time today, so I'll run some tests with Incremental ingest on/off, full card/empty card etc.

You should definitely get version 4.5.3.2 since it addresses some important issues in Mac OS X 10.5.3 and higher.

-Kirk


Offline Laskadog

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: "Scanning Source Paths" - hanging
« Reply #9 on: August 12, 2008, 07:38:33 AM »
Did the update and a quick test.  So far no more problem.  I have a shoot this afternoon and will put it through its paces a little more.  Thanks.

Offline Laskadog

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: "Scanning Source Paths" - hanging
« Reply #10 on: August 13, 2008, 05:18:45 AM »
Yup, I think the update did the trick.  Thanks

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24131
    • View Profile
    • Camera Bits, Inc.
Re: "Scanning Source Paths" - hanging
« Reply #11 on: August 13, 2008, 06:39:58 AM »
I know this doesn't help much, but it doesn't follow any regular pattern.  Sometimes it works great, sometimes it hangs and never finishes, sometimes it hangs then eventually finishes.  Unfortunately the last few times it's happened have been during breaks in sporting events when I've been tight on deadline so I've just aborted the ingest and tried again, where it worked fine...it really makes no sense as to what I do or don't do.

Since 4.5.3.2 fixed the problem for the other user, are you certain that you are really running version 4.5.3.2?  Open up the About box while you're running Photo Mechanic to check the version number.

-Kirk

UPDATE: we tried to reproduce this issue over two days worth of testing with multiple incremental ingests on a single card with a MacBook Pro running 10.5.4 with a Lexar FireWire card reader.  We never had it hang in our testing.


« Last Edit: August 13, 2008, 12:45:03 PM by Kirk Baker »

Offline drjay32

  • Newcomer
  • *
  • Posts: 46
    • View Profile
    • Luminescence of Nature Photograpy
Re: "Scanning Source Paths" - hanging
« Reply #12 on: August 14, 2008, 05:58:28 AM »
Kirk-
I've seen this problem in 4.5.3.2 on OS 10.5.4 as well-- it seems to hang up on ingest and then eventually muddle through the offending file.  I've never had the ingest fail outright, just slow down.  It seems to happen during incremental ingest when I have a secondary destination specified.

-Jason
Jason P. Odell
Photographer and author in Colorado, USA
www.luminescentphoto.com

Offline mcarlson

  • Newcomer
  • *
  • Posts: 16
    • View Profile
Re: "Scanning Source Paths" - hanging
« Reply #13 on: August 15, 2008, 04:37:46 PM »
Haven't forgot about the question I asked...just been busy.  Will keep an eye out this weekend to see what happens...a couple of games on the schedule so we'll see.

Offline mcarlson

  • Newcomer
  • *
  • Posts: 16
    • View Profile
Re: "Scanning Source Paths" - hanging
« Reply #14 on: August 18, 2008, 03:29:08 PM »
Everything seemed to work fine this weekend...guess it's like taking the car to the shop - can't seem to hear the noise or feel the bump once you get to the mechanic.

Maybe it was the update...?  Will follow up if there's any future issue - thanks for your time.