Author Topic: Problem - Mail embeds rather than attaches pics?  (Read 11915 times)

Offline davidyoung

  • Newcomer
  • *
  • Posts: 9
    • View Profile
    • davidyoungphoto
Problem - Mail embeds rather than attaches pics?
« on: September 19, 2008, 03:58:22 AM »
I've just changed over from using a windows laptop to a macbook pro but I've hit a problem, when i sent pics from PM by email using windows it sent the pics as attachments from outlook express, but when i do the same on my new mac it embeds them into the body of my Mail message.

The main paper I shoot for told me this causes them problems - is there an easy way of making sure that the pics are attacehd rather than embedded?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20923
    • View Profile
    • Camera Bits, Inc.
Re: Problem - Mail embeds rather than attaches pics?
« Reply #1 on: September 19, 2008, 06:03:10 AM »
I've just changed over from using a windows laptop to a macbook pro but I've hit a problem, when i sent pics from PM by email using windows it sent the pics as attachments from outlook express, but when i do the same on my new mac it embeds them into the body of my Mail message.

The main paper I shoot for told me this causes them problems - is there an easy way of making sure that the pics are attacehd rather than embedded?

No.  The choice to attach rather than embed is entirely under the control of the email client you're using.  Apple's Mail application puts them in the body of the email and has no other option.

Why not use something like FTP to get your photos to your paper?

-Kirk

Offline davidyoung

  • Newcomer
  • *
  • Posts: 9
    • View Profile
    • davidyoungphoto
Re: Problem - Mail embeds rather than attaches pics?
« Reply #2 on: September 19, 2008, 08:06:10 AM »
Thanks for confirming what I'd begun to suspect Kirk, unfortunately this client wants pics emailed rather than FTP'd looks like I'll have to find a way around this - or just send them manually.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20923
    • View Profile
    • Camera Bits, Inc.
Re: Problem - Mail embeds rather than attaches pics?
« Reply #3 on: September 19, 2008, 08:15:29 AM »
Thanks for confirming what I'd begun to suspect Kirk, unfortunately this client wants pics emailed rather than FTP'd looks like I'll have to find a way around this - or just send them manually.

Or try one of the several other email clients that exist for Mac OS X.  Photo Mechanic on Mac OS X supports the following clients:

Entourage
Eudora
Mail
Mailsmith
PowerMail

Or you could host the photos on a web page on your site and give the client the URL via email.  Then the client can go to the page and copy the images from the page to their system.  Use the Exporter in Photo Mechanic to generate the pages.

HTH,

-Kirk

Offline Neil Danton

  • Newcomer
  • *
  • Posts: 2
    • View Profile
Re: Problem - Mail embeds rather than attaches pics?
« Reply #4 on: September 19, 2008, 08:29:28 AM »
Actually what Kirk says in his first response is not strictly true.  If you are using Mac Mail, on the menu bar select <edit> then <attachments> then near the bottom, select <always send windows-friendly attachments>  That should solve your problem.  This applies to sending images directly from Mail NOT via Photo Mechanic, not sure about that operation as I don't use it.

You can leave this option selected permanently, as the recipient will be able to save the attachments whether they are using Mac or Windows pc.

Unfortunately FTP is not always an option with newspapers as some are too cheapskate or technically incompetent to set up an FTP system, relying on contributors sending emails with huge attachments, clogging up your server and theirs!  There's a reason it's called email - it's for mail, like a letter.  It's not called eUPS or eDHL, because it's not designed for sending dirty great parcels of images.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20923
    • View Profile
    • Camera Bits, Inc.
Re: Problem - Mail embeds rather than attaches pics?
« Reply #5 on: September 19, 2008, 08:31:42 AM »
Neil,

Actually what Kirk says in his first response is not strictly true.  If you are using Mac Mail, on the menu bar select <edit> then <attachments> then near the bottom, select <always send windows-friendly attachments>  That should solve your problem.  This applies to sending images directly from Mail NOT via Photo Mechanic, not sure about that operation as I don't use it.

You can leave this option selected permanently, as the recipient will be able to save the attachments whether they are using Mac or Windows pc.

I have always wondered what that option did.  Thanks for the tip.

-Kirk

Offline davidyoung

  • Newcomer
  • *
  • Posts: 9
    • View Profile
    • davidyoungphoto
Re: Problem - Mail embeds rather than attaches pics?
« Reply #6 on: September 19, 2008, 08:52:29 AM »
Actually the always send windows friendly attachments doesn't stop the pic being embedded - it just means that the data fork isn't sent as a separate attachment along with the pic.

I'm doing some tests at the moment on semi solutions I've found on the web - will post if I get a solution.

As regards "Unfortunately FTP is not always an option with newspapers as some are too cheapskate or technically incompetent to set up an FTP system"

Most of the major news papers in the UK accept pics by email - some of them prefer to get pics that way, including the local and national ones I'm shooting for tomorrow - either way i don't care as long as they pay me.

Offline davidyoung

  • Newcomer
  • *
  • Posts: 9
    • View Profile
    • davidyoungphoto
Re: Problem - Mail embeds rather than attaches pics?
« Reply #7 on: September 19, 2008, 09:43:10 AM »
Seem to have got a solution but I'm not sure how  ;D - Pics are still displaying inline but they are definitely also attachments whereas the ones I tested earlier weren't.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20923
    • View Profile
    • Camera Bits, Inc.
Re: Problem - Mail embeds rather than attaches pics?
« Reply #8 on: September 19, 2008, 01:04:54 PM »
Seem to have got a solution but I'm not sure how  ;D - Pics are still displaying inline but they are definitely also attachments whereas the ones I tested earlier weren't.

Using Apple's Mail application?  Or some other app?

-Kirk

Offline cocoliso

  • Newcomer
  • *
  • Posts: 3
    • View Profile
Re: Problem - Mail embeds rather than attaches pics?
« Reply #9 on: September 25, 2008, 02:31:50 PM »
I have noticed this same problem with mail app + Leopard 10.5.4. Before this i had a prob with mail app, it would not attach more than 5 pics in the same mail, both PM and mail would freeze. I updated PM to the latest ed. and its OK now.... but I have 2 things i'm not happy with, 1. is this issue talked of here with the embedding as opposed to attaching. As far as I can see its not something that is consistent, sometimes it embeds, and sometimes it does'nt!, i was starting to think it was a problem with the outgoing mail server in the office. I use Gmail/imap via os x mail app without any problems.

Problem No.2 is that as i edit and send a bunch of mails for example 10 at a time, each in its own mail, i would ike this then to be done in the background, ... but as mail app 'attaches' (or maybe embeds?) it comes to the front and will not let me keep working in PM or safari or whatever. This did not happen before, and i imagine its a bug with mail app?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20923
    • View Profile
    • Camera Bits, Inc.
Re: Problem - Mail embeds rather than attaches pics?
« Reply #10 on: September 25, 2008, 02:46:03 PM »
I have noticed this same problem with mail app + Leopard 10.5.4. Before this i had a prob with mail app, it would not attach more than 5 pics in the same mail, both PM and mail would freeze. I updated PM to the latest ed. and its OK now.... but I have 2 things i'm not happy with, 1. is this issue talked of here with the embedding as opposed to attaching. As far as I can see its not something that is consistent, sometimes it embeds, and sometimes it does'nt!, i was starting to think it was a problem with the outgoing mail server in the office. I use Gmail/imap via os x mail app without any problems.

Problem No.2 is that as i edit and send a bunch of mails for example 10 at a time, each in its own mail, i would ike this then to be done in the background, ... but as mail app 'attaches' (or maybe embeds?) it comes to the front and will not let me keep working in PM or safari or whatever. This did not happen before, and i imagine its a bug with mail app?

Yes, there are bugs in the Leopard version of Mail.  Something changed in the Mail application in regards to how it works with AppleScripting.  We have filed a bug report with Apple and the bug is still open.  Hopefully they will fix it soon.

-Kirk

Offline davidyoung

  • Newcomer
  • *
  • Posts: 9
    • View Profile
    • davidyoungphoto
Re: Problem - Mail embeds rather than attaches pics?
« Reply #11 on: September 28, 2008, 02:59:28 AM »
Seem to have got a solution but I'm not sure how  ;D - Pics are still displaying inline but they are definitely also attachments whereas the ones I tested earlier weren't.

Using Apple's Mail application?  Or some other app?

-Kirk


With Apple Mail on Leopard - First set of pics I sent were embedded  but not attached and that's when I made my enquiry here - but subsequent transfers appear to send pics as attachments (though they still show up in the body of outgoing mail) - the papers seem happy enough with the way it's working now - I've been paid anyway  :)

Offline SamFrost

  • Full Member
  • ***
  • Posts: 241
    • View Profile
    • Sam Frost Photography
Re: Problem - Mail embeds rather than attaches pics?
« Reply #12 on: October 01, 2008, 11:23:07 AM »
While dealing with attachments in Mail, I find that Lokiware's Iconizer is a useful little plug-in for Mail that stops images being displayed in Mail and just shows an icon instead.

http://lokiware.info/Mail-Attachments-Iconizer

Offline jeffkowalsky

  • Newcomer
  • *
  • Posts: 12
    • View Profile
Re: Problem - Mail embeds rather than attaches pics?
« Reply #13 on: October 26, 2011, 06:33:25 AM »
I know I am reviving an old thread. Does any one have any better solutions?

I use Apple Mail and need occasionally to email a client who uses outlook a photo which gets embedded and unusable. 

Offline louster1950

  • Newcomer
  • *
  • Posts: 17
    • View Profile
Re: Problem - Mail embeds rather than attaches pics?
« Reply #14 on: October 26, 2011, 07:08:50 AM »
Is it possible the problem might be on the receiving end?
I was covering assignment and some helpful, friendly folks asked if I'd take and e-mail their photo.
Did that and first got a reply from one of them saying no photo was attached. Few minutes later received reply from other person thanking me for nice photo.
I had sent only one e-mail with both as recipients and with "Windows friendly" box checked in Mac mail from my iMac. They're with government agency and both probably on Windows.
I think issue is on their end.
L