Author Topic: 4.6 beta 2 slower to load than currant version 4.5.4  (Read 4123 times)

Offline sandy

  • Newcomer
  • *
  • Posts: 11
    • View Profile
4.6 beta 2 slower to load than currant version 4.5.4
« on: February 14, 2009, 03:42:28 PM »
I have found version 4.6 beta 2 is a lot slower to load than my original 4.5.4 is there anything I can do to speed it up once loaded it appears to be fine works much better than the first 4.6 beta that wouldnt load at all! at present the latest 4.6 version takes 5 to 10 minutes to load compared to 4.5.4 which loads almost instantly my computer is running 4 gig ram processor is 2.5 ghz intel core 2 duo macbookpro

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21909
    • View Profile
    • Camera Bits, Inc.
Re: 4.6 beta 2 slower to load than currant version 4.5.4
« Reply #1 on: February 14, 2009, 07:44:08 PM »
Sandy,

I have found version 4.6 beta 2 is a lot slower to load than my original 4.5.4 is there anything I can do to speed it up once loaded it appears to be fine works much better than the first 4.6 beta that wouldnt load at all! at present the latest 4.6 version takes 5 to 10 minutes to load compared to 4.5.4 which loads almost instantly my computer is running 4 gig ram processor is 2.5 ghz intel core 2 duo macbookpro

What do you mean by 'load'?  For the Splash screen to appear?  For the main Contact Sheet window to appear?  What to you does 'load' mean?

Please give as many specifics as you can.

-Kirk

Offline sandy

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Re: 4.6 beta 2 slower to load than currant version 4.5.4
« Reply #2 on: February 15, 2009, 01:26:09 AM »
when I initially click on 4.6 it takes 5-10 minutes to open up then it kicks in with the blank contact sheet in 4.5.4 it opens almost immediately just wondering if there is any way that it can open quicker once open it appears to be working fine have had no problems with it other than the initial startup thankyou for the prompt reply sandy

Offline camerauk

  • Newcomer
  • *
  • Posts: 41
    • View Profile
Re: 4.6 beta 2 slower to load than currant version 4.5.4
« Reply #3 on: February 15, 2009, 04:26:02 AM »
That is taking a long time mine opens on a 2.0 ghz intel core 2 duo macbook alu with 2 gig ram in about 4-5 secs
so that is very very slow, I have not noticed any speed differences between 4.5.4 and 4.6 when starting up

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21909
    • View Profile
    • Camera Bits, Inc.
Re: 4.6 beta 2 slower to load than currant version 4.5.4
« Reply #4 on: February 15, 2009, 06:11:35 AM »
Sandy,

when I initially click on 4.6 it takes 5-10 minutes to open up then it kicks in with the blank contact sheet in 4.5.4 it opens almost immediately just wondering if there is any way that it can open quicker once open it appears to be working fine have had no problems with it other than the initial startup thankyou for the prompt reply sandy

I can't think of any reason it would take that long to just start up.  I can build a logging version of Photo Mechanic 4.6 for you if you're willing to try it.  The log file that is generated will tell me where the time is being spent.

Let me know if you're interested.

-Kirk

Offline sandy

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Re: 4.6 beta 2 slower to load than currant version 4.5.4
« Reply #5 on: February 15, 2009, 10:15:06 AM »
hi yes i would be interested will try anything to get it up and running thankyou much appreciated sandy

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21909
    • View Profile
    • Camera Bits, Inc.
Re: 4.6 beta 2 slower to load than currant version 4.5.4
« Reply #6 on: February 16, 2009, 06:43:10 PM »
Sandy,

hi yes i would be interested will try anything to get it up and running thankyou much appreciated sandy

The updated version that solves the speed issues you were experiencing is now available on the Announcements section of the forums.

-Kirk

Offline youngblood

  • Newcomer
  • *
  • Posts: 2
    • View Profile
Re: 4.6 beta 2 slower to load than currant version 4.5.4
« Reply #7 on: February 19, 2009, 08:29:00 AM »
I haven't waited 5 to 10 minutes to wait for application to start up so I don't know if this is the same issue. What happens to me is that when network volumes are mounted on my MacBook Pro running 10.4.11, PM 4.6 launches to the splash screen and just sits. After a minute or so I just force quit it. If I dismount the network volumes it launches immediately.

alan

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21909
    • View Profile
    • Camera Bits, Inc.
Re: 4.6 beta 2 slower to load than currant version 4.5.4
« Reply #8 on: February 19, 2009, 08:55:44 AM »
Alan,

I haven't waited 5 to 10 minutes to wait for application to start up so I don't know if this is the same issue. What happens to me is that when network volumes are mounted on my MacBook Pro running 10.4.11, PM 4.6 launches to the splash screen and just sits. After a minute or so I just force quit it. If I dismount the network volumes it launches immediately.

It is unlikely to be the same issue.  If you want to run a logging version of Photo Mechanic to narrow down what is going on, let me know.  But before that I would want to know if this is new behavior in 4.6 or does 4.5.4 do the same thing?  How many network volumes do you have?

In version 4.6 if you right-click (Ctrl-click) on an item in the Navigator or Favorites panels, you can choose the Preferences item from the contextual menu that appears.  From there you can turn off "Always check sub-folders for folders on servers" option which may speed things up quite a bit on your server volumes.

-Kirk

Offline JAS Photo

  • Sr. Member
  • ****
  • Posts: 393
    • View Profile
    • JAS Photo LLC
Re: 4.6 beta 2 slower to load than currant version 4.5.4
« Reply #9 on: February 19, 2009, 12:53:12 PM »
Kirk - In 4.6 beta 2 the only chioces I get are Show Hidden Folders & Show System Folders in preferences? on a Win XP Pro SP3 System.

As a guage 4.6 take about 2 1/2 minutes to "load" a bit slower but then 4.5.4. - On a dual core with 2.5gb RAM  with network volumes.

Thanks
Joe


Joe Sorrentino
JAS Photo LLC
http://www.JASPhoto.com

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21909
    • View Profile
    • Camera Bits, Inc.
Re: 4.6 beta 2 slower to load than currant version 4.5.4
« Reply #10 on: February 19, 2009, 01:26:06 PM »
Joe,

Kirk - In 4.6 beta 2 the only chioces I get are Show Hidden Folders & Show System Folders in preferences? on a Win XP Pro SP3 System.

As a guage 4.6 take about 2 1/2 minutes to "load" a bit slower but then 4.5.4. - On a dual core with 2.5gb RAM  with network volumes.

My comments above pertain only to the Mac OS X version.

Though I am curious as to why your system takes 2.5 minutes to load Photo Mechanic.  Do you have networked drives?  Do you have Photo Mechanic maintaining an unusually large Disk Cache?

-Kirk