Author Topic: Preferences Changing & Disappearing  (Read 2702 times)

Offline bazography

  • Full Member
  • ***
  • Posts: 188
    • View Profile
Preferences Changing & Disappearing
« on: February 15, 2009, 02:40:07 PM »
I began testing PM 4.6 on my early 2008 MacBook Pro 2, GB RAM, using OS 10.5.6 a few days ago. I installed 4.6 over my previous version 4.4.3.3. Several times since installing 4.6 my preferences have changed spontaneously. The problem is identical with both the Beta 1 and the new Beta 2 versions.

On 3 or 4 occasions the preview’s background color and selected background color have turned bright blue, without me touching the preferences. This occurred while the program was up and running, not immediately after launching PM. Upon opening the Preview preferences, I found the color selections had indeed changed themselves to blue, and the rest of the check boxes in the Preview preferences window were blank.

Also, on 2 or 3 occasions PM warned me (both on shut-down and at start-up) that the Cache folder had been moved. I checked the Cache preferences window and all the fields and check boxes were blank.

I checked the rest of the preferences and discovered all the fields in the Color Management window were also blank. The rest appeared fine, so only the Preview, Caching and Color Management preference windows seem to be affected. Although all the fields in those 3 windows appeared blank, the only actual behaviour issues I noticed so far have been the blue preview background and the cache issue mentioned above.

After testing I discovered that every time I launch PM, the same 3 preference windows display blank fields and blue color selections described above, yet the program and all the preferences function normally. If I close the preferences window and re-open it, all preferences then appear normal. I believe that if I don’t initially correct the preferences, that at some point during the session the incorrect preferences suddenly start to take effect and I end up with the blue background and the cache error message.

I hope I am describing this well enough to be helpful. I haven’t seen anyone else describe a similar problem yet. Should I delete all the preference files and the application and try a fresh install?


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20837
    • View Profile
    • Camera Bits, Inc.
Re: Preferences Changing & Disappearing
« Reply #1 on: February 15, 2009, 07:19:29 PM »
I began testing PM 4.6 on my early 2008 MacBook Pro 2, GB RAM, using OS 10.5.6 a few days ago. I installed 4.6 over my previous version 4.4.3.3. Several times since installing 4.6 my preferences have changed spontaneously. The problem is identical with both the Beta 1 and the new Beta 2 versions.

On 3 or 4 occasions the preview’s background color and selected background color have turned bright blue, without me touching the preferences. This occurred while the program was up and running, not immediately after launching PM. Upon opening the Preview preferences, I found the color selections had indeed changed themselves to blue, and the rest of the check boxes in the Preview preferences window were blank.

Also, on 2 or 3 occasions PM warned me (both on shut-down and at start-up) that the Cache folder had been moved. I checked the Cache preferences window and all the fields and check boxes were blank.

I checked the rest of the preferences and discovered all the fields in the Color Management window were also blank. The rest appeared fine, so only the Preview, Caching and Color Management preference windows seem to be affected. Although all the fields in those 3 windows appeared blank, the only actual behaviour issues I noticed so far have been the blue preview background and the cache issue mentioned above.

After testing I discovered that every time I launch PM, the same 3 preference windows display blank fields and blue color selections described above, yet the program and all the preferences function normally. If I close the preferences window and re-open it, all preferences then appear normal. I believe that if I don’t initially correct the preferences, that at some point during the session the incorrect preferences suddenly start to take effect and I end up with the blue background and the cache error message.

I hope I am describing this well enough to be helpful. I haven’t seen anyone else describe a similar problem yet. Should I delete all the preference files and the application and try a fresh install?

Screen shots might be helpful as well.  Is there anything odd about your user account?  Is it on your boot drive or somewhere else?

-Kirk

Offline bazography

  • Full Member
  • ***
  • Posts: 188
    • View Profile
Re: Preferences Changing & Disappearing
« Reply #2 on: February 15, 2009, 09:35:01 PM »
No, nothing unusual about my user account... standard Mac set-up with just one account on the internal boot drive.
The first 3 screen shots are what I see when I open Preferences after first launching PM. The next 3 are what I see if I close the preferences window and immediately re-open it (these are all the correct preferences the way I set them).




[attachment deleted by admin]
« Last Edit: February 15, 2009, 09:43:45 PM by bazography »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20837
    • View Profile
    • Camera Bits, Inc.
Re: Preferences Changing & Disappearing
« Reply #3 on: February 15, 2009, 10:06:51 PM »
No, nothing unusual about my user account... standard Mac set-up with just one account on the internal boot drive.
The first 3 screen shots are what I see when I open Preferences after first launching PM. The next 3 are what I see if I close the preferences window and immediately re-open it (these are all the correct preferences the way I set them).

This is completely repeatable?

In the second set of screen shots, did you set the various settings again and then OK the Preferences dialog?

-Kirk

Offline bazography

  • Full Member
  • ***
  • Posts: 188
    • View Profile
Re: Preferences Changing & Disappearing
« Reply #4 on: February 15, 2009, 11:41:53 PM »
Yes, the preferences showing up altered and/or blank as shown in the screen shots is fully repeatable upon initial launch of PM. In the 2nd set of screen shots I did not reset or OK any of the preferences. If I just close the window and open it again, everything appears back to normal. Once the preferences are back to normal they don't change again until I quit PM and launch it again.

I've been playing around some more and just figured out why the altered preferences actually took effect on those few occasions (like the blue background and the missing cache folder). When I first started trying out 4.6 I was playing with preferences lots, so I must have hit the OK button after changing a preference, for example, in the General window, not realizing that the preferences had altered themselves in the Preview, Cache and Color Management windows.

So now all of this is repeatable: when I launch PM and open preferences, they appear altered/blank. If I just close the window and reopen it, my correct preferences return and remain until I quit and launch again. On the other hand, if I OK the window, the altered/blank preferences stick and I get the blue preview background, missing cache folder etc again. At this point I will have to manually change all the preferences back to the way I prefer and click OK.

If I do OK the altered/blank preferences, there is one more peculiarity: even though all the check boxes appear blank, the actual preference may still be in effect, or not. I haven't tested them all, but for example the "Show soft rotation indicator" preference continues to work, whereas "Auto-center thumbnails in thumbnail gallery" does not, even though all the boxes in the Preview window are unchecked.
« Last Edit: February 15, 2009, 11:46:19 PM by bazography »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20837
    • View Profile
    • Camera Bits, Inc.
Re: Preferences Changing & Disappearing
« Reply #5 on: February 16, 2009, 07:32:56 AM »
Yes, the preferences showing up altered and/or blank as shown in the screen shots is fully repeatable upon initial launch of PM. In the 2nd set of screen shots I did not reset or OK any of the preferences. If I just close the window and open it again, everything appears back to normal. Once the preferences are back to normal they don't change again until I quit PM and launch it again.

I've been playing around some more and just figured out why the altered preferences actually took effect on those few occasions (like the blue background and the missing cache folder). When I first started trying out 4.6 I was playing with preferences lots, so I must have hit the OK button after changing a preference, for example, in the General window, not realizing that the preferences had altered themselves in the Preview, Cache and Color Management windows.

So now all of this is repeatable: when I launch PM and open preferences, they appear altered/blank. If I just close the window and reopen it, my correct preferences return and remain until I quit and launch again. On the other hand, if I OK the window, the altered/blank preferences stick and I get the blue preview background, missing cache folder etc again. At this point I will have to manually change all the preferences back to the way I prefer and click OK.

If I do OK the altered/blank preferences, there is one more peculiarity: even though all the check boxes appear blank, the actual preference may still be in effect, or not. I haven't tested them all, but for example the "Show soft rotation indicator" preference continues to work, whereas "Auto-center thumbnails in thumbnail gallery" does not, even though all the boxes in the Preview window are unchecked.

OK, so when this happens, check the console.log file for any messages related to Photo Mechanic.  To view the console.log file, use the "Console" application which can be found in the Utilities folder inside the Applications folder on your system.

Please copy and paste any messages you think may be applicable.

Thanks,

-Kirk

Offline bazography

  • Full Member
  • ***
  • Posts: 188
    • View Profile
Re: Preferences Changing & Disappearing
« Reply #6 on: February 16, 2009, 10:15:56 AM »
Here is the Console report after doing the following: Launch PM. Open preferences folder. Close preferences folder (no changes, no OK).

16/02/09 10:07:05 AM Photo Mechanic[161] Path (null) given to -[NSWorkspace iconForFile:] is not a full path.
16/02/09 10:07:05 AM Photo Mechanic[161] Path (null) given to -[NSWorkspace iconForFile:] is not a full path.
16/02/09 10:08:12 AM Photo Mechanic[161] *** Assertion failure in -[NSMenu itemAtIndex:], /SourceCache/AppKit/AppKit-949.43/Menus.subproj/NSMenu.m:819
16/02/09 10:08:12 AM Photo Mechanic[161] Invalid parameter not satisfying: (index >= 0) && (index < (_itemArray ? CFArrayGetCount((CFArrayRef)_itemArray) : 0))