Author Topic: Not displaying all thumbnails after ingest  (Read 3393 times)

Offline bazography

  • Full Member
  • ***
  • Posts: 174
    • View Profile
Not displaying all thumbnails after ingest
« on: February 20, 2009, 01:19:51 PM »
Whenever I ingest, only some of the thumbnails display in the resulting contact sheet. For example, I may be ingesting 40 photos, and sometimes 3 photos will show up in the contact sheet, and sometime 7 will show up, but on all occasions the majority of the thumbnails are not displayed. The info on the bottom bar of the contact sheet will indicate there are 3 or 7 images in the contact sheet, not 40. This not random behaviour, it happens every time I ingest, and this is after the confirmation box appears telling me the ingest is complete.

If I manually select the refresh menu item, all the photos will then show up. After some testing it appears this only happens if the ingest preference "open contact sheet during ingest" is selected. The other 2 options do not produce this result.

MacBook Pro 4,1
2 GB RAM
Leopard 10.4.6
PM 4.6 latest beta Feb 18

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20586
    • View Profile
    • Camera Bits, Inc.
Re: Not displaying all thumbnails after ingest
« Reply #1 on: February 20, 2009, 01:43:08 PM »
Whenever I ingest, only some of the thumbnails display in the resulting contact sheet. For example, I may be ingesting 40 photos, and sometimes 3 photos will show up in the contact sheet, and sometime 7 will show up, but on all occasions the majority of the thumbnails are not displayed. The info on the bottom bar of the contact sheet will indicate there are 3 or 7 images in the contact sheet, not 40. This not random behaviour, it happens every time I ingest, and this is after the confirmation box appears telling me the ingest is complete.

If I manually select the refresh menu item, all the photos will then show up. After some testing it appears this only happens if the ingest preference "open contact sheet during ingest" is selected. The other 2 options do not produce this result.

MacBook Pro 4,1
2 GB RAM
Leopard 10.4.6
PM 4.6 latest beta Feb 18

Are you using the Loupe cursor during the Ingest?  Rescans are averted during zooming of images.

-Kirk

Offline bazography

  • Full Member
  • ***
  • Posts: 174
    • View Profile
Re: Not displaying all thumbnails after ingest
« Reply #2 on: February 20, 2009, 03:36:47 PM »
The cursor mode is set to the regular cursor, not loupe. I've been letting the ingest complete without touching anything.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20586
    • View Profile
    • Camera Bits, Inc.
Re: Not displaying all thumbnails after ingest
« Reply #3 on: February 20, 2009, 03:40:32 PM »
The cursor mode is set to the regular cursor, not loupe. I've been letting the ingest complete without touching anything.

What are all of the file types you're ingesting?

-Kirk

Offline bazography

  • Full Member
  • ***
  • Posts: 174
    • View Profile
Re: Not displaying all thumbnails after ingest
« Reply #4 on: February 20, 2009, 03:47:12 PM »
Tried ingesting Jpgs and Tifs with same results.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20586
    • View Profile
    • Camera Bits, Inc.
Re: Not displaying all thumbnails after ingest
« Reply #5 on: February 20, 2009, 05:40:09 PM »
Tried ingesting Jpgs and Tifs with same results.

I had one of our support guys test an Ingest:

"I just Ingested two flash cards (~2 gigs) of mixed files and the Contact Sheet is refreshing as expected. I'm not sure why this is not working for them."

-Kirk

Offline bazography

  • Full Member
  • ***
  • Posts: 174
    • View Profile
Re: Not displaying all thumbnails after ingest
« Reply #6 on: February 20, 2009, 11:48:02 PM »
Just realized I made a mistake earlier... I meant to say it is the Rescan button I must use to get all the images to show up, not the Refresh button. Sorry about that.

I've been playing around with ingesting a card of 77 jpegs. Every time I ingest it only 1 thumbnail appears. Just for fun I tried hitting the Rescan in the middle of the ingest and that time 39 thumbnails appeared. All the thumbnails that had been ingested, up until the exact time I hit Rescan, showed up in the contact sheet. All those ingested after the manual Rescan did not show up. It would appear that for some reason the contact sheet is not being scanned during ingest.

I fired up 4.4.3.3 again just to check, and all the thumbnails loaded properly every time.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20586
    • View Profile
    • Camera Bits, Inc.
Re: Not displaying all thumbnails after ingest
« Reply #7 on: February 21, 2009, 06:07:48 AM »
Just realized I made a mistake earlier... I meant to say it is the Rescan button I must use to get all the images to show up, not the Refresh button. Sorry about that.

I've been playing around with ingesting a card of 77 jpegs. Every time I ingest it only 1 thumbnail appears. Just for fun I tried hitting the Rescan in the middle of the ingest and that time 39 thumbnails appeared. All the thumbnails that had been ingested, up until the exact time I hit Rescan, showed up in the contact sheet. All those ingested after the manual Rescan did not show up. It would appear that for some reason the contact sheet is not being scanned during ingest.

I fired up 4.4.3.3 again just to check, and all the thumbnails loaded properly every time.

Well, I believe you.  We just cannot reproduce it on our systems.  If you want to help me get to the bottom of this, and are willing to do some troubleshooting with me let me know.  I will create a logging version for you to run and we'll find out why it isn't automatically rescanning.

-Kirk

Offline bazography

  • Full Member
  • ***
  • Posts: 174
    • View Profile
Re: Not displaying all thumbnails after ingest
« Reply #8 on: February 21, 2009, 12:22:35 PM »
Yes, I'm willing to do any troubleshooting necessary.

Offline Junction10

  • Member
  • **
  • Posts: 52
    • View Profile
    • Junction10 Photography
Re: Not displaying all thumbnails after ingest
« Reply #9 on: February 23, 2009, 08:29:19 AM »
I also noticed this - only one thumbnail appearing in the contact sheet after ingest, unless I do a manual rescan.

I'm on a MacBook Pro 15", 4gb RAM, 320gb HD, OSX 10.5.6
 
iMac 27" 5K Retina 2017 -  4.2ghz 64gb RAM 1Tb HD, OSX Mojave
MacBook Pro 15" 512gb SSD 2.96ghz 8gb RAM Mojave
Canon 1DS MkIII / Canon 5D MkII / Canon 5DS / Canon 5DS

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20586
    • View Profile
    • Camera Bits, Inc.
Re: Not displaying all thumbnails after ingest
« Reply #10 on: February 23, 2009, 09:01:02 AM »
I also noticed this - only one thumbnail appearing in the contact sheet after ingest, unless I do a manual rescan.

I'm on a MacBook Pro 15", 4gb RAM, 320gb HD, OSX 10.5.6
 

Are you willing to do some troubleshooting as well?

Thanks,

-Kirk

Offline Junction10

  • Member
  • **
  • Posts: 52
    • View Profile
    • Junction10 Photography
Re: Not displaying all thumbnails after ingest
« Reply #11 on: February 23, 2009, 09:15:59 AM »
As much as humanly possible, absolutely.
iMac 27" 5K Retina 2017 -  4.2ghz 64gb RAM 1Tb HD, OSX Mojave
MacBook Pro 15" 512gb SSD 2.96ghz 8gb RAM Mojave
Canon 1DS MkIII / Canon 5D MkII / Canon 5DS / Canon 5DS