Author Topic: Amazon S3 Issue  (Read 1640 times)

Offline MetPhotoDesk

  • Newcomer
  • *
  • Posts: 1
    • View Profile
Amazon S3 Issue
« on: April 13, 2009, 01:34:58 AM »
OS: XP Pro SP3
RAM: 4 gb

Photo Mechanic Version: 4.6 (latest RC)

Photos are shot by Nikon D300, JPEG fine.

==========================

I'm getting a very specific ruby error when trying to upload to an Amazon S3 account.

It appears that the script you are employing is attempting to recreate the chosen bucket upon upload. Now, obviously, that causes errors seeing as the bucket already exists.

I am able to complete a successful upload if I specify a NEW bucket in the settings, but seeing as how Amazon S3 users have a limit of 100 buckets per account, this is NOT a workable solution. Please just fix the bug.

The error from the log is as follows:

Code: [Select]
2009-04-13 00:50:01 [ERROR] Q:\3-3-2009--30thProduction\30thProd_001.jpg AmazonS3 C:\Program Files\Camera Bits\Photo Mechanic 4.6\ruby/lib/ruby/1.8/aws/s3/error.rb:38:in `raise': Your previous request to create the named bucket succeeded and you already own it.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21567
    • View Profile
    • Camera Bits, Inc.
Re: Amazon S3 Issue
« Reply #1 on: April 13, 2009, 09:10:42 PM »
OS: XP Pro SP3
RAM: 4 gb

Photo Mechanic Version: 4.6 (latest RC)

Photos are shot by Nikon D300, JPEG fine.

==========================

I'm getting a very specific ruby error when trying to upload to an Amazon S3 account.

It appears that the script you are employing is attempting to recreate the chosen bucket upon upload. Now, obviously, that causes errors seeing as the bucket already exists.

I am able to complete a successful upload if I specify a NEW bucket in the settings, but seeing as how Amazon S3 users have a limit of 100 buckets per account, this is NOT a workable solution. Please just fix the bug.

The error from the log is as follows:

Code: [Select]
2009-04-13 00:50:01 [ERROR] Q:\3-3-2009--30thProduction\30thProd_001.jpg AmazonS3 C:\Program Files\Camera Bits\Photo Mechanic 4.6\ruby/lib/ruby/1.8/aws/s3/error.rb:38:in `raise': Your previous request to create the named bucket succeeded and you already own it.

I checked into this issue.  The 4.6.1 beta should not have this issue.  I tested it with an existing bucket and it was not recreated.

Please get the 4.6.1 beta from the Announcements section of the forums and test with it.  If the problem still persists, please let me know.

-Kirk