Author Topic: IPTC problems in PM 4.6.1  (Read 9685 times)

Offline vAfotoriporter

  • Uber Member
  • ******
  • Posts: 1027
    • View Profile
    • Attila Volgyi photojournalist
IPTC problems in PM 4.6.1
« on: April 22, 2009, 07:39:39 AM »
I recently discovered (on OSX 10.5.6) that PM 4.6.1 beta 5 doesn't add Caption and more of the IPTC fields. First I met with the issue upon ingest but it seems it exist on Apply IPTC stationery as well. Both after Ingest and after I Apply Stationery the following fields stay empty:
Caption
Capiton writer
Headline
Keywords
Object Name
Transmission reference
Edit status
Category
Supp Cat1
Supp Cat2 (I didn't use it)
Supp Cat3 (I didn't use it)
IPTC scene (I didn't use it)
Special instructions
City
Location
State (I didn't use it)
Country
Code
Photographer
Title
Credit
Source
Copyright
the rest seems to work
I tried to enter info into the IPTC through the IPTC info for image window but PM didn't store the entered info either.
Working on Mac, OSX, iOS and with some Canons.
Allways shooting RAW.

http://www.volgyiattila.com

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20259
    • View Profile
    • Camera Bits, Inc.
Re: IPTC problems in PM 4.6.1
« Reply #1 on: April 22, 2009, 09:44:20 AM »
I recently discovered (on OSX 10.5.6) that PM 4.6.1 beta 5 doesn't add Caption and more of the IPTC fields. First I met with the issue upon ingest but it seems it exist on Apply IPTC stationery as well. Both after Ingest and after I Apply Stationery the following fields stay empty:
Caption
Capiton writer
Headline
Keywords
Object Name
Transmission reference
Edit status
Category
Supp Cat1
Supp Cat2 (I didn't use it)
Supp Cat3 (I didn't use it)
IPTC scene (I didn't use it)
Special instructions
City
Location
State (I didn't use it)
Country
Code
Photographer
Title
Credit
Source
Copyright
the rest seems to work
I tried to enter info into the IPTC through the IPTC info for image window but PM didn't store the entered info either.

On what kind of files?  Please provide more information so that I can reproduce the problem.  This obviously isn't a widespread issue or many people would be reporting this.

-Kirk

Offline nharnik

  • Full Member
  • ***
  • Posts: 112
    • View Profile
Re: IPTC problems in PM 4.6.1
« Reply #2 on: April 22, 2009, 10:29:03 AM »
OS X
PM 4.6.1 beta 6

I'm having the same problem, upon ingest of a disk, all iptc fields are empty, nothing is carrying over from stationary pad.
My last good working version was 4.6.1 beta 4.

help.

Offline nharnik

  • Full Member
  • ***
  • Posts: 112
    • View Profile
Re: IPTC problems in PM 4.6.1
« Reply #3 on: April 22, 2009, 11:10:03 AM »
Further info:
after an ingest, even though the "apply iptc pad to photos" is checked, all fields are empty.
If I select all photos in the contact sheet and then right-click and apply iptc pad to selected, nothing happens.
If I select one photo, and in the iptc window hit the "apply stationary pad" then the caption info does get copied.
is this possibly a use local vs use global iptc pad problem?

 

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20259
    • View Profile
    • Camera Bits, Inc.
Re: IPTC problems in PM 4.6.1
« Reply #4 on: April 22, 2009, 12:05:34 PM »
Nati,

Further info:
after an ingest, even though the "apply iptc pad to photos" is checked, all fields are empty.
If I select all photos in the contact sheet and then right-click and apply iptc pad to selected, nothing happens.
If I select one photo, and in the iptc window hit the "apply stationary pad" then the caption info does get copied.
is this possibly a use local vs use global iptc pad problem?

I don't know yet.  I haven't been able to reproduce the issue yet.  Here is what I have done:

1) Added "IPTC Stationery Pad" to the Caption field along with the '+' checkbox checked.
2) Closed the IPTC Stationery Pad dialog and selected several photos (they already had IPTC data, by the way.)
3) Right-clicked on the first photo and chose "Apply IPTC Stationery Pad"

The result was that each photo had the text "IPTC Stationery Pad" appended to their Caption fields.

What image type are you working with?  Does this happen only with images that have no IPTC data yet?

-Kirk

Offline nharnik

  • Full Member
  • ***
  • Posts: 112
    • View Profile
Re: IPTC problems in PM 4.6.1
« Reply #5 on: April 22, 2009, 01:57:57 PM »
Kirk,
I'm not sure I follow your description.
here is what I do, and I have not changed any settings on PM since updating from beta 4 directly to beta 6.
**I'm shooting Canon CR2 raw.
**Stick CF card in reader and that brings up the PM ingest dialog.
**Click on "IPTC Stationary Pad" button to write caption. (Global IPTC stationary selected)
**Click on Ingest. (to primary destination, no secondary destination)
**Ingest occurs, into folder with name, and folder name picks up the variables there.
**Now I have a folder full of CR2's, but all the iptc fields are empty.
**Now I click on the round Info symbol on the thumbnail, and the iptc info window opens, none of the fields are filled.
**Now I click on "Apply Stationary Pad" at the bottom of the iptc info window, and the fields do fill with the proper info from the stationary pad, including tokens and text replacement, as they should have during the ingest.
**I click OK., and close the iptc info window.
**Then I once again click on the round I symbol, on same thumbnail, and the iptc info window opens EMPTY AGAIN. the info did not get saved.

BUT: I just took one of the CR2 files, did a "Save As" to convert it to a JPEG image. and tried to apply the stationary pad to the JPEG. Now the IPTC info sticks.
So the problem must be something with the handling of CR2 files

As a test I just ingested a few files shot in JPEG, and there is no problem with the IPTC info.

thanks, Nati

Offline vAfotoriporter

  • Uber Member
  • ******
  • Posts: 1027
    • View Profile
    • Attila Volgyi photojournalist
Re: IPTC problems in PM 4.6.1
« Reply #6 on: April 22, 2009, 11:14:59 PM »
I recently discovered (on OSX 10.5.6) that PM 4.6.1 beta 5 doesn't add Caption and more of the IPTC fields. First I met with the issue upon ingest but it seems it exist on Apply IPTC stationery as well. Both after Ingest and after I Apply Stationery the following fields stay empty:
Caption
Capiton writer
Headline
Keywords
Object Name
Transmission reference
Edit status
Category
Supp Cat1
Supp Cat2 (I didn't use it)
Supp Cat3 (I didn't use it)
IPTC scene (I didn't use it)
Special instructions
City
Location
State (I didn't use it)
Country
Code
Photographer
Title
Credit
Source
Copyright
the rest seems to work
I tried to enter info into the IPTC through the IPTC info for image window but PM didn't store the entered info either.

On what kind of files?  Please provide more information so that I can reproduce the problem.  This obviously isn't a widespread issue or many people would be reporting this.

-Kirk

I prefer using Canon CR2 files from both Canon EOS 1D mk II and Canon EOS 40D. Neither has the IPTC. I didn't change any settings since PM 4.6 came out before any betas and the problem seems to appear after 4.6.1 beta 4. I don't write protect the images I mostly use FAT32 USB HDD but this shouldn't affect the IPTC.

As I described some fields get their values but not the most important ones like headline and caption. Actually it seems only some * marked XMP fields get value. And not even all of them.
Working on Mac, OSX, iOS and with some Canons.
Allways shooting RAW.

http://www.volgyiattila.com

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20259
    • View Profile
    • Camera Bits, Inc.
Re: IPTC problems in PM 4.6.1
« Reply #7 on: April 23, 2009, 01:45:26 AM »
Nati,

I'm not sure I follow your description.
here is what I do, and I have not changed any settings on PM since updating from beta 4 directly to beta 6.
**I'm shooting Canon CR2 raw.
**Stick CF card in reader and that brings up the PM ingest dialog.
**Click on "IPTC Stationary Pad" button to write caption. (Global IPTC stationary selected)
**Click on Ingest. (to primary destination, no secondary destination)
**Ingest occurs, into folder with name, and folder name picks up the variables there.
**Now I have a folder full of CR2's, but all the iptc fields are empty.
**Now I click on the round Info symbol on the thumbnail, and the iptc info window opens, none of the fields are filled.
**Now I click on "Apply Stationary Pad" at the bottom of the iptc info window, and the fields do fill with the proper info from the stationary pad, including tokens and text replacement, as they should have during the ingest.
**I click OK., and close the iptc info window.
**Then I once again click on the round I symbol, on same thumbnail, and the iptc info window opens EMPTY AGAIN. the info did not get saved.

BUT: I just took one of the CR2 files, did a "Save As" to convert it to a JPEG image. and tried to apply the stationary pad to the JPEG. Now the IPTC info sticks.
So the problem must be something with the handling of CR2 files

As a test I just ingested a few files shot in JPEG, and there is no problem with the IPTC info.

Can you post screenshots of your IPTC/XMP tab, and the Files tab of the Preferences dialog?

Thanks,

-Kirk

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20259
    • View Profile
    • Camera Bits, Inc.
Re: IPTC problems in PM 4.6.1
« Reply #8 on: April 23, 2009, 01:45:54 AM »
szurkebarat,

I recently discovered (on OSX 10.5.6) that PM 4.6.1 beta 5 doesn't add Caption and more of the IPTC fields. First I met with the issue upon ingest but it seems it exist on Apply IPTC stationery as well. Both after Ingest and after I Apply Stationery the following fields stay empty:
Caption
Capiton writer
Headline
Keywords
Object Name
Transmission reference
Edit status
Category
Supp Cat1
Supp Cat2 (I didn't use it)
Supp Cat3 (I didn't use it)
IPTC scene (I didn't use it)
Special instructions
City
Location
State (I didn't use it)
Country
Code
Photographer
Title
Credit
Source
Copyright
the rest seems to work
I tried to enter info into the IPTC through the IPTC info for image window but PM didn't store the entered info either.

On what kind of files?  Please provide more information so that I can reproduce the problem.  This obviously isn't a widespread issue or many people would be reporting this.

-Kirk

I prefer using Canon CR2 files from both Canon EOS 1D mk II and Canon EOS 40D. Neither has the IPTC. I didn't change any settings since PM 4.6 came out before any betas and the problem seems to appear after 4.6.1 beta 4. I don't write protect the images I mostly use FAT32 USB HDD but this shouldn't affect the IPTC.

As I described some fields get their values but not the most important ones like headline and caption. Actually it seems only some * marked XMP fields get value. And not even all of them.

Can you post screenshots of your IPTC/XMP tab, and the Files tab of the Preferences dialog?

Thanks,

-Kirk

Offline vAfotoriporter

  • Uber Member
  • ******
  • Posts: 1027
    • View Profile
    • Attila Volgyi photojournalist
Re: IPTC problems in PM 4.6.1
« Reply #9 on: April 23, 2009, 03:25:50 AM »

Working on Mac, OSX, iOS and with some Canons.
Allways shooting RAW.

http://www.volgyiattila.com

Offline nharnik

  • Full Member
  • ***
  • Posts: 112
    • View Profile
Re: IPTC problems in PM 4.6.1
« Reply #10 on: April 23, 2009, 05:17:43 AM »
My tabs.
thanks,
Nati

[attachment deleted by admin]

Offline Bob Russell

  • Camera Bits Staff
  • Full Member
  • *****
  • Posts: 128
    • View Profile
    • Camera Bits, Inc.
Re: IPTC problems in PM 4.6.1
« Reply #11 on: April 23, 2009, 05:39:30 PM »
  Hi Nati,  Thank you for the screen shots. I have tried to recreate your problem on my X.5.6 Macs using 1DMk II CR2 files and everything is working correctly. I tried using both the local and global stationary pads on raw+jpeg plus raw only files and so far so good. I didn't try using an external FAT32 drive. Can you Ingest to the local hard drive without any problems?   If you send an email to bob@camerabits.com with your phone number and a good time to call, I should be able to get to the bottom of this problem.  Thanks for your help.

regards,

--Bob


Offline vAfotoriporter

  • Uber Member
  • ******
  • Posts: 1027
    • View Profile
    • Attila Volgyi photojournalist
Re: IPTC problems in PM 4.6.1
« Reply #12 on: April 23, 2009, 09:57:34 PM »
For me this issue is not only about ingest but it seems to be any IPTC functionality.
Ingest works with the main HD the same way: most of the IPTC fields are left empty.
Working on Mac, OSX, iOS and with some Canons.
Allways shooting RAW.

http://www.volgyiattila.com

Offline nharnik

  • Full Member
  • ***
  • Posts: 112
    • View Profile
Re: IPTC problems in PM 4.6.1
« Reply #13 on: April 24, 2009, 02:13:24 PM »
Well,
Thanks to the amazing Camerabits customer support my IPTC issues are solved.
When was the last time you needed help with software and the customer support staff (Bob Russell in this case) insisted they call you?
Seems what took care of my problems was running Disk Utility and fixing file permissions. That and some minor tweaks in preferences, now all my IPTC data is restored.
 ;D

Offline vAfotoriporter

  • Uber Member
  • ******
  • Posts: 1027
    • View Profile
    • Attila Volgyi photojournalist
Re: IPTC problems in PM 4.6.1
« Reply #14 on: April 24, 2009, 10:58:39 PM »
Camerabits is famous about their amazing support! Keep up with the good work.
Working on Mac, OSX, iOS and with some Canons.
Allways shooting RAW.

http://www.volgyiattila.com