Author Topic: Is this normal behavior?  (Read 4414 times)

Offline bdickson

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Is this normal behavior?
« on: July 29, 2006, 05:25:38 PM »
1. displayed a contact sheet and set a color class for several images.
2. Selected Edit->Select Color Class
3. Did a View by->Selected
4. Right clicked one of the images and edited it in Photoshop CS2
5. Saved the file in PS and returned to PM
6. The contact sheet now contains only the file I just edited, the other files are gone.

Is this normal behavior?

Thanks
Bruce Dickson

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20582
    • View Profile
    • Camera Bits, Inc.
Re: Is this normal behavior?
« Reply #1 on: July 29, 2006, 08:07:13 PM »
Bruce,

1. displayed a contact sheet and set a color class for several images.
2. Selected Edit->Select Color Class
3. Did a View by->Selected
4. Right clicked one of the images and edited it in Photoshop CS2
5. Saved the file in PS and returned to PM
6. The contact sheet now contains only the file I just edited, the other files are gone.

Is this normal behavior?

They're not gone.  They just became un-selected somehow, and since you are viewing by selected, they have been filtered out.  View All should make them come back.

What OS version are you using, and which version of Photo Mechanic are you using?

-Kirk

Offline bdickson

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: Is this normal behavior?
« Reply #2 on: July 30, 2006, 10:48:13 AM »
Hi Kirk,

yes, I understand they are not gone, just not displayed any more. Sure, I can do a View by All, but what I want to do is keep only the selected set showing as I jump between PS and PM.

I'm running PM 4.4.3.1, PS CS2 and XP SP2.

I'm guessing this is not a bug, more of an annoyance.

Thanks
Bruce

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20582
    • View Profile
    • Camera Bits, Inc.
Re: Is this normal behavior?
« Reply #3 on: July 30, 2006, 10:51:54 AM »
Bruce,

yes, I understand they are not gone, just not displayed any more. Sure, I can do a View by All, but what I want to do is keep only the selected set showing as I jump between PS and PM.

I'm running PM 4.4.3.1, PS CS2 and XP SP2.

I'm guessing this is not a bug, more of an annoyance.

How are you switching back into PM?  Are you clicking into the Contact Sheet area?  If so, it might be what is deselecting your images, and when PM refreshes (as it always does when it is resumed) the newly deselected images disappear.

Do you think that's what is going on?

-Kirk

Offline bdickson

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: Is this normal behavior?
« Reply #4 on: July 30, 2006, 04:10:33 PM »
Yep, looks like that's the problem. If I use tagged images instead of color selction, no problem.

Maybe you could think about something like a "Lock Selection" control in a future release?

Thanks
Bruce Dickson

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20582
    • View Profile
    • Camera Bits, Inc.
Re: Is this normal behavior?
« Reply #5 on: July 30, 2006, 06:19:43 PM »
Bruce,

Yep, looks like that's the problem. If I use tagged images instead of color selction, no problem.

Maybe you could think about something like a "Lock Selection" control in a future release?

I think the solution would be to just resume PM in a different way:  Alt-Tab, click on the Program icon in the Taskbar, or click on the Photo Mechanic frame window, but not into the Contact Sheet.  Then your selection won't change.

If we added some "Lock Selection" feature, inevitably, people would forget to engage it...

-Kirk

Offline bdickson

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: Is this normal behavior?
« Reply #6 on: July 30, 2006, 06:42:01 PM »
Yep, that works. Thanks!