Author Topic: PM Keywords not translating to Lightroom?  (Read 4540 times)

Offline theim

  • Member
  • **
  • Posts: 67
    • View Profile
PM Keywords not translating to Lightroom?
« on: September 01, 2009, 08:27:29 PM »
I've been using PM's IPTC Stationery Pad to write keywords to Nikon RAW (NEF) files.
Importing these NEF files into Lightroom (Windows version) has worked really well.  I can make changes to the keywords in PM, then go into LR and LR sees the changes just fine.

However, it is a different story with LR (Mac version).  When I import a RAW file to LR for Mac, the keywords do not match what I see when the same RAW file is viewed in PM or LR (Windows).  The strange thing is that LR Mac displays the keywords that I wrote to the file (using PM) initially.  I have refined my keywords a number of times over the last few weeks.  Each time I make a change to the keywords (using PM), the changes transfer to LR Windows just fine.  But LR Mac seems unable to see any of the new keywords - just the ones PM originally wrote to the RAW file.

Any idea on what could be causing this?

Btw, I have made sure to close Nikon Capture NX2 before keywording with PM, as I've heard there can be issues with NX2 not releasing its hold on a file so that PM can work with it.

PM 4.6.1 (both platforms)
Lightroom 2.4 (both platforms)

Windows XP Professional
Mac OS X 10.5.8

Thanks,
-Tom


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21338
    • View Profile
    • Camera Bits, Inc.
Re: PM Keywords not translating to Lightroom?
« Reply #1 on: September 01, 2009, 09:13:58 PM »
Tom,

I've been using PM's IPTC Stationery Pad to write keywords to Nikon RAW (NEF) files.
Importing these NEF files into Lightroom (Windows version) has worked really well.  I can make changes to the keywords in PM, then go into LR and LR sees the changes just fine.

However, it is a different story with LR (Mac version).  When I import a RAW file to LR for Mac, the keywords do not match what I see when the same RAW file is viewed in PM or LR (Windows).  The strange thing is that LR Mac displays the keywords that I wrote to the file (using PM) initially.  I have refined my keywords a number of times over the last few weeks.  Each time I make a change to the keywords (using PM), the changes transfer to LR Windows just fine.  But LR Mac seems unable to see any of the new keywords - just the ones PM originally wrote to the RAW file.

Any idea on what could be causing this?

Btw, I have made sure to close Nikon Capture NX2 before keywording with PM, as I've heard there can be issues with NX2 not releasing its hold on a file so that PM can work with it.

PM 4.6.1 (both platforms)
Lightroom 2.4 (both platforms)

Windows XP Professional
Mac OS X 10.5.8

Adobe's products have issues with embedded XMP data.  It sounds like you're embedding XMP into your NEF files which works really well with Capture NX2 but causes issues with ACR, Bridge, and Lightroom.  It is not really possible to get the best workflow with NX2 and Lightroom since NX2 ignores XMP sidecar files and only embeds XMP, whereas Lightroom only updates XMP sidecar files but actually prefers to read embedded XMP over the reading of a XMP sidecar file.

You'll need to get PM to update the XMP inside the NEF file in order for Lightroom to see the keywords.
Or use PM's Delete Metadata tool to strip the XMP data from the RAW file and then suddenly Lightroom will start seeing the data in the XMP sidecar file.

HTH,

-Kirk

Offline theim

  • Member
  • **
  • Posts: 67
    • View Profile
Re: PM Keywords not translating to Lightroom?
« Reply #2 on: September 02, 2009, 05:27:48 AM »
Tom,


Adobe's products have issues with embedded XMP data.  It sounds like you're embedding XMP into your NEF files which works really well with Capture NX2 but causes issues with ACR, Bridge, and Lightroom.  It is not really possible to get the best workflow with NX2 and Lightroom since NX2 ignores XMP sidecar files and only embeds XMP, whereas Lightroom only updates XMP sidecar files but actually prefers to read embedded XMP over the reading of a XMP sidecar file.

You'll need to get PM to update the XMP inside the NEF file in order for Lightroom to see the keywords.
Or use PM's Delete Metadata tool to strip the XMP data from the RAW file and then suddenly Lightroom will start seeing the data in the XMP sidecar file.

HTH,

-Kirk


Hi Kirk,

I should have clarified the following:

- I am NOT using NX2 to embed anything.
- I am using PM exclusivley for writing the keywords to the NEF files.

The isssue I am having is that:

- LR (Windows) sees the keyword changes written to the NEF files by PM
- LR (Mac) does NOT see the (latest) keyword changes written to the NEF files by PM

In other words, if I view the same NEF file in both versions of Lightroom (Windows and Mac), the keywords are different.

Please see my prior note about LR for Mac seeing only the initial keywords PM embedded in the NEF files, but not keywords embeddd later on.
This, to me, could indicate an issue with PM.

Oh, and I'm not using Lightroom to write anything to any of my files.  I use PM exclusively to write xmp data, and Lightroom as a read-only DAM tool.
I use NX2 to process my images (ie, white balance, exposure compensation, etc.) but not for keywording, etc.

Thanks,
-Tom

« Last Edit: September 02, 2009, 05:32:29 AM by theim »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21338
    • View Profile
    • Camera Bits, Inc.
Re: PM Keywords not translating to Lightroom?
« Reply #3 on: September 02, 2009, 06:36:19 AM »
Tom,

Adobe's products have issues with embedded XMP data.  It sounds like you're embedding XMP into your NEF files which works really well with Capture NX2 but causes issues with ACR, Bridge, and Lightroom.  It is not really possible to get the best workflow with NX2 and Lightroom since NX2 ignores XMP sidecar files and only embeds XMP, whereas Lightroom only updates XMP sidecar files but actually prefers to read embedded XMP over the reading of a XMP sidecar file.

You'll need to get PM to update the XMP inside the NEF file in order for Lightroom to see the keywords.
Or use PM's Delete Metadata tool to strip the XMP data from the RAW file and then suddenly Lightroom will start seeing the data in the XMP sidecar file.

HTH,

-Kirk


Hi Kirk,

I should have clarified the following:

- I am NOT using NX2 to embed anything.
- I am using PM exclusivley for writing the keywords to the NEF files.

The isssue I am having is that:

- LR (Windows) sees the keyword changes written to the NEF files by PM
- LR (Mac) does NOT see the (latest) keyword changes written to the NEF files by PM

In other words, if I view the same NEF file in both versions of Lightroom (Windows and Mac), the keywords are different.

Please see my prior note about LR for Mac seeing only the initial keywords PM embedded in the NEF files, but not keywords embeddd later on.
This, to me, could indicate an issue with PM.

Oh, and I'm not using Lightroom to write anything to any of my files.  I use PM exclusively to write xmp data, and Lightroom as a read-only DAM tool.
I use NX2 to process my images (ie, white balance, exposure compensation, etc.) but not for keywording, etc.

Are you telling Lightroom to read the metadata again on your Mac?

Since the file isn't spontaneously changing from when you last wrote to it with PM and you can see those changes on the Windows version but not the Mac version of Lightroom it indicates to me that their is either operator error in the usage of the Mac version of Lightroom or the Mac version of Lightroom behaves differently than the Windows version.  You did say you viewed the same NEF file in both versions of Lightroom, right?

-Kirk

Offline theim

  • Member
  • **
  • Posts: 67
    • View Profile
Re: PM Keywords not translating to Lightroom?
« Reply #4 on: September 02, 2009, 06:49:12 AM »

Are you telling Lightroom to read the metadata again on your Mac?


Yes.  Actually, this shouldn't be necessary, as I created a brand new catalog in LR (Mac), then imported the one NEF as a test.  Then, just to be sure, I had LR (Mac) read the metadata from the file again.  Same result:  The keywords displayed for this NEF in LR (Mac) were the ones I orginally wrote to the NEF a week ago using PM 4.6.1 for Windows.  During the past week I have rewritten different keywords to this same NEF using PM 4.6.1 for Windows.  All these changes show up in LR (Windows) but not LR (Mac).


Since the file isn't spontaneously changing from when you last wrote to it with PM and you can see those changes on the Windows version but not the Mac version of Lightroom it indicates to me that their is either operator error in the usage of the Mac version of Lightroom or the Mac version of Lightroom behaves differently than the Windows version.  You did say you viewed the same NEF file in both versions of Lightroom, right?

-Kirk


I have rechecked that the source file is one and the same (same volume, same path, same file).
I just had a thought - I'll state that in a new post...

Offline theim

  • Member
  • **
  • Posts: 67
    • View Profile
Re: PM Keywords not translating to Lightroom?
« Reply #5 on: September 02, 2009, 07:10:25 AM »
Hi Kirk,

Here's my workflow for the particular NEF I'm using as a test:

1.  Open folder containing the NEF in PM 4.6.1 (Windows).  The folder is on an external USB drive.
2.  Apply keywords using PM.  Close PM.
3.  Batch process the same folder in NX2 (Windows), using NX2 for image adjustments, only (ie, white balance, exposure comp, etc.).  Close NX2.
4.  Import the folder into LR 2.4 for Windows - the keywords are all there and match what I see in PM.
5.  Open same folder in PM 4.6.1 (Windows) and make further updates to keywords.
6.  Go back to LR 2.4 for Windows and read the metadata changes in from the source files - the keyword updates are visible.

     (Everything good so far).

7.  Plug the same external USB drive into Mac.
8.  Open a new catalog in LR 2.4 for Mac (an empty catalog).
9.  Import the same folder from the external USB drive.
10. The keywords appear as they did in step 2 above, but not as they do in step 5 above.

I'm still unclear as to why the keywords in an NEF file are different when viewed in LR for Windows and LR for Mac.

The communication between PM 4.6.1 for Windows and LR 2.4 for Windows works just as I would expect.

But keywords written by PM 4.6.1 for Windows and viewed in LR 2.4 for Mac are not the same.
I even opened up PM 4.6.1 for Mac and viewed the keywords in this NEF - they are the same as with PM 4.6.1 for Windows (and LR for Windows).

So I'm having an issue with LR 2.4 for Mac and I don't know why.
Problem is, I sunk $600 into CS4 for Mac and that license is not transferrable to CS4 for Windows.
So I'm committed to Mac for photo work, and that may have been a mistake!

Thanks,
-Tom


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21338
    • View Profile
    • Camera Bits, Inc.
Re: PM Keywords not translating to Lightroom?
« Reply #6 on: September 02, 2009, 08:14:35 AM »
Tom,

Here's my workflow for the particular NEF I'm using as a test:

1.  Open folder containing the NEF in PM 4.6.1 (Windows).  The folder is on an external USB drive.
2.  Apply keywords using PM.  Close PM.
3.  Batch process the same folder in NX2 (Windows), using NX2 for image adjustments, only (ie, white balance, exposure comp, etc.).  Close NX2.
4.  Import the folder into LR 2.4 for Windows - the keywords are all there and match what I see in PM.
5.  Open same folder in PM 4.6.1 (Windows) and make further updates to keywords.
6.  Go back to LR 2.4 for Windows and read the metadata changes in from the source files - the keyword updates are visible.

     (Everything good so far).

7.  Plug the same external USB drive into Mac.
8.  Open a new catalog in LR 2.4 for Mac (an empty catalog).
9.  Import the same folder from the external USB drive.
10. The keywords appear as they did in step 2 above, but not as they do in step 5 above.

I'm still unclear as to why the keywords in an NEF file are different when viewed in LR for Windows and LR for Mac.

The communication between PM 4.6.1 for Windows and LR 2.4 for Windows works just as I would expect.

But keywords written by PM 4.6.1 for Windows and viewed in LR 2.4 for Mac are not the same.
I even opened up PM 4.6.1 for Mac and viewed the keywords in this NEF - they are the same as with PM 4.6.1 for Windows (and LR for Windows).

So I'm having an issue with LR 2.4 for Mac and I don't know why.
Problem is, I sunk $600 into CS4 for Mac and that license is not transferrable to CS4 for Windows.
So I'm committed to Mac for photo work, and that may have been a mistake!

Your workflow indicates an issue with Lightroom on your Mac and not Photo Mechanic.

Are you sure you can't transfer your license to Windows?  Have you tried contacting Adobe and see what they have to say?

-Kirk

Offline theim

  • Member
  • **
  • Posts: 67
    • View Profile
Re: PM Keywords not translating to Lightroom?
« Reply #7 on: September 02, 2009, 08:36:26 AM »
Ok, thanks Kirk.  I'll see how far I get with Adobe.

Best regards,
-Tom

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21338
    • View Profile
    • Camera Bits, Inc.
Re: PM Keywords not translating to Lightroom?
« Reply #8 on: September 02, 2009, 09:45:10 AM »
Tom,

Ok, thanks Kirk.  I'll see how far I get with Adobe.

Just out of curiosity, could you send me a sample file (and XMP sidecar file if any) and let me know what keywords you expect to see in the file?  Please click on my name to the left of this message, then click on the 'personal message' link.  I will respond with upload instructions.

-Kirk

Offline theim

  • Member
  • **
  • Posts: 67
    • View Profile
Re: PM Keywords not translating to Lightroom?
« Reply #9 on: September 02, 2009, 12:55:08 PM »
Hi Kirk,

Just sent you a message - I look forward to your instructions and later, your findings!

Thanks again,
-Tom