Author Topic: Snow Leapard upgrade - functionality missing in PM?  (Read 10673 times)

Offline camerauk

  • Newcomer
  • *
  • Posts: 41
    • View Profile
Re: Snow Leapard upgrade - functionality missing in PM?
« Reply #15 on: September 09, 2009, 11:33:22 PM »
Hmmm, this is my first to this forum, so my brilliant Photo Mechanic  4.6.1 worked fine using Leopard....not a glitch until I put the the upgrade to Snow Leopard on my Macbook last week.
Now when I get in from my assignments, put the flash card in the card reader Photo Mechanic fires up but the ingest dialogue no longer opens up when the camera disc is mounted like it used to. I have to manually open the ingest dialogue... command G... then no discs are selected, this to was automatic before...  so I click on the camera disc which is listed to highlight and select it , then all is as normal. No crashes yet though. So some things are missing...will there be some fixes soon.

I am having the same problem as above

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20596
    • View Profile
    • Camera Bits, Inc.
Re: Snow Leapard upgrade - functionality missing in PM?
« Reply #16 on: September 10, 2009, 12:23:23 AM »
Hmmm, this is my first to this forum, so my brilliant Photo Mechanic  4.6.1 worked fine using Leopard....not a glitch until I put the the upgrade to Snow Leopard on my Macbook last week.
Now when I get in from my assignments, put the flash card in the card reader Photo Mechanic fires up but the ingest dialogue no longer opens up when the camera disc is mounted like it used to. I have to manually open the ingest dialogue... command G... then no discs are selected, this to was automatic before...  so I click on the camera disc which is listed to highlight and select it , then all is as normal. No crashes yet though. So some things are missing...will there be some fixes soon.

I am having the same problem as above

Did you set Image Capture to launch Photo Mechanic?

See my earlier post on how to set it up from within PM.

-Kirk

Offline camerauk

  • Newcomer
  • *
  • Posts: 41
    • View Profile
Re: Snow Leapard upgrade - functionality missing in PM?
« Reply #17 on: September 10, 2009, 04:28:08 PM »
yes followed that was working fine before upgrade also it does seem a bit slower on importing pictures and some times hangs for a few seconds when previewing your ingested pictures

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20596
    • View Profile
    • Camera Bits, Inc.
Re: Snow Leapard upgrade - functionality missing in PM?
« Reply #18 on: September 10, 2009, 05:15:21 PM »
yes followed that was working fine before upgrade also it does seem a bit slower on importing pictures and some times hangs for a few seconds when previewing your ingested pictures

But have you set Image Capture to launch Photo Mechanic after you did the upgrade?

-Kirk

Offline David Alexander Photo

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: Snow Leapard upgrade - functionality missing in PM?
« Reply #19 on: September 11, 2009, 02:37:09 AM »
Hi again Kirk,
so no traction with this/these anomalous problems yet? I guess there must be a lot of folk beginning to regret the upgrade. I have done everything you suggested but Photo Mechanic seems to have acquired a handicap that will need specialist assistance.

cheers David. (Down under (NZ) and perplexed)

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20596
    • View Profile
    • Camera Bits, Inc.
Re: Snow Leapard upgrade - functionality missing in PM?
« Reply #20 on: September 11, 2009, 06:35:10 AM »
David,

so no traction with this/these anomalous problems yet? I guess there must be a lot of folk beginning to regret the upgrade. I have done everything you suggested but Photo Mechanic seems to have acquired a handicap that will need specialist assistance.

So if you go into Image Capture and check to see what it does when a camera disk is mounted, does it say that it will launch Photo Mechanic?  And it doesn't launch it when a camera disk is mounted?

-Kirk

Offline David Alexander Photo

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: Snow Leapard upgrade - functionality missing in PM?
« Reply #21 on: September 12, 2009, 01:59:30 AM »
Hi Kirk,
Ok....
thanks for your patience.. My work flow past wise was this... come in from an assignment start up my macbook (with attached monitor) plug my flash card from the camera into the card reader this would cause Photo Mechanic would launch (I had configured it to do so in preferences) the window would appear,  the ingest box would appear with the named camera disc highlighted ready for me to select a destination or make a new folder.... I would ingest the images then I would tag favourites, view tagged, name, caption, edit in CS4 and either email to a News source or burn to disc. Simple.

Now on plugging in a card (even though I have configured it like you said previously and retried it when it didn't work) Photo Mechanic starts up with a blank window... and does no more. To get my work done I Command G, click on the disc showing in the top left corner (only one shows up, the card from the camera)...I see some folk have several things in that box?..to select it then it is business as usual.

As I mentioned before ...If Photo Mechanic is running then I plug in the card it behaves like the old days, ingest box appears, Card highlighted-selected... business as usual.

So to reiterate Plugging in the card starts the program but inspite of configuring etc refuses to show the ingest box and associated options which one has to do manually once one has figured it out..

Good skills....and luck,
Cheers,
David

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20596
    • View Profile
    • Camera Bits, Inc.
Re: Snow Leapard upgrade - functionality missing in PM?
« Reply #22 on: September 12, 2009, 08:17:06 AM »
David,

thanks for your patience.. My work flow past wise was this... come in from an assignment start up my macbook (with attached monitor) plug my flash card from the camera into the card reader this would cause Photo Mechanic would launch (I had configured it to do so in preferences) the window would appear,  the ingest box would appear with the named camera disc highlighted ready for me to select a destination or make a new folder.... I would ingest the images then I would tag favourites, view tagged, name, caption, edit in CS4 and either email to a News source or burn to disc. Simple.

Now on plugging in a card (even though I have configured it like you said previously and retried it when it didn't work) Photo Mechanic starts up with a blank window... and does no more. To get my work done I Command G, click on the disc showing in the top left corner (only one shows up, the card from the camera)...I see some folk have several things in that box?..to select it then it is business as usual.

As I mentioned before ...If Photo Mechanic is running then I plug in the card it behaves like the old days, ingest box appears, Card highlighted-selected... business as usual.

So to reiterate Plugging in the card starts the program but inspite of configuring etc refuses to show the ingest box and associated options which one has to do manually once one has figured it out..

Got a fix on the way.  Apple changed how applications are launched from the Image Capture system.  Instead of Image Capture itself launching PM, a new background application is launching PM now and it has a different signature so PM wasn't acknowledging it.

-Kirk

Offline David Alexander Photo

  • Newcomer
  • *
  • Posts: 5
    • View Profile
Re: Snow Leapard upgrade - functionality missing in PM?
« Reply #23 on: September 12, 2009, 05:09:58 PM »
Hi Kirk,
absolutely marvelous, thank you in anticipation 100 fold...
hopefully you got some break over the weekend!

I'm off to catch whitebait.... and images of whitebaiters for a few days (Overated Kiwi delicacy...but part of our culture) makes great photos.

cheers,
David.

Offline Ben Curtis

  • Member
  • **
  • Posts: 90
    • View Profile
    • Snappertalk blog
Re: Snow Leapard upgrade - functionality missing in PM?
« Reply #24 on: September 13, 2009, 10:53:43 AM »
Got a fix on the way.  Apple changed how applications are launched from the Image Capture system.  Instead of Image Capture itself launching PM, a new background application is launching PM now and it has a different signature so PM wasn't acknowledging it.
-Kirk

Any idea if the fix will work with the ever-useful Cameras preference-pane?
http://www.flexibits.com/
(To be honest I haven't tried that with 10.6 yet, but just thought I'd mention it as worth considering)

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20596
    • View Profile
    • Camera Bits, Inc.
Re: Snow Leapard upgrade - functionality missing in PM?
« Reply #25 on: September 13, 2009, 12:51:20 PM »
Got a fix on the way.  Apple changed how applications are launched from the Image Capture system.  Instead of Image Capture itself launching PM, a new background application is launching PM now and it has a different signature so PM wasn't acknowledging it.
-Kirk

Any idea if the fix will work with the ever-useful Cameras preference-pane?
http://www.flexibits.com/
(To be honest I haven't tried that with 10.6 yet, but just thought I'd mention it as worth considering)

I don't know if their software is compatible with 10.6 or any changes that 10.6 brought to ImageCapture.  If they've updated it (or tested with 10.6 and found it to work without issues) then I think it will work fine.

-Kirk

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20596
    • View Profile
    • Camera Bits, Inc.
Re: Snow Leapard upgrade - functionality missing in PM?
« Reply #26 on: September 22, 2009, 10:02:37 AM »
Iain,

I am running version 4.6.1 on a MAC Pro with Snow Leopard.  Before updating to Snow Leopard (SL), I could use the RH click of the mouse when on a file to open PM.

After the install of SL this no longer is available.

I have reinstalled the software just in case SL removes this option.

Any ideas to restore functionality?

Please try this:

http://camerabits.fileburst.com/BrowseWithPhotoMechanic.zip

It's a Service that is compatible with the new Finder in Snow Leopard.  There is a ReadMe.txt file that tells you all you need to know in order to get it installed.

Please let me know how you like it (or not) and whether the instructions in the ReadMe are clear and easy to perform.

Thanks,

-Kirk