Author Topic: MAPI and Windows 7 64-bit  (Read 13629 times)

Offline InsightOne

  • Newcomer
  • *
  • Posts: 11
    • View Profile
MAPI and Windows 7 64-bit
« on: November 09, 2009, 02:19:31 pm »
I have been using PM to send photos via e-mail.  All of a sudden I can't send and get a message that I need MAPI.   I think this started last week when I did a clean install of Windows 7 64-bit.  I use Outlook 2007 and Mozilla Firefox.  How do I solve the problem?

Vaughn

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 17922
    • View Profile
    • Camera Bits, Inc.
Re: MAPI and Windows 7 64-bit
« Reply #1 on: November 09, 2009, 02:31:30 pm »
Vaughn,

I have been using PM to send photos via e-mail.  All of a sudden I can't send and get a message that I need MAPI.   I think this started last week when I did a clean install of Windows 7 64-bit.  I use Outlook 2007 and Mozilla Firefox.  How do I solve the problem?

Have you set Outlook 2007 to be your default MAPI client?

-Kirk

Offline InsightOne

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Re: MAPI and Windows 7 64-bit
« Reply #2 on: November 10, 2009, 05:00:44 am »
Honestly, I don't know how to check that. 

Vaughn

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 17922
    • View Profile
    • Camera Bits, Inc.
Re: MAPI and Windows 7 64-bit
« Reply #3 on: November 10, 2009, 06:34:51 am »
Vaughn,

Honestly, I don't know how to check that. 

I don't have Outlook 2007 myself, but there should be some part of the 'Options' dialog where it says something like 'Make Outlook 2007 the default mail handler'...

-Kirk

Offline InsightOne

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Re: MAPI and Windows 7 64-bit
« Reply #4 on: November 10, 2009, 09:53:58 am »
In Outlook under Tools Options there is the choice of default mail handlers.  In my case, Outlook is already selected as the default mail handler.  So that doesn't seem to be the problem.

Vaughn

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 17922
    • View Profile
    • Camera Bits, Inc.
Re: MAPI and Windows 7 64-bit
« Reply #5 on: November 10, 2009, 10:00:55 am »
Vaughn,

In Outlook under Tools Options there is the choice of default mail handlers.  In my case, Outlook is already selected as the default mail handler.  So that doesn't seem to be the problem.

Try setting it to not be the default mail handler (if that's possible) and then close the Options dialog.  Then open the Options dialog again and set Outlook to be the default mail handler again.  This may cause Outlook to update some system settings.

If the above doesn't work, then please call our technical support folks at 503-547-2888 and they'll try and help you solve this directly.

-Kirk

Offline InsightOne

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Re: MAPI and Windows 7 64-bit
« Reply #6 on: November 10, 2009, 04:51:38 pm »
Tried your suggestion. NG.  I'll call tech support.  Thanks for you suggestions.

Offline Ed Zirkle

  • Newcomer
  • *
  • Posts: 40
  • never grow up...
    • View Profile
Re: MAPI and Windows 7 64-bit
« Reply #7 on: November 22, 2009, 07:10:12 am »
Vaughn, Kirk...

Ok, try/do this...  make sure you have the Outlook connector installed to Outlook...

http://office.microsoft.com/en-us/outlook/HA102225181033.aspx

That should take care of any MAPI problems... 


I'm running PM, 462 beta (have update), Win7 64 bit, Outlook 07 w/Outlook connector...

Everything works from a normal install...

I installed Office Pro Plus and from the Office install had 'everything run from my computer' option...

The only 'hickup' is in selecting a name from the address book and the work-around for that is right click, send photo as e-mail and do not select a recipient, hit ok, the e-mail opens and then select the name...

Let me know if you have any additional Windows questions...

Ed

Feed the Shark...