Author Topic: State Field Duplicating in Location  (Read 7322 times)

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21717
    • View Profile
    • Camera Bits, Inc.
Re: State Field Duplicating in Location
« Reply #15 on: December 22, 2009, 12:15:01 AM »
Sorry, I didn't know that's what you wanted. Here it is again:

I downloaded your file and put it into the IPTC Stationery Pad on PM 4.6.2.2 beta 3 and it worked fine for me on several photos.  Could you post a screen shot of the IPTC Info dialog of one of your affected photos?

Thanks,

-Kirk

jla

  • Guest
Re: State Field Duplicating in Location
« Reply #16 on: December 22, 2009, 12:41:27 AM »
I don't have any right now. I'll send you one the next time I see one. This is an example of what it looks like:
City: Sandusky
Location: Oakland Cemetery
State: Oakland Cemetery
Country: USA

Is it possible that it's being overwritten by fields that are stuck in some other software? Picasa might be a likely candidate since it's between somewhere and nowhere when it comes to IPTC.
« Last Edit: December 22, 2009, 12:44:25 AM by jla »

jla

  • Guest
Re: State Field Duplicating in Location
« Reply #17 on: December 24, 2009, 01:57:22 PM »
Here's the screenshot. It's over 100 photos yet again. They were fine, now they're not.





[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21717
    • View Profile
    • Camera Bits, Inc.
Re: State Field Duplicating in Location
« Reply #18 on: December 27, 2009, 07:18:06 PM »
Here's the screenshot. It's over 100 photos yet again. They were fine, now they're not.

The only thing I can suggest to do next is to send you a logging version of PM to try and see what is causing the problem.  Are you interested in helping me solve this issue?

-Kirk

jla

  • Guest
Re: State Field Duplicating in Location
« Reply #19 on: December 27, 2009, 07:49:17 PM »
I can help you with that. Although, unless someone else is also reporting this problem, I'm still thinking Picasa is the cause. I haven't opened it for several days now and I haven't seen a re-occurrence of the problem (yet) in Photo Mechanic.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21717
    • View Profile
    • Camera Bits, Inc.
Re: State Field Duplicating in Location
« Reply #20 on: December 28, 2009, 12:48:13 AM »
I can help you with that. Although, unless someone else is also reporting this problem, I'm still thinking Picasa is the cause. I haven't opened it for several days now and I haven't seen a re-occurrence of the problem (yet) in Photo Mechanic.

Before I go to the effort of adding the logging code, please re-open Picasa and try your tests again.  Let me know if somehow Picasa is causing the problem.

-Kirk

jla

  • Guest
Re: State Field Duplicating in Location
« Reply #21 on: December 28, 2009, 08:35:05 AM »
That could be really painful since I have around 10,000 photos indexed in Picasa with many different addresses. If the State field reverts to the contents of the Location field again, I've got many hours of work to do to fix it, again.

How about if you install Picasa on one of your computers and index just a few pictures and see how that works out? I noticed while I was going back and forth with this, that after being in Picasa and then checking back in PM everything would look fine, and then after the next computer reboot or opening PM a second time, the problem would show up again.

Picasa is quite 'interesting' with how it does or doesn't read/write IPTC info. They've started using the term 'IPTC' lately but it's not even close to the standard. If anything is causing a problem, I'm pretty sure that's it. If PM continues to not show the problem while I stay away from Picasa I'm going to be satisfied I've nailed it and go ahead and uninstall Picasa, or at least wait until they get up to speed. If they ever do.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21717
    • View Profile
    • Camera Bits, Inc.
Re: State Field Duplicating in Location
« Reply #22 on: December 28, 2009, 08:52:33 AM »
That could be really painful since I have around 10,000 photos indexed in Picasa with many different addresses. If the State field reverts to the contents of the Location field again, I've got many hours of work to do to fix it, again.

How about if you install Picasa on one of your computers and index just a few pictures and see how that works out? I noticed while I was going back and forth with this, that after being in Picasa and then checking back in PM everything would look fine, and then after the next computer reboot or opening PM a second time, the problem would show up again.

Picasa is quite 'interesting' with how it does or doesn't read/write IPTC info. They've started using the term 'IPTC' lately but it's not even close to the standard. If anything is causing a problem, I'm pretty sure that's it. If PM continues to not show the problem while I stay away from Picasa I'm going to be satisfied I've nailed it and go ahead and uninstall Picasa, or at least wait until they get up to speed. If they ever do.

Let's make sure we understand what's going on here.  If you take the IPTC Stationery Pad and apply the IPTC you showed me without Picasa open and then immediately examine the IPTC Info of your pictures, do they show the problem?  If not, then I can't see how PM could be at fault unless you do further modification to your photos with PM.  If PM is the only open application and immediately after applying the IPTC Stationery Pad you examine the IPTC Info of your photos and see the issue then it would have to be PM's fault.  Otherwise, I'd suspect that Picasa's indexing of the photos is causing the issue.

-Kirk

jla

  • Guest
Re: State Field Duplicating in Location
« Reply #23 on: December 28, 2009, 09:47:30 AM »
The problem did not show up in PM immediately. I was doing various things with the photos, adding IPTC using the Stationery Pad or the individual info box, adding GPS co-ordinates, making arrangements, renaming, etc. I can't say exactly the order of what I did because I'm trying to straighten out 10,000 photos that have been hacked around with by MediaDex, Adobe Elements, Picasa and ACDSee Pro over the last few years.

But I know after making the additions and changes, everything would look fine in PM. Then I would go over to Picasa and let it re-index the pictures there. Then, I'd go back to PM and everything would look fine. (This was after I was starting to catch on thinking the problem was something to do with Picasa so I was checking it out.) Then, the second or third time after that when I'd look at the pictures in PM, the Location info would be in the State field on dozens or hundreds of photos. Location and State info doesn't even show up in Picasa anywhere, only keywords on jpg's so I don't know what's going on in the background there.

All I'm saying now is that I haven't opened Picasa for the past days and my photos are fine in PM, and I can also view them in XnView without funny things happening. So, I'm guessing the problem is Picasa, but who knows, it might be ACDSee or Adobe. If I see it again, I'll tell you.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21717
    • View Profile
    • Camera Bits, Inc.
Re: State Field Duplicating in Location
« Reply #24 on: December 28, 2009, 10:15:50 AM »
The problem did not show up in PM immediately. I was doing various things with the photos, adding IPTC using the Stationery Pad or the individual info box, adding GPS co-ordinates, making arrangements, renaming, etc. I can't say exactly the order of what I did because I'm trying to straighten out 10,000 photos that have been hacked around with by MediaDex, Adobe Elements, Picasa and ACDSee Pro over the last few years.

But I know after making the additions and changes, everything would look fine in PM. Then I would go over to Picasa and let it re-index the pictures there. Then, I'd go back to PM and everything would look fine. (This was after I was starting to catch on thinking the problem was something to do with Picasa so I was checking it out.) Then, the second or third time after that when I'd look at the pictures in PM, the Location info would be in the State field on dozens or hundreds of photos. Location and State info doesn't even show up in Picasa anywhere, only keywords on jpg's so I don't know what's going on in the background there.

All I'm saying now is that I haven't opened Picasa for the past days and my photos are fine in PM, and I can also view them in XnView without funny things happening. So, I'm guessing the problem is Picasa, but who knows, it might be ACDSee or Adobe. If I see it again, I'll tell you.

OK, sounds good.

-Kirk