Author Topic: Sending photo as email from Mechanic fails and freezes Mechanic  (Read 2618 times)

Offline Whistlingmike

  • Newcomer
  • *
  • Posts: 27
    • View Profile
Sending photo as email from Mechanic fails and freezes Mechanic
« on: January 28, 2010, 12:40:44 PM »
I use the "Send photos via email" feature all the time but for some reason, this not only stopped working yesterday, it locks up Photo Mechanic and I have to force quit the program.  I reopened the program several times but no effect.  I restarted the computer - no effect.  I deleted the preferences - no effect.  I reinstalled the program as well - no effect.  I'm on Mac OS X version 10.5.8, with a 2.33 GHz Intel Core 2 Duo, 4 GB of RAM.  Any help would be most appreciated.  Thanks, Michael  www.lichterphoto.com

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20596
    • View Profile
    • Camera Bits, Inc.
Re: Sending photo as email from Mechanic fails and freezes Mechanic
« Reply #1 on: January 28, 2010, 01:41:25 PM »
Michael,

I use the "Send photos via email" feature all the time but for some reason, this not only stopped working yesterday, it locks up Photo Mechanic and I have to force quit the program.  I reopened the program several times but no effect.  I restarted the computer - no effect.  I deleted the preferences - no effect.  I reinstalled the program as well - no effect.  I'm on Mac OS X version 10.5.8, with a 2.33 GHz Intel Core 2 Duo, 4 GB of RAM.  Any help would be most appreciated.  Thanks, Michael  www.lichterphoto.com

What version of Photo Mechanic are you using?  Which email client are you using?  Are you setting the email utility to 'Review email in email application before sending'?

-Kirk

Offline Whistlingmike

  • Newcomer
  • *
  • Posts: 27
    • View Profile
Re: Sending photo as email from Mechanic fails and freezes Mechanic
« Reply #2 on: January 29, 2010, 03:41:40 PM »
I am on Photo Mechanic 4.6.2.1, the email I use is Apple "Mail" and I have always set it to "Review email in email application before sending". 

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20596
    • View Profile
    • Camera Bits, Inc.
Re: Sending photo as email from Mechanic fails and freezes Mechanic
« Reply #3 on: January 29, 2010, 06:03:27 PM »
I am on Photo Mechanic 4.6.2.1, the email I use is Apple "Mail" and I have always set it to "Review email in email application before sending". 

Does Mail ever come forward or appear to react to Photo Mechanic trying to control it?
Look inside your System.log and Console.log files (use the Console utility program in the Applications/Utilities folder) and see if there are any warning messages that have Mail.app or Photo Mechanic.app listed in the entries.

-Kirk

Offline Whistlingmike

  • Newcomer
  • *
  • Posts: 27
    • View Profile
Re: Sending photo as email from Mechanic fails and freezes Mechanic
« Reply #4 on: January 30, 2010, 06:50:14 AM »
I have started and quit my laptap several times in the last few days but today, the email feature is working again - who knows why or how!  I did go back to searched the logs for the 2-days when it was happening and saw a listing in the "Console Messages" that I presume had something to do with this -
1/27/10 11:34:05 AM com.apple.launchd[75] ([0x0-0x17017].com.camerabits.PhotoMechanic[179]) Exited: Terminated
1/27/10 11:39:10 AM com.apple.launchd[75] ([0x0-0x33033].com.camerabits.PhotoMechanic[343]) Exited: Terminated
1/27/10 11:43:21 AM com.apple.launchd[75] ([0x0-0x36036].com.camerabits.PhotoMechanic[353]) Exited: Terminated
1/27/10 12:00:32 PM com.apple.launchd[75] ([0x0-0x4a04a].com.camerabits.PhotoMechanic[428]) Exited: Terminated
1/27/10 12:31:30 PM com.apple.launchd[73] ([0x0-0x1a01a].com.camerabits.PhotoMechanic[182]) Exited: Terminated
I also searched for "Mail.app" and did not come up with anything.  As far as I could tell, it had no effect on mail prior to it locking up Mechanic.
Thanks, Michael