Author Topic: PM->CNX2->EM2 works, but not EM2->PM with NEFs  (Read 3063 times)

Offline michael33

  • Newcomer
  • *
  • Posts: 35
    • View Profile
PM->CNX2->EM2 works, but not EM2->PM with NEFs
« on: January 25, 2010, 01:33:09 PM »
Hello everyone,

For various reasons, the programs that I use are PM, CNX2 and EM2 under Mac OS 10.6, as well as, Windows XP.
I use PM to ingest, cull, fill out XMP, IPTC and label. I told PM to read XMP first, then to write XMP4IPTC when it comes to RAW files (in my case NEFs). The same for JPGs. Up the workflow, everything is fine: Whatever I ingest, or put in there as information, will be brought through to CNX2 and imported to EM2.
If I change metadata in EM2, then write back to a JPG, the information will be shown in both CNX2 and PM. If I do the same with a NEF, then CNX will only update the classic IPTC fields and will leave the XMP fields empty. PM will show nothing until I tell the program to read the IPTC first. Then, at least the classic IPTC fields are shown again. The thing is... I don´t want to switch the preferences around the whole time and somehow that behaviour gives me the feeling that this metadata workflow is not very consistent. Can anyone help me out on that?

At the moment, my workflow is to develop all Raws to JPG and keep both. As the JPG contains all metadata consistently, I use it as an information container. In this metadata I will also find a reference to the Raw File (I use OBject Name Field for that) which is also given by my naming convention. PM comes in here very handy as I have the ability to show JPG+RAW by using (CTRL+J). Then, I use the update XMP/IPTC-Tool to synchrinize the files again.

Thank you for keeping up the development of your wonderful software! Please keep up your work on the announced Catalogue Software.

Best regards from winterly Germany
Michael

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 22489
    • View Profile
    • Camera Bits, Inc.
Re: PM->CNX2->EM2 works, but not EM2->PM with NEFs
« Reply #1 on: January 25, 2010, 02:03:27 PM »
Michael,

For various reasons, the programs that I use are PM, CNX2 and EM2 under Mac OS 10.6, as well as, Windows XP.
I use PM to ingest, cull, fill out XMP, IPTC and label. I told PM to read XMP first, then to write XMP4IPTC when it comes to RAW files (in my case NEFs). The same for JPGs. Up the workflow, everything is fine: Whatever I ingest, or put in there as information, will be brought through to CNX2 and imported to EM2.
If I change metadata in EM2, then write back to a JPG, the information will be shown in both CNX2 and PM. If I do the same with a NEF, then CNX will only update the classic IPTC fields and will leave the XMP fields empty. PM will show nothing until I tell the program to read the IPTC first. Then, at least the classic IPTC fields are shown again. The thing is... I don´t want to switch the preferences around the whole time and somehow that behaviour gives me the feeling that this metadata workflow is not very consistent. Can anyone help me out on that?

At the moment, my workflow is to develop all Raws to JPG and keep both. As the JPG contains all metadata consistently, I use it as an information container. In this metadata I will also find a reference to the Raw File (I use Object Name Field for that) which is also given by my naming convention. PM comes in here very handy as I have the ability to show JPG+RAW by using (CTRL+J). Then, I use the update XMP/IPTC-Tool to synchrinize the files again.

Could you please post a JPEG screen shot of your IPTC/XMP tab of the Photo Mechanic Preferences dialog?  Use the 'Additional Options...' link when you're composing your response and there you can upload your JPEG screen shot.

Thanks,

-Kirk

Offline michael33

  • Newcomer
  • *
  • Posts: 35
    • View Profile
Re: PM->CNX2->EM2 works, but not EM2->PM with NEFs
« Reply #2 on: January 25, 2010, 02:14:19 PM »
Hello Kirk,

Thank you for your quick response.
Here is the screenshot

Best regards
Michael

[attachment deleted by admin]

Offline michael33

  • Newcomer
  • *
  • Posts: 35
    • View Profile
Re: PM->CNX2->EM2 works, but not EM2->PM with NEFs
« Reply #3 on: February 12, 2010, 01:37:30 AM »
Hello Kirk,

here is the Screenshot of my Mac. I use PM on my Mac workstation and on my Windows notebook. Behaviour is the same on both.

Do you have any idea how to solve this?

Best regards
Michael

[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 22489
    • View Profile
    • Camera Bits, Inc.
Re: PM->CNX2->EM2 works, but not EM2->PM with NEFs
« Reply #4 on: February 12, 2010, 07:20:46 AM »
Michael,

here is the Screenshot of my Mac. I use PM on my Mac workstation and on my Windows notebook. Behaviour is the same on both.

Do you have any idea how to solve this?

Reading your original posting and looking at your settings again gets me thinking that there is no simple solution for your NEFs if you're going to use Expression Media.  EM isn't updating the XMP that exists in the RAW files so the IPTC (which it sounds like they are updating) is getting out of sync with the XMP.  Unless there is some way to get EM to update the XMP, I think you're not going to find a simple solution.

The only thing I can think of is to either shoot RAW+JPEG and use PM's 'Update IPTC/XMP' tool to correct the situation after EM has updated the files, using the JPEG as the source.  Or to shoot RAW only but generate JPEGs after Ingest and then use PM's 'Update IPTC/XMP' tool to correct the situation after EM has updated the files, using the JPEG as the source.

This should cause the XMP data embedded in your NEFs to get updated with the latest changes from EM.  I suggest testing on a small sample of images and see if it works for you.

HTH,

-Kirk
« Last Edit: February 12, 2010, 07:22:26 AM by Kirk Baker »

Offline michael33

  • Newcomer
  • *
  • Posts: 35
    • View Profile
Re: PM->CNX2->EM2 works, but not EM2->PM with NEFs
« Reply #5 on: February 12, 2010, 08:58:46 AM »
Or to shoot RAW only but generate JPEGs after Ingest and then use PM's 'Update IPTC/XMP' tool to correct the situation after EM has updated the files, using the JPEG as the source.

This should cause the XMP data embedded in your NEFs to get updated with the latest changes from EM.  I suggest testing on a small sample of images and see if it works for you.

Hey Kirk,

thanks again for your reply.
I was afraid to hear that answer from you but it is what I thought and what I have experienced so far.

Your suggested workflow, that I quoted, is how I have it done now for some time and as far as I can tell, it is working for me.

The one hope that remains, is that you people will get your catalogue software on the road soon.

Thank you for your efforts and with best regards
Michael