Author Topic: problems renaming with {frame4} digits and EXIF camera {user} data in .CRW files  (Read 3509 times)

Offline designcrusader

  • Newcomer
  • *
  • Posts: 2
    • View Profile
I am using MAC OS X 10.4.7 and Photo Mechanic 4.4.3.2, but I am only experiencing the problems with .CRW files (no problems with my .CR2 files)

I have attached a screen shot that shows how sometimes (not always for some reason) Photo Mechanic does not correctly select the last 4 digits when using the {frame4} variable to rename a file. As shown in the attached image, the rename is setup so that the new file name should have the frame#5982, but instead it is choosing some other number plus the last 3 digits.

I do not encounter this problem with .CR2 files.

Also, as far as the .CRW files are concerned, I am having difficulty getting Photo Mechanic to successfully obtain the {user} or {owner} information from the EXIF, even though I have verified that when I have selected the variable with the Set Info Text... and I have verified that the camera has recorded that data (used CANON EOS Viewer Utility to verify camera data owner info). However, on .CR2 files the owner/user data from the camera (EXIF) seems to work fine and shows up properly in Photo Mechanic.

Overall, I think Photo Mechanic is a superb application.

And I would really appreciate your help on this.

Thanks,
DC


[attachment deleted by admin]

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21742
    • View Profile
    • Camera Bits, Inc.
DC,

I am using MAC OS X 10.4.7 and Photo Mechanic 4.4.3.2, but I am only experiencing the problems with .CRW files (no problems with my .CR2 files)

I have attached a screen shot that shows how sometimes (not always for some reason) Photo Mechanic does not correctly select the last 4 digits when using the {frame4} variable to rename a file. As shown in the attached image, the rename is setup so that the new file name should have the frame#5982, but instead it is choosing some other number plus the last 3 digits.

I do not encounter this problem with .CR2 files.

Also, as far as the .CRW files are concerned, I am having difficulty getting Photo Mechanic to successfully obtain the {user} or {owner} information from the EXIF, even though I have verified that when I have selected the variable with the Set Info Text... and I have verified that the camera has recorded that data (used CANON EOS Viewer Utility to verify camera data owner info). However, on .CR2 files the owner/user data from the camera (EXIF) seems to work fine and shows up properly in Photo Mechanic.

Overall, I think Photo Mechanic is a superb application.

And I would really appreciate your help on this.

It is a known issue.  Version 4.4.3.3 fixes the issue and is going to be released soon.

Sorry for the inconvenience,

-Kirk

Offline designcrusader

  • Newcomer
  • *
  • Posts: 2
    • View Profile
Kirk,

Thank you for the extremely prompt response.
The soon to be released version will address/fix both of the issues I described?

Thanks again.

-- DC


Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21742
    • View Profile
    • Camera Bits, Inc.
DC,

Thank you for the extremely prompt response.
The soon to be released version will address/fix both of the issues I described?

Yes, it should.  If you would like to test a beta version, let me know by clicking on my name to the left of this message and I'll arrange for it.

-Kirk