Author Topic: Smugmug Upload Errors with 4.6.4 Beta 4  (Read 14522 times)

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20635
    • View Profile
    • Camera Bits, Inc.
Re: Smugmug Upload Errors with 4.6.4 Beta 4
« Reply #15 on: May 05, 2010, 07:56:22 PM »
Same... 14 5Mb files without a hitch. Well done, Kirk.

It was Bill Kelly that fixed it.  But what we've done is just an interim fix.  Part of the fix was to use HTTP instead of HTTPS because SmugMug was denying our HTTPS connections.  It would be good to be able to go back to using HTTPS since HTTP is not secure.  The second part of the fix was to only let one file transfer at a time, because quite often our connection to SmugMug was being dropped during the file transfer.  By letting only one file transfer at a time, this problem is solved, but then the upload speed is significantly reduced.

Hopefully we can work these two issues out with the folks from SmugMug and restore the lost functionality.

-Kirk

P.S. Thanks to everyone who reported back that the problems are solved.

Offline ishoot

  • Newcomer
  • *
  • Posts: 10
    • View Profile
Re: Smugmug Upload Errors with 4.6.4 Beta 4
« Reply #16 on: May 08, 2010, 09:42:06 AM »
Hi, I am using the new beta and not getting uploads to work correctly, the uploads will clear without an error and it will even create the new gallery but it never actually adds the photos  ???
I have tried two sets of photos and the issue was the same both times.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20635
    • View Profile
    • Camera Bits, Inc.
Re: Smugmug Upload Errors with 4.6.4 Beta 4
« Reply #17 on: May 08, 2010, 12:25:14 PM »
Hi, I am using the new beta and not getting uploads to work correctly, the uploads will clear without an error and it will even create the new gallery but it never actually adds the photos  ???
I have tried two sets of photos and the issue was the same both times.

Is it reporting any errors?  How about posting a screen shot of the upload progress dialog?

-Kirk

Offline ishoot

  • Newcomer
  • *
  • Posts: 10
    • View Profile
Re: Smugmug Upload Errors with 4.6.4 Beta 4
« Reply #18 on: May 08, 2010, 12:47:07 PM »
Hi, I am using the new beta and not getting uploads to work correctly, the uploads will clear without an error and it will even create the new gallery but it never actually adds the photos  ???
I have tried two sets of photos and the issue was the same both times.

Is it reporting any errors?  How about posting a screen shot of the upload progress dialog?

-Kirk



The weird thing is that there are no errors, it shows each file correctly uploading, but when I check the gallery its empty

Offline derektom

  • Newcomer
  • *
  • Posts: 8
    • View Profile
Re: Smugmug Upload Errors with 4.6.4 Beta 4
« Reply #19 on: May 16, 2010, 07:45:18 AM »
With 4.6.3 Mac, I am getting these errors and with 4.6.4 beta 5, when launched it says the beta version has expired:

TIMESTAMP   STATUS   LOCAL_PATH   SERVICE_TYPE      REMOTE_PATH   SIZE   MD5_DIGEST
2010-05-16 22:42:28   [ERROR]   /Users/derek/Pictures/Photos/2010/2010-05-16 (5DII) rob's farewell, cyberport/2010-05-01@12.17(IMG_9986).JPG   SmugMug   /Applications/Photo Mechanic/Photo Mechanic 4.6.3.app/Contents/ruby/lib/ruby/1.8/resolv-replace.rb:19:in `original_resolv_initialize': Connection refused - connect(2)
2010-05-16 22:42:28   [ERROR]   /Users/derek/Pictures/Photos/2010/2010-05-16 (5DII) rob's farewell, cyberport/2010-05-01@12.18(IMG_9988).JPG   SmugMug   /Applications/Photo Mechanic/Photo Mechanic 4.6.3.app/Contents/ruby/lib/ruby/1.8/resolv-replace.rb:19:in `original_resolv_initialize': Connection refused - connect(2)
2010-05-16 22:42:29   [ERROR]   /Users/derek/Pictures/Photos/2010/2010-05-16 (5DII) rob's farewell, cyberport/2010-05-01@13.10(IMG_9993).JPG   SmugMug   /Applications/Photo Mechanic/Photo Mechanic 4.6.3.app/Contents/ruby/lib/ruby/1.8/resolv-replace.rb:19:in `original_resolv_initialize': Connection refused - connect(2)

Any new beta out that fixes this?

Thanks,
Derek

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20635
    • View Profile
    • Camera Bits, Inc.
Re: Smugmug Upload Errors with 4.6.4 Beta 4
« Reply #20 on: May 16, 2010, 07:57:30 AM »
Derek,

With 4.6.3 Mac, I am getting these errors and with 4.6.4 beta 5, when launched it says the beta version has expired:

TIMESTAMP   STATUS   LOCAL_PATH   SERVICE_TYPE      REMOTE_PATH   SIZE   MD5_DIGEST
2010-05-16 22:42:28   [ERROR]   /Users/derek/Pictures/Photos/2010/2010-05-16 (5DII) rob's farewell, cyberport/2010-05-01@12.17(IMG_9986).JPG   SmugMug   /Applications/Photo Mechanic/Photo Mechanic 4.6.3.app/Contents/ruby/lib/ruby/1.8/resolv-replace.rb:19:in `original_resolv_initialize': Connection refused - connect(2)
2010-05-16 22:42:28   [ERROR]   /Users/derek/Pictures/Photos/2010/2010-05-16 (5DII) rob's farewell, cyberport/2010-05-01@12.18(IMG_9988).JPG   SmugMug   /Applications/Photo Mechanic/Photo Mechanic 4.6.3.app/Contents/ruby/lib/ruby/1.8/resolv-replace.rb:19:in `original_resolv_initialize': Connection refused - connect(2)
2010-05-16 22:42:29   [ERROR]   /Users/derek/Pictures/Photos/2010/2010-05-16 (5DII) rob's farewell, cyberport/2010-05-01@13.10(IMG_9993).JPG   SmugMug   /Applications/Photo Mechanic/Photo Mechanic 4.6.3.app/Contents/ruby/lib/ruby/1.8/resolv-replace.rb:19:in `original_resolv_initialize': Connection refused - connect(2)

Any new beta out that fixes this?

No more betas are available.  We released version 4.6.4 late last week.  See the Announcements section of the forums for details.

-Kirk

Offline derektom

  • Newcomer
  • *
  • Posts: 8
    • View Profile
Re: Smugmug Upload Errors with 4.6.4 Beta 4
« Reply #21 on: May 16, 2010, 08:23:52 AM »
That was quick... Many thanks, Kirk!

Cheers,
Derek

Offline toddbuchanan

  • Newcomer
  • *
  • Posts: 22
    • View Profile
    • Todd Buchanan Corporate & Editorial
Re: Smugmug Upload Errors with 4.6.4 Beta 4
« Reply #22 on: May 18, 2010, 10:22:36 PM »
Anyone noticed if they are not getting concurrent uploads (if they have them checked in their pref panel in smugmug uploads)? I'm using 4.6.4 final (on Both Mac OSX 10.5.x at work and 10.6.3 at home) and I'm only getting one upload at a time, unlike in the past where you would see the two uploads in the upload que dialog box...

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20635
    • View Profile
    • Camera Bits, Inc.
Re: Smugmug Upload Errors with 4.6.4 Beta 4
« Reply #23 on: May 19, 2010, 06:17:26 AM »
Todd,

Anyone noticed if they are not getting concurrent uploads (if they have them checked in their pref panel in smugmug uploads)? I'm using 4.6.4 final (on Both Mac OSX 10.5.x at work and 10.6.3 at home) and I'm only getting one upload at a time, unlike in the past where you would see the two uploads in the upload que dialog box...

We had to disable concurrent uploads because SmugMug was dropping our connections when we had two going at once.  That change got the reliability back.

-Kirk

Offline toddbuchanan

  • Newcomer
  • *
  • Posts: 22
    • View Profile
    • Todd Buchanan Corporate & Editorial
Re: Smugmug Upload Errors with 4.6.4 Beta 4
« Reply #24 on: May 19, 2010, 10:28:37 PM »
Kirk,

Thanks...I figured something was up with that...was hoping it was just a temporary thing in the beta to get stability back but looks like it's stuck at that for awhile...know it's not your fault....Thanks

Offline ishoot

  • Newcomer
  • *
  • Posts: 10
    • View Profile
Re: Smugmug Upload Errors with 4.6.4 Beta 4
« Reply #25 on: May 30, 2010, 07:51:07 PM »
Just tried to do an upload and its not working again, I am using the latest version and successfully uploaded a week ago...

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20635
    • View Profile
    • Camera Bits, Inc.
Re: Smugmug Upload Errors with 4.6.4 Beta 4
« Reply #26 on: May 30, 2010, 11:59:15 PM »
Just tried to do an upload and its not working again, I am using the latest version and successfully uploaded a week ago...

Can you upload to SmugMug via any other application successfully at this time?

-Kirk

Offline ishoot

  • Newcomer
  • *
  • Posts: 10
    • View Profile
Re: Smugmug Upload Errors with 4.6.4 Beta 4
« Reply #27 on: May 31, 2010, 05:50:20 PM »
I moved the files to a folder on the desktop and used the web uploader

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20635
    • View Profile
    • Camera Bits, Inc.
Re: Smugmug Upload Errors with 4.6.4 Beta 4
« Reply #28 on: May 31, 2010, 09:39:47 PM »
I moved the files to a folder on the desktop and used the web uploader

And it worked fine?

-Kirk

Offline ishoot

  • Newcomer
  • *
  • Posts: 10
    • View Profile
Re: Smugmug Upload Errors with 4.6.4 Beta 4
« Reply #29 on: June 01, 2010, 04:14:08 PM »
I moved the files to a folder on the desktop and used the web uploader

And it worked fine?

-Kirk



Worked perfectly, this has been my workaround throughout this process