Author Topic: 4.6.4: Quick Search doesn't work with 1400 images in one contact sheet  (Read 2231 times)

Offline kobold

  • Member
  • **
  • Posts: 51
    • View Profile
    • foto-kobold.de
Hi,

unfortunately I'm in hurry to finish that project and therefore I cannot invest a lot of time to investigate that problem now.
I've a contact sheet holding 1463 images. Quick Search doesn't find anything. If I select a different contact sheet I'm able to search as expected: focal length, camera modell, keywords, everything works fine.

If I use "Find..." everything works fine, too, Quick Search doesn't. Any hint?

Thank you.

Klaus

EDIT: Mac OS X 10.6.3
EDIT 2: "Only search contact sheet items" is selected (Quick Search)
« Last Edit: May 31, 2010, 05:00:33 AM by kobold »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24118
    • View Profile
    • Camera Bits, Inc.
Klaus,

unfortunately I'm in hurry to finish that project and therefore I cannot invest a lot of time to investigate that problem now.
I've a contact sheet holding 1463 images. Quick Search doesn't find anything. If I select a different contact sheet I'm able to search as expected: focal length, camera modell, keywords, everything works fine.

If I use "Find..." everything works fine, too, Quick Search doesn't. Any hint?

EDIT: Mac OS X 10.6.3
EDIT 2: "Only search contact sheet items" is selected (Quick Search)

Without knowing what kind of images and how you have metadata added to them, I really have no idea why it wouldn't work for you.  To speculate, I'd guess you're working with RAW files and your RAW files do not have IPTC embedded in them, but are using XMP sidecar files.  Spotlight does not associate (or search) XMP sidecar files as if their metadata belongs to the RAW file so no results are returned.

I don't know if that is the issue in this case or not.

-Kirk

Offline kobold

  • Member
  • **
  • Posts: 51
    • View Profile
    • foto-kobold.de
Hi,

RAW files, no XMP sidecar. If I move some of the files (drag and drop using PM) into a new folder and open that folder in a new contact sheet then Quick Search works fine. Let's see if this depends to the number of files. I move files to new folder as soon as they are labeled and RAW developed, the more I've moved the less files remain in that "problem" contact sheet.

I come back to you.

Regards

Klaus

Offline kobold

  • Member
  • **
  • Posts: 51
    • View Profile
    • foto-kobold.de
I found it: the folder was on the Spotlight Index exclude list (system preferences)  8) Therefore spotlight was not able to find anything...

Offline humanclock

  • Newcomer
  • *
  • Posts: 11
    • View Profile
I was having the exact same problem too.  It was kind of frustrating.  I didn't have the directory/drive on an exclusion list, but I had to rebuild my spotlight index.

In case anyone else runs into this problem:
http://www.wwco.com/~wls/blog/2007/08/29/rebuilding-spotlights-index-on-os-x-manually/

Basically I just did this part after dropping to the terminal. (be careful with the rm-rf part and don't type in the wrong path/letters!)

sudo mdutil -i on /drive/path
rm -rf /drive/path/.Spotlight*
sudo mdutil -E /drive/path