Author Topic: Spaces in Keywords Wrecking Havoc.or: My Keywords Are A Pile Of Mismatched Socks  (Read 4629 times)

Offline julian

  • Newcomer
  • *
  • Posts: 13
    • View Profile
I'm having the problem of spaces appearing in hierarchical/structured keywords and popping up as duplicates in Lightroom lists and elsewhere. The problem seems to be one that others have had, but I've followed up on the Forum postings about configuring the IPTC/XMP settings and so on.

The situation is that in my keyword hierarchies on import into LR3, I get *duplicates as LR3 treats the leading and trailing whitespace as significant. This *may be more of an LR3 issues — but as well, it seems to me that I should ask in the PM forum if anyone else has had this problem or a solution?

I've posted a screencast film of the situation at the link below. You can see how the PM3 assignment of a structured keyword creates two seemingly identical keyword hierarchies in LR3, which quickly becomes a mess — like having lots of *almost the same socks in a drawer.



Julian

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20263
    • View Profile
    • Camera Bits, Inc.
Julian,

I'm having the problem of spaces appearing in hierarchical/structured keywords and popping up as duplicates in Lightroom lists and elsewhere. The problem seems to be one that others have had, but I've followed up on the Forum postings about configuring the IPTC/XMP settings and so on.

The situation is that in my keyword hierarchies on import into LR3, I get *duplicates as LR3 treats the leading and trailing whitespace as significant. This *may be more of an LR3 issues — but as well, it seems to me that I should ask in the PM forum if anyone else has had this problem or a solution?

I've posted a screencast film of the situation at the link below. You can see how the PM3 assignment of a structured keyword creates two seemingly identical keyword hierarchies in LR3, which quickly becomes a mess — like having lots of *almost the same socks in a drawer.

Make sure you have the "When updating XMP, add Structured Keywords to hierarchical keywords field only" check box checked.  This will keep PM from putting your hierarchical keywords in two places.

-Kirk

Offline julian

  • Newcomer
  • *
  • Posts: 13
    • View Profile
Julian,

Make sure you have the "When updating XMP, add Structured Keywords to hierarchical keywords field only" check box checked.  This will keep PM from putting your hierarchical keywords in two places.

-Kirk

This option is selected. I _think_ the problem has to do with the spaces that exist in front of or after the keywords. The keywords are semantically identical — but because there exists whitespace at either end of the keyword, Lightroom ((being silly)) interprets the keywords as different.

Julian

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20263
    • View Profile
    • Camera Bits, Inc.
Julian,

Make sure you have the "When updating XMP, add Structured Keywords to hierarchical keywords field only" check box checked.  This will keep PM from putting your hierarchical keywords in two places.

This option is selected. I _think_ the problem has to do with the spaces that exist in front of or after the keywords. The keywords are semantically identical — but because there exists whitespace at either end of the keyword, Lightroom ((being silly)) interprets the keywords as different.

What version of Photo Mechanic are you running?

-Kirk

Offline julian

  • Newcomer
  • *
  • Posts: 13
    • View Profile
I'm running 4.6.4.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20263
    • View Profile
    • Camera Bits, Inc.
Julian,

I'm running 4.6.4.

How about posting a JPEG that will cause the unintended behavior to occur when brought into LR, please?

-Kirk

Offline julian

  • Newcomer
  • *
  • Posts: 13
    • View Profile
Julian,

I'm running 4.6.4.

How about posting a JPEG that will cause the unintended behavior to occur when brought into LR, please?

-Kirk


Sure. I just created a nonsense JPEG. I tagged it with a structured keyword in PM:



((http://farm2.static.flickr.com/1301/4702906261_3fddbae934_o.jpg))
((http://www.flickr.com/photos/nearfuturelaboratory/4702906261/in/photostream/))

architecture | building materials | brick

I then import it into LR3 and my keywords look like this (n.b. the duplicates in the hierarchy and the presence of whitespace in front of " brick" (it also exists in front of " building materials" but I just show the " brick" example in the screenshot.)



((((http://www.flickr.com/photos/nearfuturelaboratory/4702906217/in/photostream))

In Preferences, my IPTC/XMP tab has "When updating XMP, add Structured Keywords to hierarchical keywords fields only" selected.

This is what exiftool says about the image:

Reup:Test julian$ exiftool -HierarchicalSubject PeoplePersonJulian.jpg
Hierarchical Subject            : architecture|building materials|brick


Reup:Test julian$ exiftool -Keywords PeoplePersonJulian.jpg
Keywords                        : architecture | building materials | brick


It may be that LR3 is reading both the Hierarchical Subject and the Keywords and because they are different — well, you get semantic duplicates.

Julian

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20263
    • View Profile
    • Camera Bits, Inc.
Julian,

Thanks for the sample image.  The issue is that your image contains XMP (which only has the structured keywords in the hierarchicalSubject portion of the XMP data) and IPTC which has no way to represent hierarchical data other than in the Keywords field.

The solution would be to no longer embed IPTC into your JPEGs.  Embed XMP only.  Lightroom is seeing both sets of metadata and is merging them.

-Kirk

Offline julian

  • Newcomer
  • *
  • Posts: 13
    • View Profile
Julian,

Thanks for the sample image.  The issue is that your image contains XMP (which only has the structured keywords in the hierarchicalSubject portion of the XMP data) and IPTC which has no way to represent hierarchical data other than in the Keywords field.

The solution would be to no longer embed IPTC into your JPEGs.  Embed XMP only.  Lightroom is seeing both sets of metadata and is merging them.

-Kirk



Thanks Kirk — I'm a little confused about how I to not embed IPTC data. I'm not doing it explicitly — I'm just adding keywords using the Structured Keyword features of PM. Is there a preference setting I need to configure?

Julian

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20263
    • View Profile
    • Camera Bits, Inc.
Julian,


Thanks for the sample image.  The issue is that your image contains XMP (which only has the structured keywords in the hierarchicalSubject portion of the XMP data) and IPTC which has no way to represent hierarchical data other than in the Keywords field.

The solution would be to no longer embed IPTC into your JPEGs.  Embed XMP only.  Lightroom is seeing both sets of metadata and is merging them.

Thanks Kirk — I'm a little confused about how I to not embed IPTC data. I'm not doing it explicitly — I'm just adding keywords using the Structured Keyword features of PM. Is there a preference setting I need to configure?

Yes.  In the IPTC/XMP Preferences in the When Writing section, on JPEGs set it to only embed IPTC4XMP.

Note: this won't help any images that already contain IPTC data, only images that don't already have IPTC in them.  This change in settings will keep your new JPEGs from getting IPTC embedded in them.  For all of your existing JPEGs, you can use the Delete Metadata command on the Tools menu to remove any IPTC data.

HTH,

-Kirk

Offline julian

  • Newcomer
  • *
  • Posts: 13
    • View Profile
Julian,


Thanks for the sample image.  The issue is that your image contains XMP (which only has the structured keywords in the hierarchicalSubject portion of the XMP data) and IPTC which has no way to represent hierarchical data other than in the Keywords field.

The solution would be to no longer embed IPTC into your JPEGs.  Embed XMP only.  Lightroom is seeing both sets of metadata and is merging them.

Thanks Kirk — I'm a little confused about how I to not embed IPTC data. I'm not doing it explicitly — I'm just adding keywords using the Structured Keyword features of PM. Is there a preference setting I need to configure?

Yes.  In the IPTC/XMP Preferences in the When Writing section, on JPEGs set it to only embed IPTC4XMP.

Note: this won't help any images that already contain IPTC data, only images that don't already have IPTC in them.  This change in settings will keep your new JPEGs from getting IPTC embedded in them.  For all of your existing JPEGs, you can use the Delete Metadata command on the Tools menu to remove any IPTC data.

HTH,

-Kirk



Does this apply to DNG / RAW files, too? I use almost entirely DNG files that have been converted from NEFs using Adobe DNG Converter prior to manipulating them in PhotoMechanic. Of course I'll test — I just want to make sure I don't confuse myself further.

Thanks for all of your help!

Julian

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20263
    • View Profile
    • Camera Bits, Inc.
Julian,


Thanks for the sample image.  The issue is that your image contains XMP (which only has the structured keywords in the hierarchicalSubject portion of the XMP data) and IPTC which has no way to represent hierarchical data other than in the Keywords field.

The solution would be to no longer embed IPTC into your JPEGs.  Embed XMP only.  Lightroom is seeing both sets of metadata and is merging them.

Thanks Kirk — I'm a little confused about how I to not embed IPTC data. I'm not doing it explicitly — I'm just adding keywords using the Structured Keyword features of PM. Is there a preference setting I need to configure?

Yes.  In the IPTC/XMP Preferences in the When Writing section, on JPEGs set it to only embed IPTC4XMP.

Note: this won't help any images that already contain IPTC data, only images that don't already have IPTC in them.  This change in settings will keep your new JPEGs from getting IPTC embedded in them.  For all of your existing JPEGs, you can use the Delete Metadata command on the Tools menu to remove any IPTC data.


Does this apply to DNG / RAW files, too? I use almost entirely DNG files that have been converted from NEFs using Adobe DNG Converter prior to manipulating them in PhotoMechanic. Of course I'll test — I just want to make sure I don't confuse myself further.

Yes, don't embed IPTC in your RAW files if you're having this issue.  In fact, if you're using Adobe products you definitely shouldn't embed IPTC4XMP either.  DNG files are handled like TIFF/JPEG/PSD files and should have metadata embedded, just not IPTC in your case.

-Kirk