Author Topic: cant apply color class or stars to files  (Read 1399 times)

Offline fearless

  • Newcomer
  • *
  • Posts: 25
    • View Profile
cant apply color class or stars to files
« on: April 08, 2011, 07:42:27 PM »
odd problem here - happening with both 4.66 and latest beta.  running PC with XP2 and I cannot apply color class to the first 20 or so raw files (CR2) in a group of 400!  Cant figure out what differentiates because at a certain point, I can apply the color class!  However, I went back to version 4.6 and no problems at all on same groups of files.  any idea what is going on here?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21709
    • View Profile
    • Camera Bits, Inc.
Re: cant apply color class or stars to files
« Reply #1 on: April 08, 2011, 09:26:58 PM »
odd problem here - happening with both 4.66 and latest beta.  running PC with XP2 and I cannot apply color class to the first 20 or so raw files (CR2) in a group of 400!  Cant figure out what differentiates because at a certain point, I can apply the color class!  However, I went back to version 4.6 and no problems at all on same groups of files.  any idea what is going on here?

No, not at all.  Please post your settings (IPTC/XMP, Files tabs) as JPEG screen shots.  Use the 'Additional Options...' link when you're composing your reply to this message and there you'll be able to upload your JPEG format screen shot.

Thanks,

-Kirk

Offline fearless

  • Newcomer
  • *
  • Posts: 25
    • View Profile
Re: cant apply color class or stars to files
« Reply #2 on: April 09, 2011, 09:16:17 AM »
okay - this is getting even weirder... I can tag/color any photo with version 4.6 however, when I came upon files previously color coded, I am unable to alter in any way.  Not even update the caption on files bearing a color code from another session.  It is as if the files are locked. 

[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21709
    • View Profile
    • Camera Bits, Inc.
Re: cant apply color class or stars to files
« Reply #3 on: April 10, 2011, 06:26:01 AM »
OK, well I certainly wouldn't recommend going back to a really old version of PM 4.6 as a solution.  There is a reason why we release updates: bug fixes and minor enhancements.

As for your settings.  Your Files tab looks fine.  Your IPTC/XMP tab, however, needs some tweaking.  When reading TIFF-based RAW files (CR2 RAW files are TIFF-based RAW files) you're telling PM to read embedded IPTC first and if that doesn't exist, it should read embedded XMP and if that doesn't exist, finally read the XMP sidecar file.  But when writing TIFF-based RAW files, you've told PM you only want to create/update XMP sidecar files and don't want to embed IPTC or XMP, and moreover if PM encounters a file that does have embedded data, that you don't want PM to update it.  These settings are the cause of your issues.

I don't know how long you've had these new settings or for how long you had your old ones and we don't know what your old settings looked like so it may be difficult to solve your issues with old files.

What software do you use to adjust your CR2 files?

At the very least, if you want to work with XMP sidecar files, change your TIFF-based RAW file read order to have XMP sidecar files read first, instead of as a last resort.  And please go back to either 4.6.6 or the 4.6.7 beta in the Announcements section of the forums.

-Kirk

Offline fearless

  • Newcomer
  • *
  • Posts: 25
    • View Profile
Re: cant apply color class or stars to files
« Reply #4 on: April 10, 2011, 08:23:26 AM »
ok - will make the suggested changes with the IPTC and reload the 4.6.6 and see what happens.   I didnt make recent changes to the IPTC - it has always read as it does now.  I  open my CR2 files with either Photoshop or Canon DPP.  I realize 4.6 isnt a solution but it was the only version that would allow me to color code so I could get work done.  I'll give you news...   thanks!