Author Topic: IPTC Stationary Pad issue  (Read 1434 times)

Offline tommycampbell

  • Newcomer
  • *
  • Posts: 4
    • View Profile
IPTC Stationary Pad issue
« on: September 04, 2010, 01:32:09 PM »
I have PM v4.6.5 on OSX 10.6.4. I'm trying to add {year4},{mnn3:lc} to the keyword field in the IPTC Stationary Pad and save it as a template. When I save the template, only the {year4} part gets saved. I can manually put the variables in and everything works fine, I just can't save it as a template/pre-set. Any ideas?



Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20403
    • View Profile
    • Camera Bits, Inc.
Re: IPTC Stationary Pad issue
« Reply #1 on: September 04, 2010, 04:09:05 PM »
Tommy,

I have PM v4.6.5 on OSX 10.6.4. I'm trying to add {year4},{mnn3:lc} to the keyword field in the IPTC Stationary Pad and save it as a template. When I save the template, only the {year4} part gets saved. I can manually put the variables in and everything works fine, I just can't save it as a template/pre-set. Any ideas?

What happens if you use a different variable for the month name, or just remove the 'lc'?  What happens if you put the {mnn3:lc} into a different field?

-Kirk

Offline tommycampbell

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: IPTC Stationary Pad issue
« Reply #2 on: September 05, 2010, 03:49:29 AM »
If I leave off the :lc, it works. I also tried putting the {mmn3:lc} into another field by itself and it kept it. I also put {year4},{mnn3:lc} into another field and saving it works fine. I tried a little experiment by adding {year4}, {mnn3:lc} to every field and saving it. The before image show the dialog before saving to a new name. The after.png image show the dialog after clicking the clear button and reloading it.

[attachment deleted by admin]

Offline tommycampbell

  • Newcomer
  • *
  • Posts: 4
    • View Profile
Re: IPTC Stationary Pad issue
« Reply #3 on: September 05, 2010, 04:24:57 AM »
A little more info:

I just tried reversing the two variables ( {mnn3:lc}, {year4} ) and it saves just fine. I also noticed that if I open up the stationary pad and just put {year4}, {mnn3:lc} and click the Apply Stationary to Selected button, all the selected photos will only have the {year4} variable applied.

If I put another keyword at the end like {year4},{mnn3:lc}, family , the whole thing gets applied.

So it seems I can work around it by putting the {mnn3:lc} first.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20403
    • View Profile
    • Camera Bits, Inc.
Re: IPTC Stationary Pad issue
« Reply #4 on: September 05, 2010, 07:23:53 AM »
Tommy,

A little more info:

I just tried reversing the two variables ( {mnn3:lc}, {year4} ) and it saves just fine. I also noticed that if I open up the stationary pad and just put {year4}, {mnn3:lc} and click the Apply Stationary to Selected button, all the selected photos will only have the {year4} variable applied.

If I put another keyword at the end like {year4},{mnn3:lc}, family , the whole thing gets applied.

So it seems I can work around it by putting the {mnn3:lc} first.

I'll consider that a bug and see what I can do to fix it.  All of the fields that have an issue with {year4},{mnn3:lc} are repeating fields (can contain a list of items separated by commas or optionally, semi-colons) so there must be some issue with that.

Thank you for the detailed explanation.  It really helps a lot.

-Kirk