Author Topic: FIND not finding  (Read 1412 times)

Offline Graham Morgan

  • Newcomer
  • *
  • Posts: 46
    • View Profile
FIND not finding
« on: September 14, 2010, 04:00:09 AM »
Hi All

I have put a list of about 40 file names into the find tool, yet it only finds 20 of the images. All the other images are certainly in the contact sheet, and with exactly the same naming convention.
This happens every now and then and I can't figure it out.

Names are as:

P_Chapman_113212

and I am searching for just number string, like so:

111243                    
133642
111547                    
134034
113323                    
134126
113732                    
134833B
114012                    
135021
114051A                  
144324
115015                    
145830
115046                     
145925 
122030                    
150018
122104                    
150756
122114                     
151434
122146                    
152139
122203                    
152200
122308                    
152241
122310                    
152804
122328                    
154154
122342                   
165246
122704                   
183145
122838                    
183319
123111                    
183548
133635

OSX 10.5.8

Latest PM

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24222
    • View Profile
    • Camera Bits, Inc.
Re: FIND not finding
« Reply #1 on: September 14, 2010, 06:51:55 AM »
Graham,

I have put a list of about 40 file names into the find tool, yet it only finds 20 of the images. All the other images are certainly in the contact sheet, and with exactly the same naming convention.
This happens every now and then and I can't figure it out.

I'm not quite sure what you're saying.  Are the names like this: ?

P_Chapman_111243                    
P_Chapman_133642
P_Chapman_111547                    
P_Chapman_134034
P_Chapman_113323                    
...
P_Chapman_183319
P_Chapman_123111                    
P_Chapman_183548
P_Chapman_133635

And then what specifically is your search string?

What would be best for me to reproduce the problem is to have a list of names that you expect to be found (but not all of them end up selected) and the exact string you searched for (that produced the incorrect result). 

You could use the Export command on the File menu, selecting the template named 'Text Exporter' and use:

{filename}{nl}

in the middle text field.  Leave the header and footer blank.  Prior to running the Export, select only the names you expect to be found (both the found ones and the ones that aren't found) then run the export as above.  Make sure to set the 'Save all as one file' option.  Now you should have a single text file whose contents you can post here.  Then also list the exact string of text you use in the Find command.  Even better would be to post a screen shot of the Find panel with all of your settings in it.

With that information I should be able to reproduce the problem.  Generally if I can reproduce the problem I can also fix it.  You can use the 'Additional Options...' link while your posting your reply to this message to upload your sample files.

Thanks,

-Kirk