Author Topic: SmugMug Uploader Issues - anyone else have this error message ?  (Read 8235 times)

Offline a_mumford

  • Newcomer
  • *
  • Posts: 37
    • View Profile
SmugMug Uploader Issues - anyone else have this error message ?
« on: November 19, 2010, 02:12:25 PM »
Logon keeps failing with the following message "bad server response - categories root element missing".

As far as I can see my categories are still intact if I visit via web ...

PM 4.6.6 / OSX 10.6.5 w latest updates

Offline KBishop

  • Newcomer
  • *
  • Posts: 17
    • View Profile
Re: SmugMug Uploader Issues - anyone else have this error message ?
« Reply #1 on: November 20, 2010, 01:25:54 PM »
I am having this exact issue tying to upload to Smugmug.

Kevin

Same versions as above.

Offline miguelr

  • Newcomer
  • *
  • Posts: 45
    • View Profile
Re: SmugMug Uploader Issues - anyone else have this error message ?
« Reply #2 on: November 20, 2010, 02:32:11 PM »
Same here since last night.


Offline CLOSEUP

  • Newcomer
  • *
  • Posts: 19
    • View Profile
Re: SmugMug Uploader Issues - anyone else have this error message ?
« Reply #3 on: November 21, 2010, 07:17:38 AM »
I too am experiencing the same issue. Starts with Opening connection – then “bad server response - categories root element missing”; I am wondering if this is a Smugmug issue, I don’t remember having any issues last week.

Versions: PM 4.6.6, Windows XP SP3 all patches.

Thanks,

Mark

Offline gdpaige

  • Newcomer
  • *
  • Posts: 31
    • View Profile
Re: SmugMug Uploader Issues - anyone else have this error message ?
« Reply #4 on: November 21, 2010, 07:59:57 PM »
Same problem here. I contacted SmugMug and here is what I just heard back:
We are very sorry for the problem you are having right now. We made a few changes having to do with logging in on the site, and, unfortunately, it affected the login procedure in some of the third-party apps available. The developers of this application will need to make a change to their program to fix the issue. We have contacted the developers affected; however, you may wish to contact them, as well.

It seems like we are on hold for now--very unfortunate.

Kirk:   Any potential for a solution any time soon?  There must be many of us stuck with this glitch. Thanks for any help or advice.

Cheers
Gary

Offline royphotographer

  • Newcomer
  • *
  • Posts: 1
    • View Profile
Re: SmugMug Uploader Issues - anyone else have this error message ?
« Reply #5 on: November 22, 2010, 06:54:16 AM »
Me, too.  Same Photo Mechanic version.  Same email from SmugMug.  A quick fix will sure help my workflow. - Jeff -

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21959
    • View Profile
    • Camera Bits, Inc.
Re: SmugMug Uploader Issues - anyone else have this error message ?
« Reply #6 on: November 22, 2010, 09:21:12 AM »
I will check into this when I get back in town tomorrow.

-Kirk

Offline RonD200

  • Member
  • **
  • Posts: 99
    • View Profile
    • Digital Images by Ron Skinner
Re: SmugMug Uploader Issues - anyone else have this error message ?
« Reply #7 on: November 22, 2010, 02:05:47 PM »
I'm having the same problem!  :(
My Gallery - Digital Images by Ron Skinner
My Blog - Ron's Blog
______________________________________

Offline gdpaige

  • Newcomer
  • *
  • Posts: 31
    • View Profile
Re: SmugMug Uploader Issues - anyone else have this error message ?
« Reply #8 on: November 24, 2010, 07:50:57 AM »
I wonder if we might be able to use one of the other forms designated for another web service (e.g. photoshelter or other) that contains the appropriate fields for the new SmugMug requirements as a quick patch for now.

Any thoughts or successes with this approach out there?
Cheers
Gary

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21959
    • View Profile
    • Camera Bits, Inc.
Re: SmugMug Uploader Issues - anyone else have this error message ?
« Reply #9 on: November 24, 2010, 10:09:47 AM »
Gary,

I wonder if we might be able to use one of the other forms designated for another web service (e.g. photoshelter or other) that contains the appropriate fields for the new SmugMug requirements as a quick patch for now.

Any thoughts or successes with this approach out there?

It's going to require modifications on our end, and no, using code from other Uploader templates would be of no use.

I'll let you know when I have a solution.

-Kirk

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21959
    • View Profile
    • Camera Bits, Inc.
Re: SmugMug Uploader Issues - anyone else have this error message ?
« Reply #10 on: November 24, 2010, 03:51:36 PM »
Everyone,

I have a solution.  Attached (below) is an updated template for SmugMug.  You'll need to replace the current template in your installed Photo Mechanic application with the one included below.

On Windows XP the default location is:

C:\Program Files\Camera Bits\Photo Mechanic 4.6\builtin_templates\upload\SmugMug\

On other Windows versions the path will differ somewhat, but basically all you need to do is find out were PM is installed, open the builtin_templates folder, then the upload folder, then the SmugMug folder and replace the template-main.rb file.

Mac OS X users need to Ctrl-click on the Photo Mechanic application icon in the Finder, choose 'Show Package Contents', then open the 'Contents' folder, followed by the 'builtin_templates' folder, followed by the 'upload' folder, and lastly the 'SmugMug' folder.  Replace the template-main.rb file with the one attached below.

The next update to PM will include this updated template and should be coming in the next few weeks.

Please let me know if you have any issues with the updated SmugMug uploader.

Thanks,

-Kirk


[attachment deleted by admin]

Offline RonD200

  • Member
  • **
  • Posts: 99
    • View Profile
    • Digital Images by Ron Skinner
Re: SmugMug Uploader Issues - anyone else have this error message ?
« Reply #11 on: November 24, 2010, 06:48:08 PM »
Just tried out the new Smugmug template.... works great!!!  ;D

Thanks, Kirk
My Gallery - Digital Images by Ron Skinner
My Blog - Ron's Blog
______________________________________

Offline gdpaige

  • Newcomer
  • *
  • Posts: 31
    • View Profile
Re: SmugMug Uploader Issues - anyone else have this error message ?
« Reply #12 on: November 25, 2010, 05:12:00 AM »
Kirk:  Thanks so much, on behalf of all of us--terrific service!
Cheers, and happy Thanksgiving.
Gary

Offline ramblinwreck

  • Member
  • **
  • Posts: 52
    • View Profile
Re: SmugMug Uploader Issues - anyone else have this error message ?
« Reply #13 on: November 27, 2010, 02:11:59 PM »
Thanks for the fix, I was encountering this too.

-Chris

Offline a_mumford

  • Newcomer
  • *
  • Posts: 37
    • View Profile
Re: SmugMug Uploader Issues - anyone else have this error message ?
« Reply #14 on: December 01, 2010, 01:39:05 PM »
Holy Handsprings Robin, a company that read's it's support forums and fixes things in their product even when it's not their fault ....

That's it I'm switching back to iView .... Oh Wait ....

Thanks Guy's