Author Topic: Strange behaviour ...  (Read 2542 times)

Offline olidie

  • Full Member
  • ***
  • Posts: 182
    • View Profile
Strange behaviour ...
« on: December 03, 2010, 01:04:02 PM »
I have a hard to descripe issue with PM 4.6.6 (PC-Version Windows 7 64bit).
This little info is alway a part of my caption:
 "Foto: Oliver D
--
Veröffentlichung nur nach vorheriger Honorar-Vereinbarung und mit Namensnennung." (Publication terms in german) This is just for some clients whose system can only read the caption part of the IPTC information.

When I enter content in the caption field of stationary pad, before the sentence "Foto: Oliver D", something strange happens as soon as I type Shift+V and then "e". Everything after the "--" is offered to be inserted at this spot. Unfortunately the F of Foto is also highlighted and disappears when I delete the offered text. I know it's quite hard to describe. This did not happen with previous versions.

I guess it has something to do with "--". Any information on this?

Also I would like to say that this version is a little bit unstable. It crashed quite a few times offering only empty thumbnails with black boarders. 4.6.5 ran perfectly.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21661
    • View Profile
    • Camera Bits, Inc.
Re: Strange behaviour ...
« Reply #1 on: December 03, 2010, 01:57:43 PM »
I have a hard to descripe issue with PM 4.6.6 (PC-Version Windows 7 64bit).
This little info is alway a part of my caption:
 "Foto: Oliver D
--
Veröffentlichung nur nach vorheriger Honorar-Vereinbarung und mit Namensnennung." (Publication terms in german) This is just for some clients whose system can only read the caption part of the IPTC information.

When I enter content in the caption field of stationary pad, before the sentence "Foto: Oliver D", something strange happens as soon as I type Shift+V and then "e". Everything after the "--" is offered to be inserted at this spot. Unfortunately the F of Foto is also highlighted and disappears when I delete the offered text. I know it's quite hard to describe. This did not happen with previous versions.

I guess it has something to do with "--". Any information on this?

Where does '--' appear in your text?

I'd guess that it is either Autocomplete or Code Replacement that is interrupting your text input.  Both of which can be turned off.

Perhaps you could post a JPEG screen shot of what the IPTC dialog looks like just before and just after the problem occurs.  Use the 'Additional Options...' link when you're composing your reply to this message and there you'll be able to upload your JPEG format screenshots.

Thanks,

-Kirk

Offline olidie

  • Full Member
  • ***
  • Posts: 182
    • View Profile
Re: Strange behaviour ...
« Reply #2 on: December 06, 2010, 05:50:20 AM »
Thank you Kirk. It has to do with Auto Complete. Once I turn it off, it doesn't happen anymore.

Here are the steps that lead to the inserting of everything following the "--". "V" is okay. As soon as I add an "e" the insertion is offered.
« Last Edit: December 06, 2010, 05:53:35 AM by olidie »

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2523
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: Strange behaviour ...
« Reply #3 on: December 06, 2010, 06:04:18 AM »
Ok, this sounds logical to me; the Veröffentlich… text is know to PM so it offers you this as autocomplete as soon as you enter enough characters of the text. In your case right after the e. If you do not want this text, simply continue typing and the autocomplete text will not be added.

In short: the behaviour you describe is not a bug, but how it is supposed to work.

Hope this helps,
    Hayo
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline olidie

  • Full Member
  • ***
  • Posts: 182
    • View Profile
Re: Strange behaviour ...
« Reply #4 on: December 08, 2010, 02:36:11 AM »
Ok, this sounds logical to me; the Veröffentlich… text is know to PM so it offers you this as autocomplete as soon as you enter enough characters of the text. In your case right after the e. If you do not want this text, simply continue typing and the autocomplete text will not be added.

Well, yes and no. I still think it has something to do with the preceding "--" since nothing happens when I type "Hon" or "Namen". It's just this first word that triggers the insertion. Unfortunately the "F" of "Foto: Oliver D" is also marked. So when I continue typing this letter (and the autocomplete text) is removed.

I did not see this as bug. Rather I suspected a certain functionality of PM that I did not know.