Author Topic: email  (Read 4233 times)

Offline bellie

  • Newcomer
  • *
  • Posts: 7
    • View Profile
email
« on: September 12, 2006, 02:57:35 PM »
I am using photo mechanic to distribute images using email and ftp.
While sending images by email the program has crashed on two seperate occasions wipeing all the addresses in macintosh address book. I am using an Intel imac with 2gb ram
Any help would be appreciated

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20132
    • View Profile
    • Camera Bits, Inc.
Re: email
« Reply #1 on: September 12, 2006, 04:37:59 PM »
I am using photo mechanic to distribute images using email and ftp.
While sending images by email the program has crashed on two seperate occasions wipeing all the addresses in macintosh address book. I am using an Intel imac with 2gb ram
Any help would be appreciated

I don't see how Photo Mechanic can wipe out your Address Book since it only reads addresses, it has no provision for writing them.

What email client are you using to compose and send your messages?

If Photo Mechanic crashes during the emailing process, be sure to file a crash report when the Crash Reporter appears, and describe what you were doing at the time of the crash.  I look at each individual crash report that comes to us for hints as to what is causing the problem.

-Kirk
« Last Edit: September 12, 2006, 04:39:31 PM by Kirk Baker »

Offline bellie

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: email
« Reply #2 on: September 13, 2006, 07:22:29 AM »
Hi Kirk

Typically I am away sending in images into the office the problem has been reported to me so until I get back in the office I won't be able to reproduce the problem,  I use the apple mail program to send emails if this helps

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20132
    • View Profile
    • Camera Bits, Inc.
Re: email
« Reply #3 on: September 13, 2006, 07:25:07 AM »
Typically I am away sending in images into the office the problem has been reported to me so until I get back in the office I won't be able to reproduce the problem,  I use the apple mail program to send emails if this helps

OK, so when you can reproduce the crash, please file a crash report and please note in the report that you're the one with the issue that was posted in the forums.  That would really help.

Thanks,

-Kirk

Offline bellie

  • Newcomer
  • *
  • Posts: 7
    • View Profile
Re: email
« Reply #4 on: September 28, 2006, 04:50:45 AM »
Hi Kirk

I downloaded the new PM version this morning set about sending 37 emails with one image per email, sending to a group that is set up in my address book, and again my address book has been wiped of all the email addressess

This is now the 3rd time it has happened no error report form has been displayed and when it has happeded before the machine has locked up and the report form has been unable to send, any ideas would be appreciated.

I am not having any other problems with the computer it is runnng fine without incident, just when I use PM to send emails.

I am using an intel imac with 2gb of ram running system 10.4.7 the mail program version number is 2.1

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20132
    • View Profile
    • Camera Bits, Inc.
Re: email
« Reply #5 on: September 28, 2006, 07:29:15 AM »
Hi Kirk

I downloaded the new PM version this morning set about sending 37 emails with one image per email, sending to a group that is set up in my address book, and again my address book has been wiped of all the email addressess

This is now the 3rd time it has happened no error report form has been displayed and when it has happeded before the machine has locked up and the report form has been unable to send, any ideas would be appreciated.

I am not having any other problems with the computer it is runnng fine without incident, just when I use PM to send emails.

I am using an intel imac with 2gb of ram running system 10.4.7 the mail program version number is 2.1

I just looked through the code that interacts with the AddressBook framework that Apple provides.  There are only two things that I can see that can wipe out the AddressBook data:  removeRecord: and save, neither of which are called by Photo Mechanic.  Photo Mechanic only reads the addresses and groups out of the AddressBook.  It never adds addresses (persons or groups).

I would suspect that Apple's Mail.app is causing the problem.

My suggestion would be to create a backup of the AddressBook data folder.  You can do this by opening up a Finder window.  Then go to your Home folder.  Then open the Library Folder.  Then open the Application Support folder.  Near the top of the list will be a folder called AddressBook.  It contains the entire AddressBook database.  Select the AddressBook folder.  From the Finder's File menu, choose Duplicate.  If you ever find that your AddressBook is lost again, delete the AddressBook folder and then the duplicate folder can be renamed to "AddressBook", which will restore your settings.  I would shutdown and relaunch the AddressBook application before you do any of the deleting/renaming.

I should add that I use Photo Mechanic via Mail.app version 2.1 to send emails of photos and I have never had this occur to me, nor have we received reports of this happening to anyone else.

HTH,

-Kirk