Author Topic: Slideshow changed with 4.6.7  (Read 2585 times)

Offline Del

  • Newcomer
  • *
  • Posts: 19
    • View Profile
Slideshow changed with 4.6.7
« on: June 06, 2011, 06:37:57 AM »
Hi,
I installed version 4.6.7 on my Windows XP based PC and now slideshow is acting different. I use the sequencer set to about 4 seconds. When I start the slide immediately shows full brightness, dims but never goes black, brightens, starts to dim, then the next slide shows and repeats the process.

Ideas?
Thanks, del

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24131
    • View Profile
    • Camera Bits, Inc.
Re: Slideshow changed with 4.6.7
« Reply #1 on: June 06, 2011, 06:51:28 AM »
I installed version 4.6.7 on my Windows XP based PC and now slideshow is acting different. I use the sequencer set to about 4 seconds. When I start the slide immediately shows full brightness, dims but never goes black, brightens, starts to dim, then the next slide shows and repeats the process.

It's because of the new libSDL that doesn't do gamma fades properly anymore.  We went with the newer libSDL because it has some other benefits (compatibility with Unicode file paths) despite the poor fading.  If you never work on files that have accented characters in their names then you could revert to an older libSDL.

I'll see if I can get some instructions to help you revert to an older version.

-Kirk

Offline Del

  • Newcomer
  • *
  • Posts: 19
    • View Profile
Re: Slideshow changed with 4.6.7
« Reply #2 on: June 07, 2011, 06:15:27 AM »
Thanks, I appreciate looking that up.
del

Offline Bob Russell

  • Camera Bits Staff
  • Full Member
  • *****
  • Posts: 142
    • View Profile
    • Camera Bits, Inc.
Re: Slideshow changed with 4.6.7
« Reply #3 on: June 07, 2011, 12:26:27 PM »
Hi Del,

  I have posted the older SDL.dll at the following location :

http://camerabits.fileburst.com/SDL.dll.zip

  If you are running the 32 bit version of XP, then you just need to replace the SDL.dll file in the system32 folder. The complete path is : 

Computer -> C: -> WINDOWS -> system32 -> SDL.dll

If you have a 64 bit version of XP, then you will need to change the SDL.dll in the SysWOW64 as well as the system32 folder.  The SysWOW64 folder will be next to the system32 folder when sorting by name.

I hope this helps.

regards,

--Bob

Offline Cycleboy

  • Newcomer
  • *
  • Posts: 24
    • View Profile
Re: Slideshow changed with 4.6.7
« Reply #4 on: June 10, 2011, 01:35:04 PM »
I hope this helps.

Yes. it helped, thanks!

Werner

Offline muzdav

  • Newcomer
  • *
  • Posts: 20
    • View Profile
    • Murray Davidson Photography
Re: Slideshow changed with 4.6.7
« Reply #5 on: August 21, 2012, 02:51:36 AM »
I have this same problem on two Windows 7 64 bit PCs.  Can the fix mentioned above be adapted to Win 7?

The issue is present in 4.6.9 and v5

All drivers are up to date.

Thanks,

Murray


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24131
    • View Profile
    • Camera Bits, Inc.
Re: Slideshow changed with 4.6.7
« Reply #6 on: August 21, 2012, 06:32:04 AM »
Murray,

I have this same problem on two Windows 7 64 bit PCs.  Can the fix mentioned above be adapted to Win 7?

Yes, I believe it works fine on Windows 7 as well.

-Kirk

Offline muzdav

  • Newcomer
  • *
  • Posts: 20
    • View Profile
    • Murray Davidson Photography
Re: Slideshow changed with 4.6.7
« Reply #7 on: August 24, 2012, 09:14:20 PM »
Thanks Kirk, the fix did work.

I've put up with that issue for ages!