Author Topic: Gallery 2 upload via Photo Mechanic - connection issue? 301 Moved Permanently?  (Read 2251 times)

Offline aaron

  • Newcomer
  • *
  • Posts: 3
    • View Profile
Mac OS X 10.6.7 Intel Xeon
Photo Mechanic 4.6.7

Hello!

I'm trying to connect to Gallery 2 using Photo Mechanic...
I keep getting this response:
#<Net::HTTPMovedPermanently 301 Moved Permanently readbody=true>
(example2.jpg)

I can upload to Gallery 2 from gallery remote and from the web.
I'm not sure I have the connection settings correct?
(example.jpg)

Cheers!
-Aaron

Information:
Web host: Dreamhost -> Gallery was an auto install feature of Dreamhost

GALLERY INFO:
Gallery URL = aaronpaden.com/gallery/main.php
Gallery version = 2.3.1 core 1.3.0.1
API = Core 7.54, Module 3.9, Theme 2.6, Embed 1.5
PHP version = 5.2.17 cgi-fcgi
Webserver = Apache
Database = pdo_sqlite sqlite 3.3.7, lock.system=flock
Toolkits = ArchiveUpload, Exif, Ffmpeg, Getid3, ImageMagick, jpegtran, LinkItemToolkit, NetPBM, SquareThumb, Thumbnail, Gd
Acceleration = none, none
Operating system = Linux algenib 2.6.32.8-grsec-2.1.14-modsign-xeon-64 #2 SMP Sat Mar 13 00:42:43 PST 2010 x86_64
Default theme = matrix
gettext = enabled
Locale = en_US
Browser = Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10_6_7; en-us) AppleWebKit/533.21.1 (KHTML, like Gecko) Version/5.0.5 Safari/533.21.1



[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20927
    • View Profile
    • Camera Bits, Inc.
Aaron,

Try removing the 'w/' from your connection settings.

HTH,

-Kirk

Offline aaron

  • Newcomer
  • *
  • Posts: 3
    • View Profile
Kirk,

Thanks for the quick response!  Did try that already - tried it again to be sure -
Sent login information to you in a private message - you want to test it and see if you get the same response?

Thanks!
Aaron

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20927
    • View Profile
    • Camera Bits, Inc.
Aaron,

Thanks for the quick response!  Did try that already - tried it again to be sure -
Sent login information to you in a private message - you want to test it and see if you get the same response?

Try adding 'www.' to the beginning of your Remote host.  So it would read:  www.aaronpaden.com

Your server is doing a redirect and the template isn't picking up on it.  The redirect is to www.aaronpaden.com so I think this should work.

HTH,

-Kirk

Offline aaron

  • Newcomer
  • *
  • Posts: 3
    • View Profile

Thanks Kirk!

That was it - the:
#<Net::HTTPMovedPermanently 301 Moved Permanently readbody=true>
error was just the server redirecting to www.myurl.com 
I swear I had tried that - feel kinda silly. 

Cheers!
Aaron