Author Topic: Lightroom - PM Star rating  (Read 4183 times)

Offline Karsten

  • Member
  • **
  • Posts: 66
    • View Profile
    • Photographer Karsten Weirup
Lightroom - PM Star rating
« on: August 17, 2011, 02:43:56 PM »
Hi.
When I rate my pics i PM with stars the ratings don´t show in Lightroom.
I have made a search in earlier posts and made some changes in Pref. but it does not work. I have updated the folder in Ligthroom. Nothing! What am I missing?
Could you please make a screenshot of the correct settings. Please. I am drowning!

PM 4.6.6. MAC 10.6.8

Best Karsten

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20824
    • View Profile
    • Camera Bits, Inc.
Re: Lightroom - PM Star rating
« Reply #1 on: August 17, 2011, 02:54:18 PM »
Karsten,

When I rate my pics i PM with stars the ratings don´t show in Lightroom.
I have made a search in earlier posts and made some changes in Pref. but it does not work. I have updated the folder in Ligthroom. Nothing! What am I missing?
Could you please make a screenshot of the correct settings. Please. I am drowning!

What type of files are you working with?  JPEGs?  RAW?  TIFF?

-Kirk

Offline Karsten

  • Member
  • **
  • Posts: 66
    • View Profile
    • Photographer Karsten Weirup
Re: Lightroom - PM Star rating
« Reply #2 on: August 17, 2011, 03:03:45 PM »
Sorry. RAW. Nikon.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20824
    • View Profile
    • Camera Bits, Inc.
Re: Lightroom - PM Star rating
« Reply #3 on: August 17, 2011, 05:07:10 PM »
Karsten,

Sorry. RAW. Nikon.

Are you having PM always create XMP sidecar files and not embed XMP when writing?

-Kirk

Offline Karsten

  • Member
  • **
  • Posts: 66
    • View Profile
    • Photographer Karsten Weirup
Re: Lightroom - PM Star rating
« Reply #4 on: August 17, 2011, 09:38:13 PM »
Well I am not sure. Could you post a screenshot.
Because of a huge amount of pics I have turned to Lightroom. I used to use Photoshop.

Best Karsten

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20824
    • View Profile
    • Camera Bits, Inc.
Re: Lightroom - PM Star rating
« Reply #5 on: August 17, 2011, 10:44:50 PM »
Karsten,

Well I am not sure. Could you post a screenshot.
Because of a huge amount of pics I have turned to Lightroom. I used to use Photoshop.

Here are the settings I recommend to Adobe software users:


[attachment deleted by admin]

Offline Tony Hall

  • Member
  • **
  • Posts: 78
    • View Profile
    • Tony Hall Photography
Re: Lightroom - PM Star rating
« Reply #6 on: August 18, 2011, 08:06:51 AM »
Hi Kirk,

The settings for "When writing IPTC/XMP:" recommended above differ from the the settings advised in the 4.6.3 manual.

Which should we be using?

Many thanks.

Cheers,
Tony

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20824
    • View Profile
    • Camera Bits, Inc.
Re: Lightroom - PM Star rating
« Reply #7 on: August 18, 2011, 08:15:39 AM »
Tony,

The settings for "When writing IPTC/XMP:" recommended above differ from the the settings advised in the 4.6.3 manual.

Which should we be using?

The only change is that in my above example I enabled IPTC embedding which won't hurt anything and will allow other non-XMP observing applications to pickup IPTC data.  If you don't want your RAW files modified, then don't embed IPTC.

-Kirk

Offline Karsten

  • Member
  • **
  • Posts: 66
    • View Profile
    • Photographer Karsten Weirup
Re: Lightroom - PM Star rating
« Reply #8 on: August 18, 2011, 01:19:45 PM »
Hi.
That was the settings I already had. Still nothing. Hmmm?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20824
    • View Profile
    • Camera Bits, Inc.
Re: Lightroom - PM Star rating
« Reply #9 on: August 18, 2011, 01:25:26 PM »
Karsten,

That was the settings I already had. Still nothing. Hmmm?

What happens if you start out with images straight off the camera, ingest with PM, set rating with PM, and then import into Lightroom?

Does it work then?

-Kirk

Offline Karsten

  • Member
  • **
  • Posts: 66
    • View Profile
    • Photographer Karsten Weirup
Re: Lightroom - PM Star rating
« Reply #10 on: August 18, 2011, 01:41:54 PM »
Then everything is cool!

Offline Karsten

  • Member
  • **
  • Posts: 66
    • View Profile
    • Photographer Karsten Weirup
Re: Lightroom - PM Star rating
« Reply #11 on: August 18, 2011, 01:47:30 PM »
Also I can make changes in rating afterwards in PM update the folder in Lightroom and the changes will show up.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20824
    • View Profile
    • Camera Bits, Inc.
Re: Lightroom - PM Star rating
« Reply #12 on: August 18, 2011, 02:01:48 PM »
Karsten,

Also I can make changes in rating afterwards in PM update the folder in Lightroom and the changes will show up.

OK, so it's just your older files that don't update correctly?

-Kirk

Offline Karsten

  • Member
  • **
  • Posts: 66
    • View Profile
    • Photographer Karsten Weirup
Re: Lightroom - PM Star rating
« Reply #13 on: August 18, 2011, 02:12:04 PM »
Yes. It is only folders earlier imported.
Of course I could just import all the pictures again but then all the changes in the 500+ pictures would be lost.
The problem is that the pictures have been rated in PM for different  uses.

Best karsten

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20824
    • View Profile
    • Camera Bits, Inc.
Re: Lightroom - PM Star rating
« Reply #14 on: August 18, 2011, 04:33:02 PM »
Karsten,

Yes. It is only folders earlier imported.
Of course I could just import all the pictures again but then all the changes in the 500+ pictures would be lost.
The problem is that the pictures have been rated in PM for different  uses.

If I had to guess, I'd think that the files that aren't working correctly have embedded XMP in them.  You can remove the embedded XMP with the 'Revert TIFF-based RAW to original' command on the Tools menu.  You should then be left with unmodified RAW files and XMP sidecar files.  Then LR should be able to update correctly.

-Kirk