Author Topic: Problems with norwegian letters æøå  (Read 7104 times)

Offline tobinor

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Problems with norwegian letters æøå
« on: November 06, 2011, 01:55:40 AM »
Hi!

I have a problem with the norwegian letters æøå becomes æ à  Ã¥ when I send them in to the newspaper I work for. The letters are right when I write IPTC in PhotoMechanic and open it to read in Photoshop and vice versa. The problem appears when i FTP the photos to the newspaper or upload the images directly in the software for publishing on the net (Esenic Content Studio - no FTP). In Esenic i can not change any settings because there is no option for that.

I know there are other photographers for the same newspaper that uses same settings inPM and PS as me, and don't have a problem with æøå. The problem did go away after formatting and re-installing OS X, but suddenly reappeared. Tried do the formatting again, but did not work this time.

I use:
Photoshop CS5
PhotoMechanic 4.6.8 (Latin 10 Scandinavian, checked "Write IPTC as Unicode"
MacBook Pro with OS X (10.6.3)
FileZilla for FTP


Please se attached files. IPTC in the picture is: "Tekst for å vise at særnorske bokstver som æ, ø og å blir feil." but shows up as: "Tekst for Ã¥ vise at særnorske bokstver som æ, ø og Ã¥ blir feil." in the newspapers systems.

Anyone who knows a solution to the problem?

-Tobias

[attachment deleted by admin]
« Last Edit: November 07, 2011, 02:47:44 AM by tobinor »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24217
    • View Profile
    • Camera Bits, Inc.
Re: Problems with norwegian letters æøå
« Reply #1 on: November 06, 2011, 06:56:53 AM »
Tobias,

I have a problem with the norwegian letters æøå becomes æ à Ã¥ when I send them in to the newspaper I work for. The letters are right when I write IPTC in PhotoMechanic and open it to read in Photoshop and vice versa. The problem appears when i FTP the photos to the newspaper or upload the images directly in the software for publishing on the net (Esenic Content Studio - no FTP). In Esenic i can not change any settings because there is no option for that.

I know there are other photographers for the same newspaper that uses same settings inPM and PS as me, and don't have a problem with æøå. The problem did go away after formatting and re-installing OS X, but suddenly reappeared. Tried do the formatting again, but did not work this time.

I use:
Photoshop CS5
PhotoMechanic 4.6.8 (Latin 10 Scandinavian, checked "Write IPTC as Unicode"
MacBook Pro with OS X (10.6.3)
FileZilla for FTP


Please se attached files. IPTC in the picture is: "Tekst for å vise at særnorske bokstver som æ, ø og å blir feil." but shows up as: "Tekst for Ã¥ vise at særnorske bokstver som æ, ø og Ã¥ blir feil." in the newspapers systems.

Can you post a screen shot of your Photo Mechanic IPTC/XMP Preferences pane?

Thanks,

-Kirk

Offline tobinor

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Problems with norwegian letters æøå
« Reply #2 on: November 06, 2011, 12:27:00 PM »
Sorry I forgot to put it in the first post. Here it is!

[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24217
    • View Profile
    • Camera Bits, Inc.
Re: Problems with norwegian letters æøå
« Reply #3 on: November 06, 2011, 02:13:00 PM »
Tobias,

Sorry I forgot to put it in the first post. Here it is!

Thanks.

Are these files JPEGs or RAW files?  What encoding does Esenic Content Studio want to see for IPTC?  Can Esenic Content Studio read XMP?

-Kirk

Offline tobinor

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Problems with norwegian letters æøå
« Reply #4 on: November 06, 2011, 03:21:48 PM »
I shoot RAW, sort and select images in PM before editing in Adobe Camrea Raw/Photoshop to jpg. Then add IPTC to the jpgs.

I don't know what encoding Escenic want to see for IPTC, but on the softwares webpage ( http://www.vizrt.com/products/escenic_content_studio/ ) I can only find the info that it is UTF-8 support throughout the system. Æøå also works fine if i type them in manually in Escenic.

I also have no idea if it reads XMP, but I'm willing to try just about everything. Can try to ask someone about encoding and XMP at work tomorrow.

-Tobias

Offline tobinor

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Problems with norwegian letters æøå
« Reply #5 on: November 25, 2011, 12:11:17 AM »
Have not got any answers from the tech-guy at the newspaper. No one seem to know what encoding the system wants to se or it can read XMP.

Any settings in PM/PS/osX worth trying?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24217
    • View Profile
    • Camera Bits, Inc.
Re: Problems with norwegian letters æøå
« Reply #6 on: November 25, 2011, 12:36:28 AM »
Have not got any answers from the tech-guy at the newspaper. No one seem to know what encoding the system wants to se or it can read XMP.

Any settings in PM/PS/osX worth trying?

I'd just suggest experimenting if you're allowed to.  Try writing IPTC only in Latin10 Scandinavian, leaving the Write IPTC as Unicode checkbox off.  Try writing XMP only.  Save each of your settings tests as a snapshot so you can easily restore them later.  Import your test images into Escenic and see what works best.

HTH,

-Kirk

Offline tobinor

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Problems with norwegian letters æøå
« Reply #7 on: November 25, 2011, 02:56:21 AM »
I have done a little of experimenting with settings and found that if I upgraded Photoshop, set Latin10 Scandinavian and unchecked all checked checkboxes in Photomechanic I will get the following result:

IPTC added in Photoshop is wrong
IPTC added in PhotoMechanics IPTC Stationary Pad is wrong
IPTC added in PhotoMechanic via the "i" button on previews are correct (!)

As I almost never add IPTC in Photoshop, that's not a problem. The big question now is why it works if I use the info-button but not Stationary Pad...

-Tobias

[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24217
    • View Profile
    • Camera Bits, Inc.
Re: Problems with norwegian letters æøå
« Reply #8 on: November 25, 2011, 07:43:45 AM »
Tobias,

I have done a little of experimenting with settings and found that if I upgraded Photoshop, set Latin10 Scandinavian and unchecked all checked checkboxes in Photomechanic I will get the following result:

IPTC added in Photoshop is wrong
IPTC added in PhotoMechanics IPTC Stationary Pad is wrong
IPTC added in PhotoMechanic via the "i" button on previews are correct (!)

As I almost never add IPTC in Photoshop, that's not a problem. The big question now is why it works if I use the info-button but not Stationary Pad...

I don't see how that could be possible since the same code is used in both dialogs to encode IPTC and/or XMP data.

Can you post two images, one updated by the IPTC Info dialog, and one updated by the IPTC Stationery Pad dialog?  Use the 'Additional Options...' link when you're composing your reply to this message and there you'll be able to upload your JPEG files.

Thanks,

-Kirk

Offline tobinor

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Problems with norwegian letters æøå
« Reply #9 on: November 25, 2011, 08:06:04 AM »
Here are screenshots from Escenic.

-Tobias

[attachment deleted by admin]

Offline tobinor

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Problems with norwegian letters æøå
« Reply #10 on: December 01, 2011, 08:20:26 AM »
Any idea what could make this weird problem?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24217
    • View Profile
    • Camera Bits, Inc.
Re: Problems with norwegian letters æøå
« Reply #11 on: December 01, 2011, 09:47:04 AM »
Tobias,

Any idea what could make this weird problem?

No, but I'd sure like to have all three sample images.  Please click on my name to the left of this message, then click on the 'personal message' link.  I will respond with upload instructions.

Thanks,

-Kirk

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24217
    • View Profile
    • Camera Bits, Inc.
Re: Problems with norwegian letters æøå
« Reply #12 on: December 06, 2011, 02:30:53 PM »
Tobias,

Any idea what could make this weird problem?

In the sample images you uploaded:

tobinor_sample_01.jpg  Written in Photoshop.  Contains only XMP which is UTF-8 encoded.
tobinor_sample_02.jpg  Written in PM's IPTC Stationery Pad.  Contains UTF-8 encoded IPTC and XMP which is UTF-8 encoded.
tobinor_sample_03.jpg  Written in PM's IPTC Info. Contains non-encoded IPTC and XMP which is UTF-8 encoded.

Which one works best?  If it is tobinor_sample_03.jpg then Escenic does not know how to deal with UTF-8 encoded data properly.  Do they have an updated version?

-Kirk

Offline tobinor

  • Newcomer
  • *
  • Posts: 9
    • View Profile
Re: Problems with norwegian letters æøå
« Reply #13 on: December 07, 2011, 03:12:00 AM »
Sample 3 is the one that works. I use the latest version of Escenic, but they only use Escenic for publishing on web. The system for paper is acting just like escenic when it comes to iptc.

I think I know whereabout the problem is and it seem nothing can be done before the newspaper do anything to their systems...

Thank you!

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 24217
    • View Profile
    • Camera Bits, Inc.
Re: Problems with norwegian letters æøå
« Reply #14 on: December 07, 2011, 06:02:06 AM »
Tobias,

Sample 3 is the one that works. I use the latest version of Escenic, but they only use Escenic for publishing on web. The system for paper is acting just like escenic when it comes to iptc.

I think I know whereabout the problem is and it seem nothing can be done before the newspaper do anything to their systems...

If #3 is the one that works, then be sure to turn off the 'Write IPTC as Unicode' checkbox in the IPTC/XMP section of the PM Preferences dialog.  Set your 'Default IPTC Encoding' to the 'Latin 10 Scandinavian' item.  You may want to just turn off any embedding of XMP data in your JPEGs and embed only IPTC.  Do not caption in Photoshop since it is only writing out XMP which Escenic does not interpret properly.

Do some tests with some images fresh from the camera.  I think you'll find that both the IPTC Info and IPTC Stationery Pad dialogs will work correctly with your accented characters when brought into Escenic.

HTH,

-Kirk