Author Topic: Annoying Ding  (Read 3166 times)

Offline Eric

  • Full Member
  • ***
  • Posts: 238
    • View Profile
Annoying Ding
« on: October 12, 2006, 07:55:34 PM »
Kirk,

This is not something new but rather something that I hope will be removed in the next few releases. When editing in the preview window, if I zoom an image in and then out, I get a "ding" when applying a color class to the image. It won't ding again on the next image unless I zoom in and out again. I know that it's a small thing, but with 4000 more frames to edit tonight it's just one of those little things chewing on a nerve. ;D

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20501
    • View Profile
    • Camera Bits, Inc.
Re: Annoying Ding
« Reply #1 on: October 12, 2006, 08:02:41 PM »
This is not something new but rather something that I hope will be removed in the next few releases. When editing in the preview window, if I zoom an image in and then out, I get a "ding" when applying a color class to the image. It won't ding again on the next image unless I zoom in and out again. I know that it's a small thing, but with 4000 more frames to edit tonight it's just one of those little things chewing on a nerve. ;D

Please tell me the exact set of steps, including keystrokes, in order to reproduce the issue.

I guess I've never noticed it since I usually have my speakers turned off on my Windows box.

-Kirk

Offline Eric

  • Full Member
  • ***
  • Posts: 238
    • View Profile
Re: Annoying Ding
« Reply #2 on: October 13, 2006, 09:18:40 PM »
In the preview window mouse to the zoom function and click the check box. Now if you press ANY of the numeric keys 0-9 to assign a color class, you will hear the ding. If you uncheck the zoom check box and hit a number key it will ding again. If you ---> to the next image and don't zoom you can assign a color class and there won't be any sound. Checking the zoom checkbox for some reason causes the color class assignment to ding. I REALLY noticed this when I had the sound on my speakers cranked up from an Itunes session and forgot to turn it back down. The full volume ding scared me out of my seat! :o Like I said it's been going on for the last few releases. I was just a little cranky when I posted the original msg. I have a new shooter working for me, and I've never had to assign a trash color class to so much junk. So everything was getting on my nerves.

Eric

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20501
    • View Profile
    • Camera Bits, Inc.
Re: Annoying Ding
« Reply #3 on: October 13, 2006, 09:49:33 PM »
Eric,

In the preview window mouse to the zoom function and click the check box. Now if you press ANY of the numeric keys 0-9 to assign a color class, you will hear the ding. If you uncheck the zoom check box and hit a number key it will ding again. If you ---> to the next image and don't zoom you can assign a color class and there won't be any sound. Checking the zoom checkbox for some reason causes the color class assignment to ding. I REALLY noticed this when I had the sound on my speakers cranked up from an Itunes session and forgot to turn it back down. The full volume ding scared me out of my seat! :o Like I said it's been going on for the last few releases. I was just a little cranky when I posted the original msg. I have a new shooter working for me, and I've never had to assign a trash color class to so much junk. So everything was getting on my nerves.

My guess is that the zoom checkbox now has keyboard focus and it is playing the system beep sound when input arrives that it doesn't handle.

Other ways to zoom:

Type 'z' to toggle zoom mode.
Hold down the Control key and click on an area of interest in the photo.  Control click again to zoom out.

Either of these two methods should stop the dinging.

HTH,

-Kirk