Author Topic: Metadata ingest problem  (Read 1433 times)

Offline zed

  • Newcomer
  • *
  • Posts: 1
    • View Profile
Metadata ingest problem
« on: April 06, 2012, 06:44:54 AM »
My version of photomechanic is 4.6.8 and my operating system is mac OS intel Xeon Version 10.6.8

The problem I am having is, when ingesting NEF RAW + jpeg files (of same image) from Nikon D3X camera (and also Nikon D3 camera)  not all of the metadata is attaching itself to the raw files. It does however all appear on the the jpegs only.

In Photomechanic the fields that are showing empty on the raw files are the fields maked with * stating these fields are only saved in the xmp data format. But, then when opening the files in Adobe Bridge or Photoshop which read XMP the metadata doesn’t appear.


So basically, after applying metadata in PhotoMechanic during ingest, the fields such as name, address, website don’t appear in the metadata when viewed in Photoshop/Bridge.
 

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20253
    • View Profile
    • Camera Bits, Inc.
Re: Metadata ingest problem
« Reply #1 on: April 06, 2012, 08:03:28 AM »
My version of photomechanic is 4.6.8 and my operating system is mac OS intel Xeon Version 10.6.8

The problem I am having is, when ingesting NEF RAW + jpeg files (of same image) from Nikon D3X camera (and also Nikon D3 camera)  not all of the metadata is attaching itself to the raw files. It does however all appear on the the jpegs only.

In Photomechanic the fields that are showing empty on the raw files are the fields maked with * stating these fields are only saved in the xmp data format. But, then when opening the files in Adobe Bridge or Photoshop which read XMP the metadata doesn’t appear.


So basically, after applying metadata in PhotoMechanic during ingest, the fields such as name, address, website don’t appear in the metadata when viewed in Photoshop/Bridge.

In the IPTC/XMP section of the Photo Mechanic Preferences dialog under "When writing IPTC/XMP"/"For TIFF-based RAW photos" you need to set the popup menu to read "Always create and/or update XMP sidecar file with IPTC4XMP"

Without this setting all XMP-only fields will not be represented on your RAW photos.  The fields you listed are only represented in XMP data.

You should of course set the Read side of the settings to search for XMP sidecar files first for your TIFF-based RAW photos.

HTH,

-Kirk

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2431
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: Metadata ingest problem
« Reply #2 on: April 06, 2012, 01:10:24 PM »
In the IPTC/XMP section of the Photo Mechanic Preferences dialog under "When writing IPTC/XMP"/"For TIFF-based RAW photos" you need to set the popup menu to read "Always create and/or update XMP sidecar file with IPTC4XMP"

Without this setting all XMP-only fields will not be represented on your RAW photos.  The fields you listed are only represented in XMP data.

You should of course set the Read side of the settings to search for XMP sidecar files first for your TIFF-based RAW photos.

Kirk, sorry to correct/expand you here  ;)

You don't need to create sidecar files at all to be able to have XMP inside the raw files, just need to select "Add Embedded IPTC4XMP" for Tiff based raw files on the IPTC/XMP preference pane. Now your raw files will have embedded XMP (which is readable by Nikon Capture NX2, Adobe products, etc.)

Cheers,
Hayo
Hayo Baan - Photography
Web: www.hayobaan.nl

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20253
    • View Profile
    • Camera Bits, Inc.
Re: Metadata ingest problem
« Reply #3 on: April 06, 2012, 02:59:31 PM »
Hayo,

In the IPTC/XMP section of the Photo Mechanic Preferences dialog under "When writing IPTC/XMP"/"For TIFF-based RAW photos" you need to set the popup menu to read "Always create and/or update XMP sidecar file with IPTC4XMP"

Without this setting all XMP-only fields will not be represented on your RAW photos.  The fields you listed are only represented in XMP data.

You should of course set the Read side of the settings to search for XMP sidecar files first for your TIFF-based RAW photos.

Kirk, sorry to correct/expand you here  ;)

You don't need to create sidecar files at all to be able to have XMP inside the raw files, just need to select "Add Embedded IPTC4XMP" for Tiff based raw files on the IPTC/XMP preference pane. Now your raw files will have embedded XMP (which is readable by Nikon Capture NX2, Adobe products, etc.)

No problem.  But since he mentioned using Adobe products and since we know that Adobe's products will never update embedded XMP in RAW files, I do not suggest he embeds XMP into his RAW files.  He will experience no metadata synchronization issues that way.

-Kirk