Author Topic: IPTC Variables Not Filling IN  (Read 5262 times)

Offline jlfmedia

  • Newcomer
  • *
  • Posts: 6
    • View Profile
IPTC Variables Not Filling IN
« on: July 06, 2012, 07:11:17 AM »
Hey Guys,

Loving the speed of V5 just having an issue with IPTC variables not filling in as before. I haven't changed anything that I was doing in 4.6.9 and I even reloaded the variables in V5 to make sure they hadn't change. Any idea what is causing this it not to fill in now? I attached to screen shots to show before and after.

[attachment deleted by admin]

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20927
    • View Profile
    • Camera Bits, Inc.
Re: IPTC Variables Not Filling IN
« Reply #1 on: July 06, 2012, 07:17:25 AM »
Loving the speed of V5 just having an issue with IPTC variables not filling in as before. I haven't changed anything that I was doing in 4.6.9 and I even reloaded the variables in V5 to make sure they hadn't change. Any idea what is causing this it not to fill in now? I attached to screen shots to show before and after.

At what point in your workflow are you using these specific variables?  During Ingest?  After Ingest?  Do the photos have an IPTC date applied to them before you use those variables?

-Kirk

Offline jlfmedia

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: IPTC Variables Not Filling IN
« Reply #2 on: July 06, 2012, 08:43:24 AM »
It's at the point of Ingest and it's not working post Ingest either, same thing that I did in 4.6.9 works just as normal.

Offline Sven

  • Uber Member
  • ******
  • Posts: 1022
    • View Profile
Re: IPTC Variables Not Filling IN
« Reply #3 on: July 06, 2012, 08:53:19 AM »
Hi!

I tried your variables in one of my images.

variables: {iptcdow}, {iptcmonthnameap} {iptcday}, {tyr4}
result: Friday, June 29, 2012

This is done post-ingest

I gave it a try on a virtual Windows system, too.
During ingest it works also.

As the only date-related variable returned is {tyr4} (what is the year of today, what is the output of the variable {iptcyear4} on your end?
Open up the IPTC-Data, paste the variable and option-klick "OK" to get the variable evaluated without saving.

Sven
Changed from behind the cam to one who buys images as I started to run. No cam or lens left.

Offline jlfmedia

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: IPTC Variables Not Filling IN
« Reply #4 on: July 06, 2012, 09:13:57 AM »
Yup that killed the year as well by switching to {iptcyear4} So something is wrong with the IPTC variables in 5 then? The same string of variables works just fine in 4.6.9.

Offline Sven

  • Uber Member
  • ******
  • Posts: 1022
    • View Profile
Re: IPTC Variables Not Filling IN
« Reply #5 on: July 06, 2012, 09:16:52 AM »
Would you mind to post the image here on the forum?
Just save it with some pixels in dimensions.
klick on attachments below the textbox.

Just the metadata is needed to be in the image.

Variables on PM 5 Beta 1 work as expected to do.

Sven
Changed from behind the cam to one who buys images as I started to run. No cam or lens left.

Offline jlfmedia

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: IPTC Variables Not Filling IN
« Reply #6 on: July 06, 2012, 09:31:36 AM »
Something has to be different with how it works in 5 because the exact same workflow/string works in 4.6.9 I haven't changed anything. Attached is a photo with the no working variables.

[attachment deleted by admin]

Offline Sven

  • Uber Member
  • ******
  • Posts: 1022
    • View Profile
Re: IPTC Variables Not Filling IN
« Reply #7 on: July 06, 2012, 09:34:44 AM »
Thanks for the Image...
I tested it on my machine by just pasting the variables as above ({iptcdow}, {iptcmonthnameap} {iptcday}, {tyr4}) an I got the result: Thursday, July 5, 2012

That's done with PM 5 Beta 1 on OS X 10.7.4
Changed from behind the cam to one who buys images as I started to run. No cam or lens left.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20927
    • View Profile
    • Camera Bits, Inc.
Re: IPTC Variables Not Filling IN
« Reply #8 on: July 06, 2012, 09:45:14 AM »
I get the same results as Sven.

Could you post a screen shot of your IPTC/XMP preferences, please?  Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your JPEG format screenshot.

Thanks,

-Kirk

Offline jlfmedia

  • Newcomer
  • *
  • Posts: 6
    • View Profile
Re: IPTC Variables Not Filling IN
« Reply #9 on: July 06, 2012, 09:58:49 AM »
So is there something that gets changed at default? I haven't touched this any options nor did I in 4.6.9

[attachment deleted by admin]

Offline Sven

  • Uber Member
  • ******
  • Posts: 1022
    • View Profile
Re: IPTC Variables Not Filling IN
« Reply #10 on: July 06, 2012, 10:05:46 AM »
I set my IPTC/XMP prefs now like you have.
I got the same result as before. Variables get evaluated the right way.

Sven
Changed from behind the cam to one who buys images as I started to run. No cam or lens left.

Offline oryk

  • Full Member
  • ***
  • Posts: 187
    • View Profile
Re: IPTC Variables Not Filling IN
« Reply #11 on: July 06, 2012, 01:35:57 PM »
Hey Guys,

Loving the speed of V5 just having an issue with IPTC variables not filling in as before. I haven't changed anything that I was doing in 4.6.9 and I even reloaded the variables in V5 to make sure they hadn't change. Any idea what is causing this it not to fill in now? I attached to screen shots to show before and after.

I have the same problem with <{iptcday0}.{iptcmonth0}.{iptcyear4}> in PM5beta. PM 4.6.9 works fine.

-Oryk
-Oryk

( MAC, OS 10.11 )

Offline Sven

  • Uber Member
  • ******
  • Posts: 1022
    • View Profile
Re: IPTC Variables Not Filling IN
« Reply #12 on: July 06, 2012, 01:38:12 PM »
I have the same problem with <{iptcday0}.{iptcmonth0}.{iptcyear4}> in PM5beta. PM 4.6.9 works fine
Hi Oryk!

At what stage you are using the variables? During ingest or at a later stage?

Sven
Changed from behind the cam to one who buys images as I started to run. No cam or lens left.

Offline oryk

  • Full Member
  • ***
  • Posts: 187
    • View Profile
Re: IPTC Variables Not Filling IN
« Reply #13 on: July 06, 2012, 02:01:20 PM »
I have the same problem with <{iptcday0}.{iptcmonth0}.{iptcyear4}> in PM5beta. PM 4.6.9 works fine
Hi Oryk!

At what stage you are using the variables? During ingest or at a later stage?

Sven

at a later stage.
-Oryk

( MAC, OS 10.11 )

Offline Sven

  • Uber Member
  • ******
  • Posts: 1022
    • View Profile
Re: IPTC Variables Not Filling IN
« Reply #14 on: July 06, 2012, 10:28:23 PM »
Hi oryk!

Could you please try it with the public Beta 2?
I don't if there has been anything changed...

Sven
Changed from behind the cam to one who buys images as I started to run. No cam or lens left.