Author Topic: Color Class being added during igest  (Read 3452 times)

Offline Rguzmanphoto

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Color Class being added during igest
« on: July 07, 2012, 08:25:02 PM »
Just ingested a card from a baseball game and all pics were added a green color class. Not sure if this is a glitch or if I need to reset something. I just tried on 4.6.9 and this did not happen. Macbook pro 10.6.8

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Color Class being added during igest
« Reply #1 on: July 07, 2012, 08:28:45 PM »
Just ingested a card from a baseball game and all pics were added a green color class. Not sure if this is a glitch or if I need to reset something. I just tried on 4.6.9 and this did not happen. Macbook pro 10.6.8

Did you set the IPTC Stationery Pad to apply a Color Class?

-Kirk

Offline Rguzmanphoto

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: Color Class being added during igest
« Reply #2 on: July 07, 2012, 09:15:30 PM »
Here is my IPTC Stationery Pad during ingest nothing is checked. Is this a new choice and I need to check the no color class and no star?

[attachment deleted by admin]

Offline Rguzmanphoto

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: Color Class being added during igest
« Reply #3 on: July 07, 2012, 09:24:03 PM »
Kirk, just ran into another problem, in contact sheet-select all images go to Images - Set Color Class - select None. Color class did not change stayed green.

Thank
Romeo

Offline Sven

  • Uber Member
  • ******
  • Posts: 1022
    • View Profile
Re: Color Class being added during igest
« Reply #4 on: July 07, 2012, 09:45:32 PM »
Hi Romeo!
WHat is set in the IPTC/XMP preferences?
Could you pls. post a screenshot?

Sven
« Last Edit: July 07, 2012, 09:53:47 PM by SK-Foto »
Changed from behind the cam to one who buys images as I started to run. No cam or lens left.

Offline Rguzmanphoto

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: Color Class being added during igest
« Reply #5 on: July 07, 2012, 10:02:45 PM »
I am able to change color to any color, but if I try to change it to no color it does not change

[attachment deleted by admin]

Offline Sven

  • Uber Member
  • ******
  • Posts: 1022
    • View Profile
Re: Color Class being added during igest
« Reply #6 on: July 08, 2012, 05:16:25 AM »
Hi Romeo!

Have you set an "urgency" in the IPTC-Data during the ingest?

Sven
Changed from behind the cam to one who buys images as I started to run. No cam or lens left.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Color Class being added during igest
« Reply #7 on: July 08, 2012, 05:34:38 AM »
Romeo,

Can I see a screen shot of your Files settings in the Preferences dialog?

Thanks,

-Kirk

Offline Rguzmanphoto

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: Color Class being added during igest
« Reply #8 on: July 08, 2012, 06:12:18 AM »
Romeo,

Can I see a screen shot of your Files settings in the Preferences dialog?

Thanks,

-Kirk

File Preference



[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Color Class being added during igest
« Reply #9 on: July 08, 2012, 06:19:41 AM »
Romeo,

If you click on a thumbnail's color class button and change the color class there, does it change?

Can you post one of your JPEGs?  Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your JPEG file.

Thanks,

-Kirk

Offline Rguzmanphoto

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: Color Class being added during igest
« Reply #10 on: July 08, 2012, 06:39:27 AM »
Kirk, I can change to any color, but will not allow none from any color.

[attachment deleted by admin]

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2478
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: Color Class being added during igest
« Reply #11 on: July 08, 2012, 11:29:21 AM »
Hi Romeo,

I had a look at your image and when I first looked at it in PM, I saw it tagged, but unrated and without colour class. However, when I then looked at the meta data more closely using exiftool, I noticed that indeed the colour class is set. I have the urgency field synchronisation with colour class turned-on though and as the urgency is 0, I don't see it in PM (the urgency field has highest priority).

Your image:
Code: [Select]
Prefs                           : Tagged:1, ColorClass:5, Rating:0, FrameNum:016981
Urgency                         : 0 (reserved)
Label                           :
Color Class                     : 5

After force a rewrite of the meta data by changing a random field:
Code: [Select]
Prefs                           : Tagged:1, ColorClass:0, Rating:0, FrameNum:016981
Urgency                         : 0 (reserved)
Label                           :
Color Class                     : 0
As expected everything is now fine (rewriting the meta data resyncs urgency with colour class). However, it looks like you don't have the urgency field synchronise with colour class so it is likely there lies the fault in PM somewhere.

Kirk, hope this helps you find the problem.
Hayo Baan - Photography
Web: www.hayobaan.nl

Offline Rguzmanphoto

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: Color Class being added during igest
« Reply #12 on: July 11, 2012, 02:45:12 PM »
Thanks Hayo, hope all your research helps and they find a fix. I found a temp fix right now by changing the color to gray to match the back ground.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20631
    • View Profile
    • Camera Bits, Inc.
Re: Color Class being added during igest
« Reply #13 on: July 13, 2012, 06:07:54 PM »
Romeo,

Give Public Beta 3 a try.  It shouldn't have this problem anymore.

http://forums.camerabits.com/index.php?topic=7370.0

-Kirk

Offline Rguzmanphoto

  • Full Member
  • ***
  • Posts: 105
    • View Profile
Re: Color Class being added during igest
« Reply #14 on: July 13, 2012, 07:35:56 PM »
Kirk, just tried the beta 3 and it is still adding a color during ingest, also once ingested I still cannot select none as a color. In preference - General - color class #5 is what is being added on ingest, my work around is to make #5 white and then change to my other colors later.

[attachment deleted by admin]