Author Topic: Bug requiring restart of PM while deleting images in v5  (Read 4270 times)

Offline SamFrost

  • Full Member
  • ***
  • Posts: 241
    • View Profile
    • Sam Frost Photography
Bug requiring restart of PM while deleting images in v5
« on: August 16, 2012, 03:52:36 AM »
While viewing photos using the Preview window, deleting photos too quickly causes a problem.  I'm using the Opt-backspace key combo to delete them without a confirmation dialog and if you delete several files consecutively and do it too quickly, the progress bar window comes up and won't go away.  The Abort button does nothing.  Although I can continue to select different images in the contact sheet, PM then stops redrawing the sheet or Preview window.   I have to Quit (but not Force Quit) PM to progress. 

If the frontmost window is the contact sheet, it seems to work OK.  If the frontmost window is the Preview window (I have two monitors so have the preview and contact sheet visible at the same time) I can repeat this effect.

I'm using PM 5.0, build 13158 (7de0ba6), on OSX 10.7.4.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21908
    • View Profile
    • Camera Bits, Inc.
Re: Bug requiring restart of PM while deleting images in v5
« Reply #1 on: August 16, 2012, 06:35:02 AM »
Sam,

While viewing photos using the Preview window, deleting photos too quickly causes a problem.  I'm using the Opt-backspace key combo to delete them without a confirmation dialog and if you delete several files consecutively and do it too quickly, the progress bar window comes up and won't go away.  The Abort button does nothing.  Although I can continue to select different images in the contact sheet, PM then stops redrawing the sheet or Preview window.   I have to Quit (but not Force Quit) PM to progress. 

If the frontmost window is the contact sheet, it seems to work OK.  If the frontmost window is the Preview window (I have two monitors so have the preview and contact sheet visible at the same time) I can repeat this effect.

I'm using PM 5.0, build 13158 (7de0ba6), on OSX 10.7.4.

A fix for this issue is coming in the next build.

-Kirk

Offline Catto

  • Newcomer
  • *
  • Posts: 17
    • View Profile
Re: Bug requiring restart of PM while deleting images in v5
« Reply #2 on: August 17, 2012, 10:56:39 PM »
Just an FYI, having the same problem here with PM 5.0, build 13158 (7de0ba6) and OSX 10.8 (Mountain Lion) on a MacBook Pro 15" Early 2011 model, 2.2 GHz Intel Core i7 chip, 8GB of RAM.  Good to know it's already under investigation, thanks Kirk!
R

Offline Catto

  • Newcomer
  • *
  • Posts: 17
    • View Profile
Re: Bug requiring restart of PM while deleting images in v5
« Reply #3 on: August 19, 2012, 03:47:46 PM »
Actually, this is driving me a bit nuts today - got 2,000 images to edit from a shoot on the weekend, and having to quit & restart every ten minutes at most because the progress bar locks up.  Any odds of a beta with the fix coming soon?

Cheers Kirk,
R

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21908
    • View Profile
    • Camera Bits, Inc.
Re: Bug requiring restart of PM while deleting images in v5
« Reply #4 on: August 19, 2012, 08:16:42 PM »
Actually, this is driving me a bit nuts today - got 2,000 images to edit from a shoot on the weekend, and having to quit & restart every ten minutes at most because the progress bar locks up.  Any odds of a beta with the fix coming soon?

No beta.  New build.  Likely tomorrow.

-Kirk

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21908
    • View Profile
    • Camera Bits, Inc.
Re: Bug requiring restart of PM while deleting images in v5
« Reply #5 on: August 22, 2012, 11:54:06 AM »
This problem should now be fixed.

http://forums.camerabits.com/index.php?topic=7679.0

-Kirk