Author Topic: Is Canon 5D Mk3 fully supported in v4 or do I need to upgrade to v5?  (Read 2605 times)

Offline Tony Hall

  • Member
  • **
  • Posts: 78
    • View Profile
    • Tony Hall Photography
Hello,

I tried to search the forums, but "5D" brought up just 13 hits from the last 6 years, I'm convinced there must be more posts about 5Ds than that.  ???

Anyway, as the subject says: are Canon 5D Mk3 files fully supported in v4 or do I need to upgrade to v5?

I confess, I'm undecided about upgrading to v5. But I see a Canon 5D Mk3 sometime in my near future so this may be the deciding factor.

Many thanks.

Cheers,
Tony

Offline vAfotoriporter

  • Uber Member
  • ******
  • Posts: 1030
    • View Profile
    • Attila Volgyi photojournalist
Re: Is Canon 5D Mk3 fully supported in v4 or do I need to upgrade to v5?
« Reply #1 on: August 18, 2012, 04:11:10 PM »
The latest V4 upgrade had some improvements for 5Dmk3 support. It is promissed that V4 will not be further developed just minor bugfixes may come out if it is necesary. I don't know if a new camera qualifies as a bug needing a fix.

As I remember PM5 first had some problems with 5D mk3 files like serial number variables didn't work with it....than it got fixed. Now it works just fine.

On the other hand I think PM5 is well worth the price what I already paid for it.
Working on Mac, OSX, iOS and with some Canons.
Allways shooting RAW.

http://www.volgyiattila.com

Offline Tony Hall

  • Member
  • **
  • Posts: 78
    • View Profile
    • Tony Hall Photography
Re: Is Canon 5D Mk3 fully supported in v4 or do I need to upgrade to v5?
« Reply #2 on: August 19, 2012, 04:44:08 AM »
It is promissed that V4 will not be further developed just minor bugfixes may come out if it is necesary. I don't know if a new camera qualifies as a bug needing a fix.
I appreciate that, but when the 5D Mk3 was shipping PM v4 was the only version available (before v5 public betas).

Quote
As I remember PM5 first had some problems with 5D mk3 files like serial number variables didn't work with it....than it got fixed. Now it works just fine.
Good to know, thanks. However, it would be nice to hear from Camerabits that there are no outstanding issues with v4 and 5D Mk3 files.

Quote
On the other hand I think PM5 is well worth the price what I already paid for it.
Excellent. But for me, the new features in v5 are not compelling, I simply don't need them.

A few years ago I'd be all over this upgrade (it provides features I was yearning for), but my work has changed and so has how I use PM. It's now a luxury used as a browser for culling images from a shoot, adding IPTC info, and quickly generating client web galleries. Other software I also own does all this; a bit slower than PM, but $80 buys an awful lot of instant coffee for me to drink while I wait.  :D

I think v5 is an excellent product, and I appreciate all the hard work Camerabits have put into it. It's simply not as essential for me, as it used to be.

Cheers,
Tony

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21973
    • View Profile
    • Camera Bits, Inc.
Re: Is Canon 5D Mk3 fully supported in v4 or do I need to upgrade to v5?
« Reply #3 on: August 19, 2012, 06:35:36 AM »
Tony,

Anyway, as the subject says: are Canon 5D Mk3 files fully supported in v4 or do I need to upgrade to v5?

As far as I know there are no improvements in support for the Canon 5D Mark III in PM 5 over what exists in PM 4.6.9.  I'll have to check with Dennis tomorrow when he gets back into the office to know for sure.

-Kirk

Offline Tony Hall

  • Member
  • **
  • Posts: 78
    • View Profile
    • Tony Hall Photography
Re: Is Canon 5D Mk3 fully supported in v4 or do I need to upgrade to v5?
« Reply #4 on: August 19, 2012, 11:26:13 AM »
As far as I know there are no improvements in support for the Canon 5D Mark III in PM 5 over what exists in PM 4.6.9.  I'll have to check with Dennis tomorrow when he gets back into the office to know for sure.
That would be very much appreciated, thank you.

Cheers,
Tony