Author Topic: Email problem  (Read 5005 times)

Offline randy

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Email problem
« on: August 29, 2012, 12:59:54 PM »
I am not sure if this is a Photo Mechanic problem or a problem with my computer but today I was trying to email photos from Photomechanic on my IMac using Mail and the following message keeps coming up.
There was an error while creating the email via AppleScript. Please make sure your email application is configured properly.
The Console.log has details of the error

Everything worked fine 10 minutes earlier. When I check the message in the console it reads:
12-08-29 1:55:55 PM   Photo Mechanic 5[156]   AppleScript script was:tell application "Microsoft Entourage"
   set subjectVar to ""
   set contentVar to ""
   set unixPath1 to «data utf82F55736572732F72616E647976616E6465727665656E2F4C6962726172792F4361636865732F5068» as Unicode text
   set unixPath2 to «data utf86F746F204D656368616E69632F63616368652F6174746163686D656E74732F3136353735382F4D65» as Unicode text
   set unixPath3 to «data utf87965722066616D696C792D372E6A7067» as Unicode text
   set unixPath to unixPath1 & unixPath2 & unixPath3
   set a0File to (POSIX file unixPath) as alias
   set attachmentsVar to {a0File}
   set newMessage to (make new draft window with properties {subject:subjectvar, content:contentVar, attachment:attachmentsVar})
   tell newMessage
      set send attachments to cc recipients to true
   end tell
   activate
end tell
Any ideas how to fix this. Also is there anyway of using Firefox or a similar program to email the photos rather than Mail that comes on the Mac. Your help is appreciated.
RV

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23542
    • View Profile
    • Camera Bits, Inc.
Re: Email problem
« Reply #1 on: August 29, 2012, 01:42:49 PM »
Randy,

According to that message, you've changed your settings in the Send Photos via email dialog to use Microsoft Entourage instead of Apple Mail.  Try changing your settings.

As for getting PM to control a web browser to send email, I'm not sure that is even possible.

-Kirk

Offline randy

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Re: Email problem
« Reply #2 on: August 29, 2012, 04:16:51 PM »
Thanks for your reply Kirk, unfortunately that is where the problem lies. PM says it is Mail that is the designated email program. It is almost like it is corrupted or something. I have tried selecting something else and then Mail again but that doesn't help neither does turning off PM or the computer. Should I be dumping PM off the computer and trying to reinstall it? Randy

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23542
    • View Profile
    • Camera Bits, Inc.
Re: Email problem
« Reply #3 on: August 29, 2012, 04:20:39 PM »
Randy,

Thanks for your reply Kirk, unfortunately that is where the problem lies. PM says it is Mail that is the designated email program. It is almost like it is corrupted or something. I have tried selecting something else and then Mail again but that doesn't help neither does turning off PM or the computer. Should I be dumping PM off the computer and trying to reinstall it? Randy

I suggest calling our support folks and they'll troubleshoot the issue with you: 503-547-2888

-Kirk

Offline randy

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Re: Email problem
« Reply #4 on: August 29, 2012, 05:07:03 PM »
Thanks I will try calling them tomorrow. Randy

Offline randy

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Re: Email problem
« Reply #5 on: September 05, 2012, 01:44:28 PM »
PM5 on Mac Running 10.6
Still not working so I removed PM5 and reinstalled it. Now it won't even save preferences. Every time I restart PM5 it goes back to default settings. Also when a card has been loaded into a reader half the time PM won't start. The splash screen does not come up and I end up having to shut down and restart the computer.

Offline Brandon

  • Member
  • **
  • Posts: 85
    • View Profile
Re: Email problem
« Reply #6 on: September 05, 2012, 02:13:38 PM »
You might try running the Disk Utility that comes with your Mac. It can be found under Applications -> Utilities

When you open it up you'll need to select your system disk in the left-side menu (should be at the top of the column.) If your machine has multiple hard drives you can find out which one is the current system disk by looking at the Mount Point and verify that it's /

Once you have your disk selected you want to run "Repair Disk Permissions" accessible through the First Aid tab.
Reboot your machine once it has finished and try the operations again.

Offline randy

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Re: Email problem
« Reply #7 on: September 05, 2012, 03:18:23 PM »
Nope. Ran Disk Utilities like you recommended. Still the same problem both for email and for  not saving preferences.

Offline randy

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Re: Email problem
« Reply #8 on: September 05, 2012, 03:32:59 PM »
Just reloaded PM 4.6. It remembers all the preferences and will email out of  Photomechanic.

Offline randy

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Re: Email problem
« Reply #9 on: September 05, 2012, 03:45:37 PM »
Any suggestions on how to uninstall PM5 and any and all  files that may be attached to it from a Mac so I can try fresh without having it revert to something that may still be residing on my computer (Mac. 10.6) Maybe that would help.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 23542
    • View Profile
    • Camera Bits, Inc.
Re: Email problem
« Reply #10 on: September 05, 2012, 05:20:18 PM »
Any suggestions on how to uninstall PM5 and any and all  files that may be attached to it from a Mac so I can try fresh without having it revert to something that may still be residing on my computer (Mac. 10.6) Maybe that would help.

Call Brandon at 503-547-2888 between 9 AM and 5 PM Pacific and he should be able to get your preferences reset and PM 5 installed.

-Kirk