Author Topic: troubles with Lumix files  (Read 3782 times)

Offline platti

  • Full Member
  • ***
  • Posts: 169
    • View Profile
    • my gallery on zenfolio
troubles with Lumix files
« on: August 21, 2012, 07:01:41 AM »
Hi,

when I import rawfiles from my Lumix LX3 ("rw2) into PM5 they show up as usual, but when I send them to CaptureOne or Photoshop CS6, the files are not recognized by the two apps.
When I open them directly from the SDHC-Card in Photoshop, everything works; it is the same, when I copy the files to my hard disk, only when I ingest them by PM5, the files are not readable ...
greets from a hill
my gallery on zenfolio

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21442
    • View Profile
    • Camera Bits, Inc.
Re: troubles with Lumix files
« Reply #1 on: August 21, 2012, 08:55:40 AM »
when I import rawfiles from my Lumix LX3 ("rw2) into PM5 they show up as usual, but when I send them to CaptureOne or Photoshop CS6, the files are not recognized by the two apps.
When I open them directly from the SDHC-Card in Photoshop, everything works; it is the same, when I copy the files to my hard disk, only when I ingest them by PM5, the files are not readable ...

Those two apps probably don't like embedded metadata.  You'll have to use XMP sidecar files for RAW files.

-Kirk

P.S. Someone asked us to enable embedding of IPTC/XMP for RW2 files but apparently it is the cause of the problems.  We'll likely have to turn that feature off.

Offline platti

  • Full Member
  • ***
  • Posts: 169
    • View Profile
    • my gallery on zenfolio
Re: troubles with Lumix files
« Reply #2 on: August 21, 2012, 09:11:02 AM »
Hi Kirk

I always use sidecar files.
What I recognize is: the files within PM don't show any measures like "3968 x 2232" pixels, they show " 0 x 0" ...
greets from a hill
my gallery on zenfolio

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21442
    • View Profile
    • Camera Bits, Inc.
Re: troubles with Lumix files
« Reply #3 on: August 21, 2012, 09:40:37 AM »
I always use sidecar files.
What I recognize is: the files within PM don't show any measures like "3968 x 2232" pixels, they show " 0 x 0" ...

I'd like to see one of your images before and after PM has Ingested it.  So copy an image from your camera card with the OS to your hard drive, and Ingest the images with PM.  Then send me both versions.  Then I can see what the differences are.  Please click on my name to the left of this message, then click on the 'Send PM' link.  I will respond with upload instructions.

Thanks,

-Kirk

Offline msbc

  • Newcomer
  • *
  • Posts: 42
    • View Profile
Re: troubles with Lumix files
« Reply #4 on: August 22, 2012, 02:42:03 AM »

P.S. Someone asked us to enable embedding of IPTC/XMP for RW2 files but apparently it is the cause of the problems.  We'll likely have to turn that feature off.

Kirk,

That was probably me. Please don't just remove the capability. Consider an alternative mechanism to embed the data - I use ExifTool with my RW2's and Photoshop has no problems with them. I have not tried the PM5 version yet, but will shortly and let you know what I find.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21442
    • View Profile
    • Camera Bits, Inc.
Re: troubles with Lumix files
« Reply #5 on: August 22, 2012, 06:41:56 AM »

P.S. Someone asked us to enable embedding of IPTC/XMP for RW2 files but apparently it is the cause of the problems.  We'll likely have to turn that feature off.

Kirk,

That was probably me. Please don't just remove the capability. Consider an alternative mechanism to embed the data - I use ExifTool with my RW2's and Photoshop has no problems with them. I have not tried the PM5 version yet, but will shortly and let you know what I find.

We have to remove it until we can find a way to embed the data that doesn't cause major applications to fail to open those files.  Unfortunately we don't have the engineering resources right now to research a different solution.  If you want to try the current version you had better get it very soon, because we're going to be putting a new build up today that removes the functionality.  The current build will no longer be available.

-Kirk

Offline Franz Dur

  • Newcomer
  • *
  • Posts: 45
    • View Profile
Re: troubles with Lumix files
« Reply #6 on: August 22, 2012, 01:27:17 PM »
Kirk,

Is it in  Version 5 Build 13217 that the handling of metadata in RW2 has been removed?

In which case I won't install it, the fixes it offers are non relevant for me while writing Metadata in the RW2 is a plus.

Like Msbc I use Exiftool to do this at present, and am not an Adobe or Phase One customer, so no problem.

Francis

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21442
    • View Profile
    • Camera Bits, Inc.
Re: troubles with Lumix files
« Reply #7 on: August 22, 2012, 02:03:27 PM »
Francis,

Is it in  Version 5 Build 13217 that the handling of metadata in RW2 has been removed?

That is correct.  I suggest you try a file with embedded metadata with all of the tools you plan to use before you commit to modifying your files.

-Kirk

Offline Franz Dur

  • Newcomer
  • *
  • Posts: 45
    • View Profile
Re: troubles with Lumix files
« Reply #8 on: August 23, 2012, 05:05:41 AM »
Thank  you for the confirmation. I did several test with my present tools (Bibble/APS and IMatch), no problem.

In previous  tests with Exiftool I observed that modifying some tags resulted in the RW2 (and NEF as well) becoming "invisible" to PSE9, Capture One and my usual tools as well. But these tags were EXIF tags, which should not be modified anyway, it was only for the sake of experimenting.

And it was reversible (= clearing the offending tag with Exiftool "restored" the RW2/NEF.

It would be nice if this possibility would be restored in future versions, it would help to unify the workflow with my Nikon and Pana bodies

Francis

Offline msbc

  • Newcomer
  • *
  • Posts: 42
    • View Profile
Re: troubles with Lumix files
« Reply #9 on: September 22, 2012, 08:49:36 PM »
Kirk,

I'd like to request embedding IPTC/XMP for RW2 be re-enabled in PM5.

I have tested build 13158 with RW2 files and Photoshop CS5, Lightroom 4 and Aperture 3.4 all recognise the embedded metadata, and there are no image problems as reported by the original poster.

After re-reading this thread I still don't know why the feature was removed, given the original poster was using sidecars and not embedded metadata.

If you are unable to re-enable this I'd request a refund for my PM5 upgrade as I purchased it with this feature capability and it's vital to my workflow.

Mark