Author Topic: PM5 slow  (Read 3199 times)

Offline bsnead

  • Newcomer
  • *
  • Posts: 11
    • View Profile
PM5 slow
« on: September 19, 2012, 08:00:24 AM »
Hi,

Just upgraded from 4.5.4. and version5 is very, very slow to respond compared with 4.5.4. using same files, back to back launches and comparisons (after experiencing how slow 5 was)

Running Photo Mechanic Version 5.0, build 13217 (68ec133) on iMac 3.06Ghz i3 with OSX 10.6.8, 4GB ram.

PM5 install picked up prefs from 4.5.4, so settings are the same between the two as far as I can tell.

This has been reproduced on 2 iMacs at this point.

Should I be configuring PM5 differently?


Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21337
    • View Profile
    • Camera Bits, Inc.
Re: PM5 slow
« Reply #1 on: September 19, 2012, 08:05:17 AM »
Hi,

Just upgraded from 4.5.4. and version5 is very, very slow to respond compared with 4.5.4. using same files, back to back launches and comparisons (after experiencing how slow 5 was)

Running Photo Mechanic Version 5.0, build 13217 (68ec133) on iMac 3.06Ghz i3 with OSX 10.6.8, 4GB ram.

PM5 install picked up prefs from 4.5.4, so settings are the same between the two as far as I can tell.

This has been reproduced on 2 iMacs at this point.

Should I be configuring PM5 differently?

I suggest going through all of the Preferences panes and checking for things like changes to RAW rendering, sort preference, caching, etc.

-Kirk

Offline bsnead

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Re: PM5 slow
« Reply #2 on: September 19, 2012, 08:24:41 AM »
Hi Kirk,

Yeah, did that - everything's the same.
It seems its the preview pane that's actually slow. Its slow to respond to non-image things too, like resizing windows, sorting menus etc - keep getting the beachball of death. Attached are screenshots of the related prefs between 4 and 5

[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21337
    • View Profile
    • Camera Bits, Inc.
Re: PM5 slow
« Reply #3 on: September 19, 2012, 09:07:05 AM »
Yeah, did that - everything's the same.
It seems its the preview pane that's actually slow. Its slow to respond to non-image things too, like resizing windows, sorting menus etc - keep getting the beachball of death. Attached are screenshots of the related prefs between 4 and 5

Are you browsing RAW photos or JPEGs?

-Kirk

Offline bsnead

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Re: PM5 slow
« Reply #4 on: September 19, 2012, 09:30:05 AM »
Sorry - RAW files. I just checked, and there is less of a speed issue with jpegs (same batch of photos converted to jpegs)

Annnnd - just switched RAW prefs from "render Raw..." to "Use embedded JPEG Preview for speed" and speed now matched the speed for viewing jpegs, which is expected and makes sense.

I just can't figure out why v5 is so much slower at "Render RAW for preview if possible" for me compared to v4.5.4. when in the previewer window, I've nailed down every variable I can think of between the two.
« Last Edit: September 19, 2012, 09:35:17 AM by bsnead »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21337
    • View Profile
    • Camera Bits, Inc.
Re: PM5 slow
« Reply #5 on: September 19, 2012, 10:25:54 AM »
Sorry - RAW files. I just checked, and there is less of a speed issue with jpegs (same batch of photos converted to jpegs)

Annnnd - just switched RAW prefs from "render Raw..." to "Use embedded JPEG Preview for speed" and speed now matched the speed for viewing jpegs, which is expected and makes sense.

I just can't figure out why v5 is so much slower at "Render RAW for preview if possible" for me compared to v4.5.4. when in the previewer window, I've nailed down every variable I can think of between the two.

If your camera is newer than PM 4.5.4 then your camera's RAW files may not have been rendering RAW at all and were always using the embedded previews.  That would certainly account for the speed difference.

-Kirk

Offline bsnead

  • Newcomer
  • *
  • Posts: 11
    • View Profile
Re: PM5 slow
« Reply #6 on: September 19, 2012, 10:55:44 AM »
Hmmm - that could certainly well be. Camera in question for these is a Canon 5DmkII...

Offline patrickhamilton

  • Newcomer
  • *
  • Posts: 28
    • View Profile
Re: PM5 slow
« Reply #7 on: September 19, 2012, 10:20:31 PM »
Kirk,

I'm having the same problem .... when looking a folder of raw files , getting beach ball  all the time . When I try to force quit , I notice that PM is not responding .
I've been trying to edit a large job of raw files containing 4500 files & this problem has been occurring since I downloaded cards .
Beachball happens when ever I swap between say Lightroom & PM

FYI running 3.4 GHz Imac 16 GB ram + 10.8.1

my workflow is slow with this version of PM .... what gives ?
Patrick Hamilton I Photographer I shoephone +61(0)419 683 900 I skype patrickghamilton I www.patrickhamilton.com.au I patrick@patrickhamilton.com.au

Offline AliWalker

  • Newcomer
  • *
  • Posts: 1
    • View Profile
Re: PM5 slow
« Reply #8 on: October 14, 2012, 08:55:02 AM »
I just downloaded the latest version and I'm having difficulties with slowness as described in this thread. When I open the preview pane to tag photos, the application is extremely slow to a) render previews and b) advance to the next frame. The previous version was working beautifully yesterday, so I'm frustrated that this newer version isn't performing up to snuff. Is there any way I can revert to the previous version?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 21337
    • View Profile
    • Camera Bits, Inc.
Re: PM5 slow
« Reply #9 on: October 14, 2012, 02:29:00 PM »
I just downloaded the latest version and I'm having difficulties with slowness as described in this thread. When I open the preview pane to tag photos, the application is extremely slow to a) render previews and b) advance to the next frame. The previous version was working beautifully yesterday, so I'm frustrated that this newer version isn't performing up to snuff. Is there any way I can revert to the previous version?

Sure.  What OS do you run on your computer and what was the version number of your previous Photo Mechanic?

-Kirk

Offline msturk

  • Member
  • **
  • Posts: 63
    • View Profile
Re: PM5 slow
« Reply #10 on: October 14, 2012, 05:26:08 PM »
I was having similar problems with folders taking up to 45 seconds to open. Today I updated my OS from Lion to Mountain Lion OS 10.8.2 and for whatever reason the slowness issue has disappeared. I'm anxious to hear Kirk's take on this.

Offline fearless

  • Newcomer
  • *
  • Posts: 25
    • View Profile
Re: PM5 slow
« Reply #11 on: October 15, 2012, 09:42:10 AM »
just about to upgrade to 5 and checked here first.  I run both Mac and PC.  Will upgrade to Mountain Lion for the Mac but what about Windows 7?  Any issues for anyone?