Author Topic: Virtualization of Photo Mechanic  (Read 1313 times)

Offline wgoodman

  • Newcomer
  • *
  • Posts: 2
    • View Profile
Virtualization of Photo Mechanic
« on: October 15, 2012, 06:49:03 AM »
I am running Photo Mechanic 5, build 13217 on Windows 7 x86 and x64. Our network is moving towards VDI (Virtual Desktop Infrastructure) and we are virtualizing our apps using Microsoft App-V. When I deploy the Virtual Package, the software does not launch and seems to no longer be activated. Has anyone else attempted this or have any ideas of where the license file is located once the software is installed?

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20933
    • View Profile
    • Camera Bits, Inc.
Re: Virtualization of Photo Mechanic
« Reply #1 on: October 15, 2012, 07:02:04 AM »
I am running Photo Mechanic 5, build 13217 on Windows 7 x86 and x64. Our network is moving towards VDI (Virtual Desktop Infrastructure) and we are virtualizing our apps using Microsoft App-V. When I deploy the Virtual Package, the software does not launch and seems to no longer be activated. Has anyone else attempted this or have any ideas of where the license file is located once the software is installed?

I'm confused by the statement "the software does not launch and seems to no longer be activated".  How is it that the software appears to not be activated if it does not launch at all?

The path to the registration file on my system (Win 7, x64) is:

C:\Program Data\Camera Bits, Inc\Photo Mechanic\com.camerabits.PhotoMechanic.XML

The file will not be considered valid if it is moved to a different environment.

-Kirk

Offline wgoodman

  • Newcomer
  • *
  • Posts: 2
    • View Profile
Re: Virtualization of Photo Mechanic
« Reply #2 on: October 17, 2012, 06:46:49 AM »
When launching the software, the intial splash screen comes up, but my registration info is no longer at the bottom of the screen. after that windows goes away, nothing else comes up. That is what I meant by software not launching.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20933
    • View Profile
    • Camera Bits, Inc.
Re: Virtualization of Photo Mechanic
« Reply #3 on: October 17, 2012, 07:16:46 AM »
When launching the software, the intial splash screen comes up, but my registration info is no longer at the bottom of the screen. after that windows goes away, nothing else comes up. That is what I meant by software not launching.

I see.  Well we don't have Microsoft's App-V environment to test on so I don't know how far it is possible to get PM to run on it yet.

Until we can get something going regarding licensing enforcement in a virtual environment (i.e. an organization shouldn't be able to purchase one copy of PM 5 and have hundreds of people use it virtually) then it it probably best that it not work at all for now.

-Kirk