Author Topic: Live Slideshow behaviour  (Read 4736 times)

Offline bazography

  • Full Member
  • ***
  • Posts: 223
    • View Profile
Live Slideshow behaviour
« on: October 29, 2012, 02:37:21 AM »
Intel Mac, OS 10.7.4
PM 5.0, build 13444 (c5a5ad3)

I've just tried using Live Slideshow for the first time, and am using it in conjunction with Live Ingest while tethered to my camera. The Live Ingest destination folder is watched by Live Slideshow, which displays the photos full screen as they are shot. Very cool so far. But I'm wanting the last photo I took to remain on screen until I take the next photo, which I assumed was controlled by deselecting the "Redisplay previously shown photos after __ seconds of inactivity" feature. But either I'm not understanding the intended behaviour of that feature or something is amiss.

If the box is checked, the photos come up on screen as they are shot, then after the selected number seconds the slideshow will start again from the beginning. So far this makes sense. To prevent the slideshow from starting again, I thought I would just need to de-select that option. However, if I uncheck that option, the behaviour is exactly the same... the last image stays on screen for however many seconds were previously entered in the dialog box (even though it is now greyed out) and the slideshow starts again from the beginning.

I've tested this over and over, and the behaviour is exactly the same every time regardless of whether that option is selected, which can't be right, can it? Also, am I correct in thinking that with this box de-selected the last image should remain on screen until a new one is detected?

One other issue I noticed: The forward arrow key works as expected to manually navigate forward through images, but the back arrow key does not navigate correctly. Pressing the back arrow key once goes forward one image, and repeated pressings seems to just go back and forward between 2 images rather than continuing to navigate back as expected.

PS:
Any chance the the "Render Text" option that is already a part of the regular slideshow feature could find its way into the Live Slideshow? It would be very handy for displaying things like frame number and/or shooting data.
« Last Edit: October 29, 2012, 02:49:24 AM by bazography »

Offline bazography

  • Full Member
  • ***
  • Posts: 223
    • View Profile
Re: Live Slideshow behaviour
« Reply #1 on: October 30, 2012, 09:17:14 PM »
Just noticed another problem. The Snapshot feature within Live Slideshow does not work (at least not for me).

Offline bazography

  • Full Member
  • ***
  • Posts: 223
    • View Profile
Re: Live Slideshow behaviour
« Reply #2 on: November 20, 2012, 09:54:31 AM »
... any input on this?...

Offline Bill Kelly

  • Software Developer
  • Camera Bits Staff
  • Full Member
  • *****
  • Posts: 131
    • View Profile
    • Camera Bits, Inc.
Re: Live Slideshow behaviour
« Reply #3 on: November 22, 2012, 01:23:15 AM »
Hi,

Thanks for reporting these bugs. I am able to reproduce the issues here, and they'll be addressed in an upcoming build.

In the meantime, a workaround for the non-functioning "Redisplay previously shown photos after __ seconds of inactivity" checkbox is to enter a very high value for the number of seconds.


Sorry for the inconvenience,

Bill

Offline bazography

  • Full Member
  • ***
  • Posts: 223
    • View Profile
Re: Live Slideshow behaviour
« Reply #4 on: November 22, 2012, 07:22:47 AM »
That's great, thanks!