Author Topic: Color class lost after editing Raw in ACR  (Read 2901 times)

Offline Guido Van Damme

  • Newcomer
  • *
  • Posts: 12
    • View Profile
Color class lost after editing Raw in ACR
« on: February 17, 2013, 01:54:43 AM »
Hi, When I add a color class to a Canon 1Dx CR2 raw file in PM5, edit the file in ACR 7.3 (Photoshop 6), safe the file to either a jpeg or tiff then the color class is lost in both the original raw and is not added to the jpeg/tiff file.
Any idea how to solve this? Is it a PM issue or a ACR issue?
I'm on a intel iMac (2007), Snow Leopard.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20624
    • View Profile
    • Camera Bits, Inc.
Re: Color class lost after editing Raw in ACR
« Reply #1 on: February 17, 2013, 07:02:05 AM »
Hi, When I add a color class to a Canon 1Dx CR2 raw file in PM5, edit the file in ACR 7.3 (Photoshop 6), safe the file to either a jpeg or tiff then the color class is lost in both the original raw and is not added to the jpeg/tiff file.
Any idea how to solve this? Is it a PM issue or a ACR issue?
I'm on a intel iMac (2007), Snow Leopard.

Are you editing directly on your camera card?
Are the images locked in camera?
What build of Photo Mechanic 5 are you using?

-Kirk

Offline Guido Van Damme

  • Newcomer
  • *
  • Posts: 12
    • View Profile
Re: Color class lost after editing Raw in ACR
« Reply #2 on: February 18, 2013, 08:24:09 AM »
Photo Mechanic Version 5.0, build 13645 (f749491)
Images are on my computer and none of them are locked. I transfer the images using  ingest, select and color code the selected images, open them in Photoshop from PM. After the editing is done, the color code is lost when I view the same folder in PM.

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20624
    • View Profile
    • Camera Bits, Inc.
Re: Color class lost after editing Raw in ACR
« Reply #3 on: February 18, 2013, 09:27:50 AM »
Photo Mechanic Version 5.0, build 13645 (f749491)
Images are on my computer and none of them are locked. I transfer the images using  ingest, select and color code the selected images, open them in Photoshop from PM. After the editing is done, the color code is lost when I view the same folder in PM.

Are you using XMP sidecar files?
Are you embedding IPTC into your RAW files?
Are you embedding XMP into your RAW files?

-Kirk

Offline Guido Van Damme

  • Newcomer
  • *
  • Posts: 12
    • View Profile
Re: Color class lost after editing Raw in ACR
« Reply #4 on: February 18, 2013, 10:55:36 AM »
These are my settings.

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2478
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: Color class lost after editing Raw in ACR
« Reply #5 on: February 18, 2013, 11:14:11 AM »
If you change your IPTC/XMP preferences to read XMP first, then then embedded IPTC, that should fix your issue.

HTH,
Hayo
Hayo Baan - Photography
Web: www.hayobaan.nl

Online Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20624
    • View Profile
    • Camera Bits, Inc.
Re: Color class lost after editing Raw in ACR
« Reply #6 on: February 18, 2013, 11:16:32 AM »
OK.  I'd suggest not embedding XMP at all in your RAW files since you're using ACR (or any other Adobe products).  Also, set your read order to XMP Sidecar file first, then embedded XMP.

Try your workflow again with some new images and make sure that things are working correctly.  Then you can go back to the set of images that aren't working correctly and revert the RAW files back to their original un-embedded state.  You can do this with the "Revert TIFF-based RAW to original" command on the Tools menu.

-Kirk

Offline Hayo Baan

  • Uber Member
  • ******
  • Posts: 2478
  • Professional Photographer & Software Developer
    • View Profile
    • Hayo Baan - Photography
Re: Color class lost after editing Raw in ACR
« Reply #7 on: February 18, 2013, 01:53:57 PM »
Kirk is right, of course, you should definitely first read the XMP-sidecar file (should have made that explicit in my earlier answer). If you (also) use Adobe products to edit metadata, Kirk's advice about not embedding the XMP data into your raw files is a good one.

Note: I personally only use Adobe products to edit my images, and perform all my metadata edits with PM (I furthermore generally do not use Adobe for my raw edits) so I do embed the XMP. This works fine too, but in this case you need to be aware of the possible snags, hence Kirk's advice to not use embedded XMP if you (only) use Adobe products.

Anyway, updating your preferences according to the advice should fix your problem.

Hayo Baan - Photography
Web: www.hayobaan.nl

Offline Guido Van Damme

  • Newcomer
  • *
  • Posts: 12
    • View Profile
Re: Color class lost after editing Raw in ACR
« Reply #8 on: February 19, 2013, 04:35:53 AM »
Thanks Guys, will give it a try and will post my results.

Offline Guido Van Damme

  • Newcomer
  • *
  • Posts: 12
    • View Profile
Re: Color class lost after editing Raw in ACR
« Reply #9 on: February 19, 2013, 04:59:18 AM »
Yes!
Problem solved! Color class is not lost and is also added to ACR generated jpegs.
Thanks so much!