Author Topic: Letter Being Appended on Ingest  (Read 3128 times)

Offline rbsandor

  • Full Member
  • ***
  • Posts: 134
    • View Profile
Letter Being Appended on Ingest
« on: March 09, 2013, 01:13:08 PM »
PM V 5 Build 13645 and OS 10.8.2
This morning, after doing a second ingest, I noticed that the second group of ingested photos were being appended with the letter A and restarting with the number 0001 rather than a continuation of the frame number. This is new behavior. This occurred after the card was formatted in camera and with PM being set to Incremental Ingest. My rename ingested photos string ends in {frame4} and hasn't been changed.
Another reformatting in camera and third ingest gave photos being appended with the letter B and once again starting with 0001.
A fourth ingest with a different card yielded a series beginning with 0001C.
The camera/card combo is an Olympus E-M5 and SanDisk Extreme Pro. That combo has not exhibited this behavior previously.
Any ideas? Thanks in advance, Richard

PS I tried to add a screen shot, but once a file was chosen, I wasn't able to find a way to attach it to the post and I get No Files Attached window.
PPS Just looked at my own post and see part of the file appears, but, there's no indication that it has been attached. Not sure what's happening.

[attachment deleted by admin]
« Last Edit: March 09, 2013, 01:59:20 PM by rbsandor »

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20586
    • View Profile
    • Camera Bits, Inc.
Re: Letter Being Appended on Ingest
« Reply #1 on: March 09, 2013, 03:23:04 PM »
Richard,

PM V 5 Build 13645 and OS 10.8.2
This morning, after doing a second ingest, I noticed that the second group of ingested photos were being appended with the letter A and restarting with the number 0001 rather than a continuation of the frame number. This is new behavior. This occurred after the card was formatted in camera and with PM being set to Incremental Ingest. My rename ingested photos string ends in {frame4} and hasn't been changed.
Another reformatting in camera and third ingest gave photos being appended with the letter B and once again starting with 0001.
A fourth ingest with a different card yielded a series beginning with 0001C.
The camera/card combo is an Olympus E-M5 and SanDisk Extreme Pro. That combo has not exhibited this behavior previously.

In the Files section of the Photo Mechanic Preferences dialog what is your "Renaming resolution:" set to?

-Kirk

Offline rbsandor

  • Full Member
  • ***
  • Posts: 134
    • View Profile
Re: Letter Being Appended on Ingest
« Reply #2 on: March 09, 2013, 03:58:22 PM »
Kirk: it's set to Append Letter A B C etc., but these are not files with the same name, these are new files that are shot on a formatted card. I just tried a different camera with the usual and typical result. If shoot #1 ends with frame 0020 and a second shoot is done a formatted card, the second ingest begins with 0021. As I mentioned, this behavior of appending, just started today and continues. Richard

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20586
    • View Profile
    • Camera Bits, Inc.
Re: Letter Being Appended on Ingest
« Reply #3 on: March 09, 2013, 05:07:41 PM »
Richard,

Kirk: it's set to Append Letter A B C etc., but these are not files with the same name, these are new files that are shot on a formatted card. I just tried a different camera with the usual and typical result. If shoot #1 ends with frame 0020 and a second shoot is done a formatted card, the second ingest begins with 0021. As I mentioned, this behavior of appending, just started today and continues.

Look at the card in the Finder.  What do the filenames look like?  If you're using {frame4} in your renaming string and the images are of the form abc_1234.ORF then the frame number should be picked up as 1234.

-Kirk

Offline rbsandor

  • Full Member
  • ***
  • Posts: 134
    • View Profile
Re: Letter Being Appended on Ingest
« Reply #4 on: March 09, 2013, 05:29:23 PM »
Kirk: looked as suggested. There is a folder named 100Olymp with files named 3090001.ORF thru 3090011.ORF. No preceding letters are shown. Doing the same thing with a Nikon shows a folder name of 103ND800 and names _DSC0212.NEF for example. Richard

PS-still not sure what's happening with the attachment option. Once chosen, don't see a way to add to the post.

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20586
    • View Profile
    • Camera Bits, Inc.
Re: Letter Being Appended on Ingest
« Reply #5 on: March 09, 2013, 05:36:47 PM »
Richard,

Kirk: looked as suggested. There is a folder named 100Olymp with files named 3090001.ORF thru 3090011.ORF. No preceding letters are shown. Doing the same thing with a Nikon shows a folder name of 103ND800 and names _DSC0212.NEF for example.

Then the frame numbers of your ORF files are going to be 0001 through 0011 and if files already exist at the destination that have the same names then letters are going to be applied (according to your Renaming resolution settings.)

Now if you format and shoot another dozen photos and then look at the filenames with the finder, are they still in the sequence 0001 through 0012?  If so, then the fault lies with your camera (you can probably tell it not to reset the frame number after it creates a new folder) and not with Photo Mechanic.

Quote from: rbsandor
PS-still not sure what's happening with the attachment option. Once chosen, don't see a way to add to the post.

Let's see if it works for me.  If you see an image at the end of this post then it's working fine.

-Kirk


[attachment deleted by admin]

Offline rbsandor

  • Full Member
  • ***
  • Posts: 134
    • View Profile
Re: Letter Being Appended on Ingest
« Reply #6 on: March 09, 2013, 05:52:24 PM »
Kirk: thanks for the reply. Will try more with the E-M5 tomorrow as too late and two glasses of wine already involved.

Re the attachment option, yes, I see your attachment. So, on my end, once a file is chosen, what's next, i.e. what do I have to do? In preview, once a file has been chosen, all I see is my text, not the file. Richard

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20586
    • View Profile
    • Camera Bits, Inc.
Re: Letter Being Appended on Ingest
« Reply #7 on: March 09, 2013, 05:56:36 PM »
Richard,

Re the attachment option, yes, I see your attachment. So, on my end, once a file is chosen, what's next, i.e. what do I have to do? In preview, once a file has been chosen, all I see is my text, not the file.

I'm not quite sure what you're saying about 'in preview'?  Here are the instructions I tell everyone:  Use the 'Attachments and other options' link when you're composing your reply to this message and there you'll be able to upload your JPEG format screenshot.  So if you're in the Preview application and you pasted your screen shot into one of its windows, you'll save the file as a JPEG and then back in the web browser you'll choose your JPEG file for uploading.

Thanks,

-Kirk

Offline rbsandor

  • Full Member
  • ***
  • Posts: 134
    • View Profile
Re: Letter Being Appended on Ingest
« Reply #8 on: March 09, 2013, 06:27:00 PM »
Kirk: getting closer. When I post a reply, there are two boxes in the lower right corner of the PM Post reply window. One is Post, the other is Preview. I've gone into Attach: Choose File and have done so. The jpeg screen shot appears alongside Choose file as Screen Shot...PM Copy.  Now what? The jpeg has been chosen, but I can't move/paste it into the reply. When I click on the Preview, all I see is text. I'm sure this is really simple, but I can't get there from here. Richard

[attachment deleted by admin]

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20586
    • View Profile
    • Camera Bits, Inc.
Re: Letter Being Appended on Ingest
« Reply #9 on: March 09, 2013, 06:29:49 PM »
Richard,

Kirk: getting closer. When I post a reply, there are two boxes in the lower right corner of the PM Post reply window. One is Post, the other is Preview. I've gone into Attach: Choose File and have done so. The jpeg screen shot appears alongside Choose file as Screen Shot...PM Copy.  Now what? The jpeg has been chosen, but I can't move/paste it into the reply. When I click on the Preview, all I see is text. I'm sure this is really simple, but I can't get there from here.

The forums don't have a WYSIWIG (What you see is what you get) editor.  Your image (or other items you attach) just get appended to the end of the post.  Yours showed up just fine.

-Kirk

Offline rbsandor

  • Full Member
  • ***
  • Posts: 134
    • View Profile
Re: Letter Being Appended on Ingest
« Reply #10 on: March 09, 2013, 06:43:48 PM »
Kirk: Aaargh!! I guess I'm too used to some other sites which show an attachment when Preview is clicked. Thanks for the explanation and get some sleep. Richard

Offline Kirk Baker

  • Senior Software Engineer
  • Camera Bits Staff
  • Superhero Member
  • *****
  • Posts: 20586
    • View Profile
    • Camera Bits, Inc.
Re: Letter Being Appended on Ingest
« Reply #11 on: March 09, 2013, 07:06:55 PM »
Richard,

Kirk: Aaargh!! I guess I'm too used to some other sites which show an attachment when Preview is clicked. Thanks for the explanation and get some sleep. Richard

It's only 7 PM here.  Going to have dinner with my family.

-Kirk